"device not compatible" google play error CM7

Last Updated:

  1. sikk66

    sikk66 Well-Known Member

    Okay, so I've just run into a really annoying problem with CM7. I've been using MTDEV-CM7 since it's creation. Starting yesterday I started getting the "device not compatible" error in the play store when trying to install an app. Then I noticed that nearly every app said it wasn't compatible. Even ones that were already installed on my phone. There have been times in the past that I've come across this before. A reflash always fixed it before...

    Before trying a reflash I tried deleting the google play data, uninstalling updates, and even clearing cache & dalvik cache. All in every combination possible. Still had the issue. So I figured reflashing was in order. I factory reset, wiped cache, wiped dalvik, and and reflashed MTDEV-CM7 10/15. To my shock, I still got the same error on google play. Couldn't install any apps. Still said my device was not compatible. Weird. Thought maybe I didn't clear my caches right or something, so I repeated making sure to factory reset, clear cache, clear david, reflash. Same result. What?? :rolleyes:

    Ok... Really weird. Thought I would flash the 09/26 build and give that a shot. Factory reset, wipe cache, wipe dalvik, flash. Booted this one up. Let play store update. Okay it appeared to fix it. I installed about half of my apps all fresh from the app store. I didn't restore anything from a backup. I thought maybe something in a backup might be causing the error. After about half of my apps were installed I rebooted my phone and went to install the rest of my apps. Now the problem is back. "app not compatible with your device" for nearly every app in the play store. I started over again and reflashed the 09/26 build. Same problem. UGHHH! I also tried to choose the apps in the play store on my desktop browser and have them install to my phone. This didn't work either. Now I'm just at a loss for what to do...

    I am certainly no newbie to flashing these ROM's to my phone. I've literally done i hundreds of times. I've gone back and made sure I was doing each step correctly and reflashed with the results being the same. Now I'm so frustrated I just don't know what to do...

    The gapps I'm using is: gapps-gb-20110828-signed.zip

    Does anyone have any suggestions for me? This is VERY frustrating! :mad:

    treysmith likes this.
  2. bray462

    bray462 Well-Known Member

    Well, I don't have an answer for you, but I did have the exact same experience with CM9. Tried all the things you mentioned. Even flashed CM7 and back to CM9 and no dice. CM7 works perfectly for me though, so I'm on it now until a new version of CM9 is released so I can try again. Weird.
    treysmith likes this.
  3. OverByter

    OverByter Resident Slide Rule Guru

    For whatever reason for the last few weeks or so Google has been having issues with keeping the Triumph authorized on the Play Store, no one seems to really know why.
    treysmith likes this.
  4. Rcarnes91

    Rcarnes91 Well-Known Member

  5. sikk66

    sikk66 Well-Known Member

    It's so frustrating! I'm fighting the urge to smash my phone! There are a lot of things I'd rather being doing on Thanksgiving morning than fighting with my phone.
    treysmith likes this.
  6. sikk66

    sikk66 Well-Known Member

    Oh, I forgot to mention. I have also already tried thunderprop with no success. I literally went through every option that I know of to fix this...
    treysmith likes this.
  7. Rcarnes91

    Rcarnes91 Well-Known Member

    weird, seems like this is happening more and more lately, I have been getting sign in errors a lot recently Maybe our phone is going the way of the crapper
    treysmith likes this.
  8. sikk66

    sikk66 Well-Known Member

    I'm at a loss. For now I just restored one of my backups so that I won't continue fighting with my phone all day and it will be usable.
    But the problem persists...
    If anyone has any ideas please let me know.
    I hope you all have a great Thanksgiving!
    treysmith likes this.
  9. blazo21

    blazo21 Well-Known Member

    I ran into the same problem about a month ago...refer to this thread... " http://androidforums.com/motorola-triumph/645317-playstore-no-longer-supported-mt.html "...
    To fix...download thunderprop and install. reinstall gapps, but force stop in app managment and clear cache and data for playstore and uninstall update first before installing thunderprop and gapps. Also remove motomizer if running (or any screen density adjuster). these interfear with the store to.
    sikk66 and treysmith like this.
  10. MikeRL

    MikeRL Well-Known Member

    I ran into this s problem myself long ago, and it kept popping up. After some Googling, I found out what to do. Clear data for the Play Store and Google Services Framework, stop autosyncing Gmail if it is told to autosync, uninstall any Play Store updates, and reboot your phone. Then, open up the Play Store again and wait for it to update, and everything should be working again. Let me know if that fixes things. :) If what I said doesn't work, try what blazo21 said and see if that works.
    sikk66 and treysmith like this.
  11. treysmith

    treysmith Well-Known Member

    Google device was never compatible with CM7 custom Rom.
    Google Play Service have updated their app for phones running the official 4.0.4 ICS.
    The same thing with Adobe flash player they updated their app for phones running the official 4.0.4 ICS.
    I appreciate devs hard work.
    Thanks devs for making CM9 beta
  12. g60madman

    g60madman Well-Known Member Developer

    I have been using the play store with out any issues. I would recommend doing a full wipe, dalvik and install rom, install gapps and install one app at a time. Should work perfect for you. Backups can lead to many issues, specially when updates are made to the playstore, or other apps.
  13. sikk66

    sikk66 Well-Known Member

    Ok, so it was directly related to me modifying my lcd density. I bought the pro version of lcd density modder from play store(pro version has a play store compatibility fix) and everything works just fine now. blazo21 your post is the one that tipped me off about lcd density. THANK YOU!!!
    Thank you to all of you guys for taking the time to respond to me and try to help me out.
  14. blazo21

    blazo21 Well-Known Member

    Your welcome, I'm glad I could help you. I know how you felt, very frustrating. Enjoy your Thanksgiving.
    sikk66 likes this.
  15. sikk66

    sikk66 Well-Known Member

    Frustrating is an understatement!
    Phew, glad that's over with!
    Happy Thanksgiving everyone!
    Thanks again for your help! :)

Share This Page