Device unrecognized on Win, detected fine on Ubuntu


  1. Azru

    Azru New Member

    Hello everyone.

    For the last couple of days I've been struggling with an issue with my newly bought Nexus One phone and it's driving me crazy. Before I simply give up I decided to ask people way more experienced with the system and smartphones for help.

    Here's the issue: my Nexus One phone once connected to my PC through USB is showing up as unrecognized device. This happens both on my Windows 7 and a fresh install of windows XP. The catch is: the phone is correctly recognized under Ubuntu installed on my computer and on a windows xp install on my brothers laptop. Thus we can rule out a faulty microUSB port and problems with the cable.

    I have thought about a number of reasons why this could happen. I have a pretty old Intel motherboard (Intel DG965SS from '06 I think) and the manufacturer decided not to support it with drivers for Windows 7. Thinking that it might be an issue of the USB drivers being out of date I did a fresh install of Windows XP and got the newest motherboard drivers installed there.

    Another thing I've tried is upgrading BIOS to the newest version provided by Intel, that didn't help either. No settings in BIOS really concerning USB that I could change.

    I've also tried something that worked for a guy having similar issues with his Samsung phone - that is copying registry files from a system which recognized the phone and pasting them to the one that doesn't. That only lead to my windows not booting correctly. Although it is possible that I did that wrong.

    Either way I've run out of ideas and things to try. It would be greatly appreciated if you guys could help provide some feedback and help with this issue. If nothing works I may just use the Ubuntu install for my app development purposes (that's the main reason I got the phone and am so hell-bent on getting it working through USB) but it would be a lot less of a hassle if it could be done under my Windows install.

    Thanks in advance for your help.

    Advertisement
    :
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Have you tried installing the USB drivers for the device?
  3. saptech

    saptech Well-Known Member

    As Digital Controller said, install the drivers for it.

    To most people disbelief, modern Linux comes with more hardware drivers then Windows does. I use a USB ethernet device and no Windows version have drivers by default for it.
  4. Azru

    Azru New Member

    If you guys mean the Google USB drivers then I did download them from the Android SDK manager but I can't really install them. When I try updating the drivers for the Unrecognized USB Device from the Device Manager pointing it to the place where they were downloaded I only get the message that "Windows has determined the driver software for your device is up to date". Which I find
    moderately amusing because upon inspection of said driver it says that "No driver files are required or have been loaded for this device."
Loading...

Share This Page