dgm t-909 tablet


  1. kamdroid123

    kamdroid123 Member

    OK DGM_UK, I tried one more thing. I am using Play Store app version 3.4.7 which came pre-installed on my DGM T-909 and had trouble as in posts above. I downloaded the Google Play Store .apk file from Google Play Store 3.8.17 APK | Full APK Android Apps which lists the version as 3.8.17. This directed me to GeekFiles1.in for the actual download which I did on my desktop PC. I copied/pasted it to the tablet and installed it there. I was prompted and accepted to replace the pre-installed version. I cleared the cache and the data. I tried to download a free app from the store and still got the "never-ending" downloading scroll notification. I then fell back to version 3.4.17 by uninstalling updates and still have the same problem. I see from your posts that you have been successful with your test tablets so could you let us know what version of the Google Play Store you had success with as I am not convinced it is entirely a Google problem otherwise you would not have had success.
  2. DGM_UK

    DGM_UK Member

    Every tablet we have tested we have had no problems with the Play store version we have is 3.8.17 which works fine and when we uninstall the updates it reverts back to 3.5.15 which again works fine. We are still searching for a fix, however one customer has agreed to send theirs to us so we can work on a tablet which actually has the problem and then we can get a fix and issue it so this problem is resolved. We will however keep trying to find a solution, I have emailed Google and hopefully they get back to me shortly in regards to what a potential fix could be.
  3. DGM_UK

    DGM_UK Member

    Can I also ask you to check that your firewall is not blocking the download as this is a potential cause to the problem
  4. J Burlz1

    J Burlz1 New Member

    iv just recieved my t-909 tablet today and im having exactly the same problem. Anyone have any luk with fixing it? I went into apps to uninstall and play isnt even on there yet its on my home screen?
  5. EC13

    EC13 New Member

    In addition to the post above, I have successfully managed to download apps on another device (a Samsung phone) running the same version of Google Play store, so I don't think the problem stems from there.
  6. Pwgwrw11

    Pwgwrw11 New Member

    in addition i too can also download apps from play store on other devices i have at home so i dont think its the firewall,,,but just to check i logged onto my router and turned off the firewall,,but still no luck downloading,,,,:confused:patience waring thin:mad:
  7. smokey1911

    smokey1911 New Member

    I have the same problem. Bough tablet from groupon. Have tried the latest suggestion from dgm to uninstall updates I do not habe option to uninstall updates any joy from anybody else?
  8. DGM_UK

    DGM_UK Member

    We understand this is frustrating and you did not expect to have this problem. We may have narrowed down the problem, from what everyone is saying you have the Play Store icon on the main menu but when you go to apps under settings it is not there? Am I correct in this?
  9. tobydog21

    tobydog21 New Member

    No it is there, the tablet shows that it's going to start downloading, but it never goes past that and does not download a thing, including any updates to apps pre loaded onto the tablet.
  10. wyeres

    wyeres Member

    yes that is correct Toby
  11. wyeres

    wyeres Member

    Thats rich, I have emailed DGM to tell them i am returning the product and want my money back and have been told they will look at it to determine if it is user error and then take it from there!! think they may be suggesting we are all guilty of user error, anyone heard of the distance selling act??? I am fuming!!!
  12. tonyb1973

    tonyb1973 New Member

    is this issue not sorted? these are on sale with groupon NL today, has anyone had any luck with working tabs?
  13. DGM_UK

    DGM_UK Member

    Yes you are correct but the reason behind the downloading error might be this, we know the problem is the downloading but to fix it we need to find out what is wrong within the software. What I posted before has the potential to cause the errors you are experiencing. Refering to my earlier post are correct in saying that under settings and apps the Play Store is not there.
  14. smokey1911

    smokey1911 New Member

    re DGM yes the play store app is there under the all tab
  15. smokey1911

    smokey1911 New Member

    the play store app is there in settings app under the"all" tab
  16. kamdroid123

    kamdroid123 Member

    Hi, DGM_UK, I've just emailed you at meer.sheh@digimate.com (email address in previous post) with a suggestion that I am in the area and prepared to DELIVER the T-909 to your office for you to resolve the issue TODAY.
  17. swimming

    swimming Active Member

    hiya i have sent my back today as i took 3 weeks to get mine,it has been a complete waste of my time ring to see when they was going to deliver, and when recieved dont work. i am not buying another one,i am looking at paying a bit more, eg apple or samsung galaxy.
  18. robertbull

    robertbull New Member

    Ditto, says downloading but does nothing. Please help us
  19. tobydog21

    tobydog21 New Member

    DGM are you trying to screw us... is this tablet even registered with android? i have spoken to them and they tell me that this happens when a tablet has not been registered with them.
  20. Snarf36

    Snarf36 Member

    I am having exactly the same problem with mine that arrived on Monday. Not happy that they sent them out knowing that there are problems. I'll be contacting them to arrange a refund quoting the sale of goods act and distance selling regs. Waste of time.
  21. Shocky

    Shocky Well-Known Member

    I've bought a tablet from them in the past and the quality was very poor for the price, if you can get a refund then do so guys.

    You can pickup the Nexus 7 for
  22. ExtremeNerd

    ExtremeNerd Well-Known Member

    You need to make the play store a system app. Hopefully, this comes with root access.

    If you can use a file explorer, grab the vending.apk and move it to sys/apps. Reboot, and it will be a system app. It should work. Otherwise, you'll have to use adb, which is not my specialty.
  23. hex191

    hex191 New Member

    We also got dgm t-909 tablet from Group-on deal. Wi-fi works and we can downloaded from Play store. Only issue is that some apps states that we can't download due to our country. Any ideas since we are in the UK and can't even download BBC iplayer? Angry Birds doesn't work but STV player downloaded and works ok.
  24. DGM_UK

    DGM_UK Member

    Our product is registered with Android, not doing so would be illegal and we would not sell a product without the correct permissions from the software developer at all.

    hex191: This issue is do to with your ISP as your location is determined from your internet connection, I my self have encountered this problem with my laptop and it is an ISP problem.
  25. Snarf36

    Snarf36 Member

    DGM please confirm that you will issue me with a refund without any quibbles. I emailed the refunds email address you posted but no reply yet.
Loading...

Share This Page