Dialler on Samsung Galaxy S2Support


  1. ThickYorkie

    ThickYorkie Member

    Ok after reading this you may appreciate the user name!

    I've just got the Samsung Galaxy S2, which is about a million miles away from my previous phone. Anyway after playing about with it downloading a few apps today I needed to call someone not on my contact list. So I tap the phone key thinking i'd get a dialler & all I get is a page with 'logs, contacts, favourites & groups' at the top. No doubt I've done something in my attempts to get used to the phone, can anyone help me get a dialler instead of my call logs......?
    Also I missed a call, I think they have left a voicemail message, but when I tap the notification, a box with ' Missing voice mail number. No voice mail number stored on SIM card' & then Add Number. Anyone know what number i add please.......
    All help is much appreciated.

    Advertisement
    :
  2. steslatt

    steslatt Well-Known Member

    If your phone goes into the call logs when you press the phone icon just press the keypad tab in the top left corner and it will display the dialer. Next time you press the phone icon it should come back to this.
    gaby2300 and ThickYorkie like this.
  3. shivram100

    shivram100 Well-Known Member

    Hey Dude,

    Just slide to the left and you get the keypad tab which is now visible, to dial out the number.

    Shivram



    Amber24, kirktonlass and ThickYorkie like this.
  4. xmjox

    xmjox Well-Known Member

    The number will depend on your network's voicemail number. I am on O2 in the UK and the number is 901.

    Once you have found that out, if you go to Settings>Call>Voicemail>Voice mail number you should be able to update it there
    Arch Dandy likes this.
  5. lotus49

    lotus49 Well-Known Member

    If it makes you feel any better, you are at least the fourth person on this forum to have had this problem. I also did but eventually figured it out for myself.

    To all those who disagreed with me when I said that I thought this was very poor UI design - do you still think so when so many people have the same problem and are unable to figure out how to perform a phone's most basic function? :p to you.
    kirktonlass likes this.
  6. andyne

    andyne New Member

    hi, to access keypad press green phone icon . at the top of the screen you will see keypad followed by logs contacts favs and groups . you can slide these to the right or left so if you slid to the left the keypad button will be hidden . simply side it to the right . i had the same problem . i must say this is a great phone .
    soundz and kirktonlass like this.
  7. stugill

    stugill New Member

    OK so everyone now nows the bar slides. Not immediately obvious, agree with you lotus49. Next dialler qustion is how to get the dialler button on the desktop so I dont have to press contacts, slide bar, press dialler.

    Any suggestions. I realise I can download a dialler but I just want the built in one save memory etc.
  8. steslatt

    steslatt Well-Known Member

    Go into your applications drawer, there is an app called "phone" place this on your desktop or in your app dock. I'm pretty sure this is on your app dock as standard though. Maybe I miss read your question?
  9. sandeep108

    sandeep108 Well-Known Member

    Actually one of the two default icons on the bottom are redundant. I have removed the contact icon as I just hit the green phone icon and can get at my contacts by sliding the top bar. The dialler anyway brings up the first name matches as you type.
  10. luckyb52

    luckyb52 New Member

    Thanks a ton for this tip, Shivram. The apparent absence of the keypad tab was driving me mad!
  11. FrenzyNinja

    FrenzyNinja Member

    took me forever to find the dialler xD
  12. gadelkareem

    gadelkareem New Member

    Is there a way to change the long press function on the left button that brings the search to make it bring the keypad instead! I mean it still a phone right! :)
  13. GalaxyS2Kent

    GalaxyS2Kent Well-Known Member

    Ha! I had to take my phone into the store to ask how to ANSWER an incoming call! I kept tapping the incoming call icon only to find out you have to slide it across the screen. Design flaw? It was for me!
  14. Russell Ng

    Russell Ng Well-Known Member

    1) Dial keypad
    Had the same problem originally when couldn't find it. But figured it out when playing around with the phone. When pressing the call icon and msg icon and contact icon, the icons at the top part of the screen seemed to be in different configurations. Then noticed the blue glow at the corner, then figured that you could slide it. But I would rather wished they could fit it into the screen since its just one extra icon, or at least fit it when you turn it into landscape.

    2) Answering calls
    I used the option where you could answer with home button because I kept pressing the green button and it wouldn't answer. Then after I was playing with the contacts and found that sliding left and right allows you to call or msg, figured the principal is the same. Now I use sliding because its so much cooler.
    I don't think this is a design flaw, its just that we were never used to this concept. I think IPhone is the same.

    HEHE :D
  15. kirktonlass

    kirktonlass New Member

    I'm glad to see that I am not the only thicko - I had successfully sorted out emails etc but it was when I was calling my bank to update the insurance on my phone and was told to dial *#06# that I realised I hadn't figured out how to access the dialler as the numbers I had been playing around with were in my contacts list. Thanks to this forum I now have it sussed!
  16. Hawker

    Hawker Well-Known Member

  17. Beaver King

    Beaver King Well-Known Member

    I had this problem too. I spent about an hour on the app market downloading, testing and uninstalling dial pads. Then I saw a faint blue light in the corner of my screen, next tip the logs icon. I thought my phone was the issue. So I tried to wipe tyre screen and hey presto the icons moved and I had a dial pad. I felt like a royal twat. Haha. It is definitely a design flaw. :)
  18. dealman

    dealman Member

    This is a BUG

    Once you figure out the first time then its not a biggie,
    But I Spent 15 minutes trying to figure this.

    Also the two icons on the home screen are redundant. because you really only need one as someone else has pointed out
  19. Russell Ng

    Russell Ng Well-Known Member

    Go to Settings/Manage Applications

    Under the download tab, scroll down until you find skype. Tap on it and choose to clear defaults. The next time you use the dialer, you will have option to set default again. Just set default based on your stock dialer.

    Cheers
  20. gaby2300

    gaby2300 New Member

    I did just that and
Loading...

Share This Page