dialpad doesn't work during callSupport


Last Updated:

  1. gie62001

    gie62001 Well-Known Member

    wow good for you fresh mountain weather better than android world now with google sending C&D letters to some best custom ROM makers and Samsung not willing to cooperate with users of Samsung Galaxy,lol.
    so hope your fresh mind will help us with some issues.
    about the cover you can read thread about battery and firmware some guys even done some small test to prove that camera and i think volume buttons keep phone awake and drains the battery.
    it would be great if we could get donut as well just i guess we'll have to wait for official release.
    thanx KAM for being here and giving us a bit of hope :)

    Advertisement
  2. kam187

    kam187 Well-Known Member

    Hmm really? Its all open source, so what's the problem exactly? Is it so bad that we'll have to start uploading source code and instructions on how to compile it now :-/

    This is why open source for phones will never work properly, the operators always want some control :(
  3. Rastaman-FB

    Rastaman-FB Well-Known Member

    the C&D is cos the cynogen cooked rom gave access to specific apps that by default would normaly be paid for even though cynogen were developed for phones that these apps came with by default (hero, dream)
    basically as its not a "hero" rom and its "cynogen" he doesnt have the right to be including the specific files that were on his rom as the devs did not grant him permission even though its a revamp of the existing rom with added extra's

    i dont think its about developing android roms themselves
  4. kam187

    kam187 Well-Known Member

    ahhh i see. That makes alot more sense. That was inevitable tho. HTC probably arent to impressed that their custom stuff is being copied across devices.
  5. pegasus21

    pegasus21 Well-Known Member

    The apps that caused the C&D were the closed source google apps like market, sync, gmail and a couple more I can't recall atm.

    The reason why they had to send the C&D was because phone manufacturers had to license these apps from google before they can be included in their roms. So if cyanogen was including these apps even phones that did not come with them could have them. Hence google had to protect their copyrights otherwise they can't claim it in the future.

    Some people over at xda decided to start coding open sourced replacements for those closed source apps. So hopefully in the near future it wouldn't be a problem for custom roms to have the full functionally as official roms.
  6. Jabba

    Jabba New Member

    I had the same problem with the dialpad not working while in a call. The first time it came up was about 3 weeks after buying the phone, so I took it back to O2 shop I bought it from (I am in Germany) and they sent it off to Samsung for "repairs". After 4 weeks, I got the phone back and it worked fine again. Then yesterday this problem started coming up again. I was all set to take the phone back down to O2 this evening until I found this thread. Killing the Dialler Storage fixed it for me as well. What I am curious about is:

    1) Turning the phone off and turning it back on never fixed the issue
    2) Doing a factory reset on the phone never fixed the isse

    Why does just killing the app fix the issue, when rebooting the phone doesn't?

    PS: I am using the Samsung Galaxy (i7500).
  7. jfallesen

    jfallesen Member

    Updated to I5 yesterday. First few calls after the upgrade were fine; now the problem is back.

    I am using AnyCut to have a shortcut to dial my mobile parking service directly – I am wondering whether that could trigger the issue to begin with

    Unfortunately, I can't force stop my Dialer Storage process to see if that helps. When I try to, nothing seems to happen. :-(
  8. bitxboi

    bitxboi Well-Known Member

    I can tap and dial during a call, but after the call is finished (prefirably by the other party) the phone doesn't preserve the numbers you dialed, nor you have the option to save it when calling
  9. spottyelephant

    spottyelephant Well-Known Member

    Nothing appears to happen, but if you go and make a call then your dialpad should work.
  10. Cougar

    Cougar Well-Known Member

    I've never had this issue (though to be fair it's not a feature I use regularly).

    From reading here, I'd be tempted to suggest ruling out third party apps before pointing the finger at firmware issues. Use the regular dialer rather than AnyCut, for a start.
  11. qwerty100

    qwerty100 Well-Known Member

    I also have the same issue for the last few days. On/Off does not fix it, How do i stop the "Dialer Storage" process. I cant see it in taskiller??

    Managed to get the dial pad up with the menu button, select the show dialpad option with the navigation keys, and you can then navigate round the keys and press OK as you need. Annoying, but seems to be a workaround.

    However, after having just messed with this and typed it up here (and also deleted all call logs) its now working again!!!

    ??

    Samsung i7500 on O2-UK, FW I7500XXIH6 (eagerly awaiting NPS fix to update...)
  12. talldom

    talldom Member

    As a long term sufferer of this one, I'm keen to get it busted. Its followed me through firmware upgrades from H6 to I5 and through all the intervening versions. Lets have a collective think before I die of frustration.....

    One thing I've noted is during a call to voicemail, after killing the dialler storage. Once you wait so long that the "double tap to unlock" message appears, thats the end of your dialler usage until you kill the process again. I also have very fritzy screen lock behaviour. It locks at random times and always defaults back to the 30 second lock setting. Can it be a coincidence? Do you have this too?

    Another thing that occured to me is that I have a lot of contacts with a lot of info in ~ 1000 contacts including address and job title in a number of cases. Do the other sufferers have similar numbers? What about potentially having some funky formatting in the contacts, I've done a kludgy export from outlook leaving lots of crazy characters in my address book.

    In terms of anycut, I can rule that one out as the problem predates me installing that by weeks. Any other thoughts as to possible contenders?

    apps I run that might use/affect the dialler: spare parts, locale, layar, 0870no, APNdroid

    apps installed since the problem and therefore in the clear: anycut, chompSMS.

    I'm not running ahome or pandahome, or any replacement dialller apps

    Currently have uninstalled locale as a test, any more suggestions?



    -


    if i don't fix it soon I'm going to have to factory reset and see if it goes.
  13. qwerty100

    qwerty100 Well-Known Member

    i also have a lot on info in contacts, and its having all that info syncing so well with the phone has encouraged me to add addresses, DOB, and other info. Could this be it
  14. talldom

    talldom Member

    I also have the same issue for the last few days. On/Off does not fix it, How do i stop the "Dialer Storage" process. I cant see it in taskiller??

    Use settings>applications>Manage applications and browse to Dialler storage. Open it and select "force stop"

    Cheers,
    D
  15. hippy

    hippy Well-Known Member

    I have installed: spare parts, locale and layar and do not have this problem.
    So, maybe try removing 0870no, APNdroid and see if the issue persists?
  16. tulanian

    tulanian Member

    Having the same problem here. with my i7500. The screen stops working completely when in a call. Can't bring up the dialpad with the screen icon at the bottom. Menu->Show dialpad brings it up, but I can't use it by tapping. Have to use the D-pad to navigate. Very annoying.
  17. spottyelephant

    spottyelephant Well-Known Member

    Having not changed anything whatsoever, my dialpad has started working.

    The only thing i can think of that's changed, is that whenever i turn on/boot my phone in the morning, i use advanced task manager to kill all apps so i can start the day fresh. So maybe that's killing some process that makes the dialpad stop working, i dunno, but worth a try for anyone else!
  18. Povester

    Povester Active Member

    I also had this issue, but like spottyelephant my dialpad has started working again and I recently stopped using Advanced Task Manager and returned to TasKiller so would agree that it could be that software affecting the dialpad in the calls. Good spot.
  19. ryko

    ryko Well-Known Member

    I have noticed lately that dialpad was working normaly,and I tend to think also like you that it must have been an app that we may have jointly used and has now been updated. I use taskiller as well and I tried "kill all" on it just now but dialpad still works. Lets hope this bug has been finaly hit on the head ...so to speak :)
  20. tulanian

    tulanian Member

    Hate to throw cold water on this, but it's still not working for me and I've been running Taskiller the entire time--never used Advanced Task Manager.
  21. vit

    vit Member

    I'm on II5, not using any apps mentioned in thread besides Advanced Task Manager (but I don't think it this is a problem) and still having the same problem: just randomly not working dialer while in call.

    I did figure work around thought: instead of using dialer, just long-press menu button to pop-up the keyboard and use number keys to dial tones while in call.
  22. ryko

    ryko Well-Known Member

    Yup, I think I spoke too soon , even noticed that the dialer somtimes reappears during the call.
  23. skandalfo

    skandalfo Active Member

    Another option is to use the menu key, selecting the option to bring the dial pad up, then moving through the focus the buttons using the d-pad (up-down-left-right) and using OK to "push" them...
  24. pdegroote

    pdegroote New Member

    When I want to respond to IVR menu's when in a call I need to use the dialpad to select the proper response. (ie "press 1 for assisstance, 2 for ... etc)
    It used to work until I got hold of a bluetooth headset. If a call is made when the headset is paired, the dialpad can be activated upon which the the screens blacks out and the dialpad is no longer functional in the call. Trying the use the dialpad in-call is from then on impossible untill the phone is switched off and on again. as of then all is functional again until paired with BT headset and a call made...

    Is this a known bug, or just me not using it properly?

    regards
  25. tulanian

    tulanian Member

    I have had great luck with the H8 firmware after doing a factory reset. The dialpad has worked during all my calls after the reset and the battery life is much better. I think the phone is actually sleeping properly now.

Share This Page