Did I mess up my phone for good?Support


Last Updated: 2013-02-23 00:41:30
  1. plaguer

    plaguer Member

    I only recently got around to unlocking and rooting my phone, and it went fine. I had a small problem when trying to do my first custom ROM flash, such as when I tried to boot into recovery it would simply restart my phone. I didn't consider it a problem because I could boot into recovery with my computer, so I just went ahead and flashed.
    Problem is I forgot to do a wipe and factory reset before, and I'm worried if it may be affecting my phone. I flashed CM9 and it's been on the boot screen for about 15 minutes. I tried pulling the battery and restarting, and even tried booting into recovery with my laptop like I used to but it just takes me to the same screen. Should I just try and wait it out, or have I completely messed up?

    Advertisement
  2. adamhos1234

    adamhos1234 Well-Known Member

    Pull the battery, reinstall batt

    Hold vol down and power, that should bring you to boot loader, from there scroll to recovery

    Most non stock based roms require a Change in hboot, which requires s off.
    If you didn't flash lower hboot, that is probably why you can't boot

    Get into recovery and wipe everything but sd and restore your nandroid, or flash a stock base rom
    plaguer and Brian706 like this.
  3. Brian706

    Brian706 Moderator Moderator

    Yep Adam is correct. The reason you were having trouble reaching the bootloader is because on your stock rom, in the settings, there is an option called "enable fastboot" that needs to be unchecked. If it is not unchecked, you need to do a battery pull before trying to boot into the bootloader.

    And also like he said, CM9 requires a downgraded hboot version. I'm assuming you are on the stock hboot (1.57.0000) and have not gained s-off via the wire trick. If you want to flash any non sense based roms, you will need to be s-off first and downgrade your hboot (preferably to Juopunutbear 1.50.5050 patched hboot), which will allow you to flash basically any rom except for stock Ice Cream Sandwich roms.
  4. plaguer

    plaguer Member

    I've pulled the battery and gone into bootloader. From there I've tried recovery and factory reset, my phone simply resets and goes back to the CM9 screen.
  5. Brian706

    Brian706 Moderator Moderator

    Are you using 4ext recovery? Go back into your recovery and go into the tools menu and make sure smart flash is enabled. (This is if you are in 4ext recovery)

    Then wipe everything (except sd card) and then flash a stock based rom that you know works.

    If you are using twrp we will probably have to use the pc and fastboot to get you back up and running.
  6. plaguer

    plaguer Member

    I am using TWRP. I thought I had tried just about everything but I'm hoping not because I still am having problems.

    And to make it better, I let my phone bootloop itself to a dead battery through the night because I was hoping it would pull out and just end up being a long startup. Nope. Now my phone won't charge at all. So to do this I only have a spare battery to use, I hope it makes it~
  7. Brian706

    Brian706 Moderator Moderator

    Okay! I am assuming your phone is still s-on here, so let me know if you are s-off.

    So do you have a backup made from before you tried to flash another rom? What rom were you on before flashing?

    After I get that info we can get out of this :p
  8. plaguer

    plaguer Member

    It is still S-On, I have no idea why I forgot about that before I started doing this.
    I did make a backup right before I flashed. Before this, I had just a stock ROM, as I was just following a guide that led me that way. Had no problems with that one either. If you need a specific name I could look it up.
    Brian706 likes this.
  9. Brian706

    Brian706 Moderator Moderator

    Well first thing I would do is boot into recovery, wipe everything and then choose to restore your backup. Once that finishes, hopefully you'll boot up. If not, we will move onto the next step and flash the boot.img from your backup but that may not be necessary.
    plaguer likes this.
  10. plaguer

    plaguer Member

    I can't remember if I mentioned it in my original post, but I could only boot into recovery via command prompt on my laptop. I didn't think it was a problem, but guess I should have been more worried now that I'm basically locked out of recovery mode.
  11. Brian706

    Brian706 Moderator Moderator

    Even after doing a battery pull and then holding volume down+power it wouldn't go into your bootloader?

    However we get there is fine... If you need to use the pc to get to the bootloader that's fine too.

    adb reboot bootloader

    fastboot boot recovery.img

    After you are up and running, I would highly suggest switching to 4ext recovery, especially if you are s-on. It will save you many headaches while trying to flash roms.
    plaguer likes this.
  12. plaguer

    plaguer Member

    I can enter bootloader with those actions, the thing that worries me is how I press recovery and my phone reboots as though it works, then the CM9 startup screen shows and bootloops me all over again. The same with a factory reset.

    When I try with my laptop, it says the device cannot be found. Probably because I cannot get to my phone settings to enable debugging, which was my problem once before.
  13. Brian706

    Brian706 Moderator Moderator


    If your recovery.img is still in your adb/fastboot folder use the other command I mentioned. Don't select recovery from the bootloader screen. Using fastboot boot will boot the recovery into the phones memory temporarily.
    So after adb reboot bootloader then type fastboot boot recovery.img

    That should boot your recovery and you should be able to restore your backup.

    I need to get a quick bite to eat. Try the above and see if you can get your backup restored. Then I will help you get 4ext recovery when I get back. Should be a half hour or less.
    plaguer likes this.
  14. plaguer

    plaguer Member

    I'm really happy now because your last post helped me make progress to get back to my recovery screen. I wiped everything and flashed the SU zip I originally had on with no problem. Selected to reboot after successful flash. Phone reboots. And there's the CM9 boot screen. So I'm not really sure what to do when factory resets and flashing different ROMs don't get rid of it.

    Take your time, really, I just appreciate the help.

    Edit: I do need to add that when I went to restore my backup, it wasn't there. So that's not really an easy out option anymore, unfortunately.
  15. Brian706

    Brian706 Moderator Moderator

    Okay... So no backup left huh? You will have to flash a rom then. Right now your phone has nothing to boot into. You have wiped all data which means that there is no operating system installed on the phone.

    Flashing superuser is done when there is already a rom installed. It can't do anything on it's own.

    Can you get a file to your sd card? Either with a card reader or another device?

    Here's what we'll do. First go here: Goo.im Downloads - Browsing JmzStockRoms and download the one called "JmzStock_VM_Shooter_Odex.zip".

    Put that on your sd card (in your ROMs folder or wherever you want it).

    Then boot into recovery like we did before:
    adb reboot bootloader

    fastboot boot recovery.img

    wipe everything

    Choose install zip file from sd card

    find that file and install it.

    Then you should hopefully be able to boot up. And I think that already has super user so I don't think you need to flash super user afterward.
    plaguer likes this.
  16. plaguer

    plaguer Member

    That makes sense, then. I had wanted to try out Harmonia before CM9 so that was still on my SD card. I also noticed I can access my phone to put files on when in recovery, so if Harmonia doesn't work I'll just go with your suggestion and try not to mess up again. Thanks so much!

    Edit: The Harmonia ROM is working fine and I can actually get into my phone now. I really appreciate your replies, I can't imagine what more damage I would have done on my own.
    Brian706 likes this.
  17. Brian706

    Brian706 Moderator Moderator

    Harmonia should work fine. It is a stock based rom. So yes, flash that if you'd rather :)

    Then we will install 4ext recovery!
  18. plaguer

    plaguer Member

    I don't think I will be changing anytime soon since I'm kind of terrified now of messing up my phone, but if you have the free time I'd love to hear how to do it.
  19. OverByter

    OverByter Resident Slide Rule Guru

    For everyone else, learn from this gentleman's behavior, it's so much easier to troubleshoot and solve problems when you have a problem that instead of forging blindly ahead that you stop immediately and then ask for help. Makes it a lot simpler instead of digging a deeper hole for yourself. :thumbup: :D
    OB
    Brian706 likes this.
  20. plaguer

    plaguer Member

    I actually think I should have posted on here last night. And since he was nice enough to explain some things to me, I think I can fix it myself next time. Which is much easier on everyone. c:
  21. Brian706

    Brian706 Moderator Moderator

    It's really near impossible to brick this phone. Especially while s-on...

    Installing 4ext recovery is super easy! And will make flashing roms and restoring backups a lot simpler for you.


    Just visit their website: 4EXT Development and download 4ext recovery updater. That is the free version. You can find the paid version in the playstore if you ever want it. It has an app with extra features.

    The actual recovery that comes with the free version is fully functional.

    Anyway, after downloading that app and install it on your phone. Once opening the app choose the online install option. When it asks if your device is s-on make sure to say yes. That will enable the smart flash feature. Just choose install, pick the newest version (at the top) and it will automatically install the recovery for you while the phone is booted up and everything. Doesn't get any easier than that.


    Plus it sounds like you don't have a working recovery right now anyway since you couldn't access it from the bootloader screen. Might as well switch to 4ext if you'd have to re-install twrp anyway!
    plaguer likes this.
  22. plaguer

    plaguer Member

    I'll get right on it. Makes me feel better knowing it's harder to brick this phone. I think my Triumph spoiled me too much, I was used to Gingerbreak and taking the easy way with ROMs and flashing. Thanks again though. n___n
  23. adamhos1234

    adamhos1234 Well-Known Member

    Install 4ext recovery and make a backup now. That way you have something to fall back on.

    Don't let that little scare keep you from flashing. Just pay attention to hboot requirements.

    Right now you are 1.57, so look for those. Roms like mobster, harmonia are stock based so everything works. There are a ton of roms out there and this phone is amazing once you learn a little, through trial and error :-b


    Edit: just read Brian's post above....what he said !
    plaguer likes this.
  24. nsciucco

    nsciucco Well-Known Member

    Live and learn. Trial and error. It is extremely difficult to brick these things. I have had my fair share of mistakes. I learn new stuff everyday. I learned today that you can flash a recovery thru the boot loader if you are s-off

Share This Page