Didn't disable lagfix before install. What do I do?

Last Updated:

  1. klims

    klims New Member

    Hi Guys,

    I got a little too excited when I downloaded a new ROM and tried to flash before I had removed the lagfix. Initially the ROM installed fine but when I tried to apply the lagfix to the new ROM everything fell apart.

    I tried a few things to try and get a new ROM to install but nothing has worked. I have done a factory reset to clear data and wiped the cache but this seems to have made things worse. Before I broke everything I was able to disable the lagfix but now I can't access the lagfix conf file from clockworkmod!

    I am getting the following errors when trying to install new ROM:
    can't chown/mod /data/app operation not permitted

    What have I done? How can I fix it? I want my phone back!! :confused:
    I have read on another post for another phone that I will have to restore using Odin. I can't seem to find any information on restoring to stock for the Galaxy S.

    Any help or advice would be greatly appreciated.


    EDIT: I'm in Australia and the phone was originally locked to the carrier Virgin Mobile.

  2. beer-in-box

    beer-in-box Well-Known Member

    I am not sure, but I will tell anyway. It is up to YOU to try it or not.
    Enter the recovery mode, format your internal sd and flash a new rom.
    I don't think it has to be original, but you can find at samfirmware.com, or something like that.
    Hope tou can have your phone back.
  3. klims

    klims New Member

  4. shaahinjjj

    shaahinjjj Well-Known Member

    me too i forgot to disable the lagfix and everything is screwed now. I even flashed my stock 2.1 firmware with odin, and no luck. I searched all over and im not a noob but i couldnt find any solution for it, thats why i just returned the phone to Bell and theyre gonna fix/replace it for me.

Share This Page