Dim Browser bug fix....General

Last Updated:

  1. sorka

    sorka Well-Known Member

    I haven't opened my S3's yet but was playing with a co-workers tonight and comparing the screen to my DX. We turned auto brightness off in the system settings and turned brightness up to maximum.

    Entered stock browser. Super dim. Went to browser settings and turned auto brightness off and turned it all the way up. Still dim but brighter than before.

    Now the interesting thing is that if you press the home button or menu button, the current page in the browser suddenly gets bright right before exiting or popping up the the menu. This proved to me that it was at least possible to have a much brighter view in the stock browser.

    Next, we downloaded firefox and installed. Did not show the same problem as the stock browser.

    Decided to visit the stock browser settings one more time. In the brightness and color menu, the color profile that was selected was #3, the high power setting. The default one was not selected, so the owner of the phone had changed this at one point. When selecting the default profile, the screen suddenly got very bright and stayed that way even when exiting the settings.

    Note, the browser brightness is not an offset to the system brightness. They are totally independent. If you the system brightness down and the browser brightness up, the screen gets brighter when you enter the browser. If you reverse the settings, the screen gets dimmer when you enter the browser.''

    The bottom line is that with the brightness truly up to max, it still wasn't as bright as the DX, but it was at least 2/3rds of the way there which is pretty darned good for AMOLED.

  2. rushmore

    rushmore Well-Known Member

    Is this the Verizon version? I could not find an option for this. I have posted about the G3 display being dim and gray for whites compared to the Razr. The Razr's brightness and contrast are better at 60% than the G3 at 100%. I was hoping there is some setting I missed, but I did not see a color option in the display settings.

    The only options I could find were autobrightness (turned it off) and dynamic image (turned it off). With those off and a setting to 100% the G3 still was dim compared to the Razr at 60%. Also, the Razr has whites instead of grays like the G3.

    Update: Never mind: Speed reading your post proved fatal, since you point out you are not talking system setting. IMO, the current system settings for contrast is weak on the G3. At least for the one I tested.

    ADDED: I wonder if Screen Adjuster works? It apparently does on the GS2.
  3. Ken7

    Ken7 Well-Known Member

    FWIW, I just tried screen adjuster on my GNex and it doesn't seem to have any effect. The only setting that seemed to work was 'system brightness'. Not sure if that has any relevance to the G3.
  4. sorka

    sorka Well-Known Member

    It was a T-Mobile version. Another co-worker will be in this morning with his vzw GS3. As soon as he gets in(assuming he actually activated it last night), I'll check his browser settings. If the color profile options below the brightness setting are missing, then we'll know this is yet another feature that vzw had removed from the phone, in this case, from the stock browser.
  5. rushmore

    rushmore Well-Known Member

    I did not look in the browser, since the problem stood out in the Play store as well. At 100%, the G3 had grays for white and dim compared to the Razr at 60%. At 100%, the Razr looks like a spotlight in comparison. An obvious overstatement, but point is valid.

    If just looking at the G3, my eyes adjust to it mostly, but stands out profoundly when comparing them. G3 appears to have light grays for whites and this impacts brightness and contrast.

    Again, three other people including the manager noticed this as well, when comparing the devices next to each other and the manager also compared to his Maxx. It was so different, he joked that he would point this out to an employee that had ordered a 16gb.

    Anandtech did not mention this, so maybe a bum unit.....?
  6. sorka

    sorka Well-Known Member

    I think I was pretty clear in my OP that the profile color setting is in the browser brightness setting.

    Yes, this phone will of course be dimmer than an LCD. It's AMOLED. Next to my DX, it's about 2/3rds as bright which.

    This specific thread is for those who have had issues with display being too dim only while in the browser.
  7. rushmore

    rushmore Well-Known Member

    I also still have the Incredible and it is brighter and an amoled tech. I pointed out my failed speed read of your OP.

    Moving along :)
  8. sorka

    sorka Well-Known Member

    Oops. My failed speed read now :)
    rushmore likes this.
  9. JayS3

    JayS3 Well-Known Member

    try turning off power saving mode
  10. Ron H

    Ron H Well-Known Member

    I'm sure I'm just missing this, but how do you get to the stock browser settings?
  11. SUroot

    SUroot Well-Known Member Developer

    The stock Browser has it's own brightness setting but in the latest European release XXBLFB this has been removed so it simply works off system brightness
  12. rushmore

    rushmore Well-Known Member

    I would if had my G3, but appears Best Buy does not have blue 32gb in stock for launch. So much for the preorder premise.
  13. sorka

    sorka Well-Known Member

    We unboxed a new S3 this morning and activated it. The stock browser brightness menu be default is select to profile 3 and *not* default. So on profile 3, your stock browser will be super dim. I find it incredible that it is shipping this way. There will be a lot of people that don't realize there's a separate brightness setting and even fewer who discover setting the color profile from 3 to default will make their display much brighter.
  14. Ron H

    Ron H Well-Known Member

    Where do you find these settings?
  15. sorka

    sorka Well-Known Member

    While in the stock browser, hit menu (left of the home button). Select brightness. Select "default". Should be good to go.
  16. Ron H

    Ron H Well-Known Member

    That's the problem; I had tried that before and the only choices are Settings (which have only "Searchable items" and "Google search"), and Help. There is no Brightness setting.
    Any ideas?
  17. svensett

    svensett Well-Known Member

    Wrong settings. Press the menu button to the left of the home button to bring up the browser settings. Different than pressing "Settings" on the google page.
  18. techgeek32

    techgeek32 Member

    It won't be as bright as the RAZR. Two different screens. The RAZR has an advanced amoled and the sIII does not. No way to make it brighter. It is slightly brighter than my GNex but not my Maxx. I don't use my phone outside too much so won't be an issue for me. If you want bright Verizon is releasing a new LG device in the next week or two that has an HD IPS display at about 500 nits. No penniless and twice as bright as the SIII. Same specs except 4.7 inch display and 1GB RAM. It is LG answer to the SIII.
  19. sorka

    sorka Well-Known Member

    This is a youtub review comparing the S3 with the RAZR. At one point he has both side by side with the stock browser up on the same page and the S3 is much dimmer than the RAZR, but he has the same issue others are having and he has profile 3 set instead of default and doesn't realize it. You can tell because at exactly 4:15 into the video, he presses the home button on the S3 and for a brief moment, the browser is exactly the same brightness as the RAZR for an instant before exiting. He hits menu while in the browser and selects brightness and colors and then selects "default", it will always be that bright and even brighter if he turns auto brightness off, but then we wouldn't be comparing apples to apples.

    Motorola Razr Vs Samsung Galaxy SIII - YouTube
  20. Ron H

    Ron H Well-Known Member

    Thanks. I didn't realize that you had to actually open a page from the Google search results to get that specific menu. Mine was already set at the Default setting, but still dim. I unchecked "Automatic brightness" and manually increased it, and that seems to stay with subsequent searches.

Share This Page