Disable auto-mount SD card when hooking up to PC


Last Updated:

  1. philipwelch4

    philipwelch4 Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    14
    Likes Received:
    0
    I hope this question hasn't been addressed before; I've tried searching google but I may not be searching with the right keywords:

    My Droid (running NexFro 1.01 - about to install BB with NexFro in ~20 mins) has been automatically mounting my SD card to my PC since installing Froyo last Saturday. I didn't have this feature enabled before flashing to Froyo, and I've tried a few roms since Saturday and they all have this feature auto-enabled.

    This normally wouldn't be an issue, but this week I have been traveling with my job and I have been using tethering quite a bit, and would like to be able to charge my phone from my laptop without mounting my SD card every time.

    Is there a way to disable this feature? Also I'm not sure that it is a feature at this point, as I haven't seen any other forum posts about this one any of the Android forums and I can't be the only person who doesn't want this feature enabled by default.

    Sorry for the long-winded post, I have trouble writing anything that isn't a few paragraphs long.

    Thanks in advance!

    --Philip
     

    Advertisement
  2. nstallion

    nstallion Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    1,152
    Likes Received:
    136
    For me it does not automatically mount. I still have "USB Connected. Select to copy files to/from your computer" to mount the SD card up in the notification bar.

    Yours is actually mounting without you telling it to?
     
  3. cookiemonster79

    cookiemonster79 Well-Known Member

    Joined:
    Nov 30, 2009
    Messages:
    80
    Likes Received:
    21
    Do you have doubleTwist installed? It has an option to automatically enable USB drive mode, and it is on by default.
     
  4. bgish3

    bgish3 Well-Known Member

    Joined:
    Nov 8, 2009
    Messages:
    72
    Likes Received:
    0
    hahaha youre a genius i completely forgot i had that app and i had the same question
     
  5. philipwelch4

    philipwelch4 Member This Topic's Starter

    Joined:
    Jun 10, 2010
    Messages:
    14
    Likes Received:
    0
    Problem solved, thanks cookiemonster79.
     
  6. captaincanada84

    captaincanada84 Well-Known Member

    Joined:
    Feb 28, 2010
    Messages:
    99
    Likes Received:
    4
    Yeah I had this same problem and figured out that it was DoubleTwist that was doing it a couple days ago.
     
  7. RocknSteve

    RocknSteve Well-Known Member

    Joined:
    Jan 8, 2010
    Messages:
    93
    Likes Received:
    7
    Dude, seriously. I don't know how to thank you. This problem has been driving me INSANE over the past week. Couldn't figure it out. And here you are, my friggin hero. Lol. Thanks so much!
     
  8. MurrayBowles

    MurrayBowles Member

    Joined:
    Apr 16, 2010
    Messages:
    5
    Likes Received:
    0
    I don't have Double Twist installed, but I still get the "USB Connected" popup. I can touch Back and it goes away without doing a mount, but the popup is still irritating, and I don't find a disable setting in Froyo.
     
  9. valewalker

    valewalker New Member

    Joined:
    Aug 25, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks CookieMonster
     
  10. DroidGnome

    DroidGnome Well-Known Member

    Joined:
    May 25, 2010
    Messages:
    99
    Likes Received:
    19
    Ok in case someone else has this issue and ends up here.. there is another app that has this same 'auto-mount' setting enabled by default: WINAMP (by Nullsoft).

    You might want to check and see if you have WinAMP installed if you have this issue.
     
  11. sigz024

    sigz024 New Member

    Joined:
    Dec 1, 2010
    Messages:
    1
    Likes Received:
    0
    I had both installed, uninstalled doubleTwist and still didn't fix it. WinAMP was the second culprit. Thanks for posting that extra tidbit - it was driving me crazy.

    Edit: just noticed the "thanks" button. Would've been faster than a whole other post. Sorry 'bout that. /blush

    I iz n00b.
     
  12. Amorphis

    Amorphis New Member

    Joined:
    Apr 24, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks DroidGnome , I was about to throw my N1 against the wall .
     
  13. AsadAhmad

    AsadAhmad New Member

    Joined:
    Feb 8, 2013
    Messages:
    1
    Likes Received:
    0
    Problem solved! I mostly charge the phone using the usb cable and this was driving me insane. Not only the time needed for the remounts, there are application compatibility problems as well. Thanks mate!
     
  14. lebac

    lebac New Member

    Joined:
    Jun 3, 2013
    Messages:
    1
    Likes Received:
    0
    If Winamp is your problem, you can still keep it. Just make sure that 'enable auto-mount' option in settings is disabled.
     

Share This Page

Loading...