Disable Automatic Backlight Dimming while ChargingSupport


Last Updated:

  1. DeMiNe0

    DeMiNe0 Active Member This Topic's Starter

    Joined:
    Jun 11, 2010
    Messages:
    30
    Likes Received:
    16
    Hey Everyone,

    I'm running into an issue, that i'm sure many of you have ran into at some point and found a way around.

    When I have my Phone Plugged into the Charger (For example when in my car) after a set amount of time (I think it's around 30 seconds) my screen will Dim to only about 25% brightness(But never shut off completely). As you can imagine, this is horribly inconvenient when I'm running Google maps or sprint navigation.

    How can I make it, so that when I'm charging the phone, the screen just always stays on and does not dim at all? And then when i'm on battery the screen resumes the normal behavior of shutting off after 30 seconds.

    I've tried setting the "Stay Awake" option under "Applications > Development" to on, I've also tried setting the "Automatic Brightness" option under "Sound & Display > Brightness" to off. Neither of these worked.

    The only thing that DOES work, is setting the "Screen Timeout" option under "Sound & Display" to "Never turn Off". But this disables the Automatic Shutoff of the screen even when on battery.

    Anyone have a solution for me? My phone is rooted using Toast's method.
     

    Advertisement
  2. axisofoil

    axisofoil Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    136
    Likes Received:
    19
    it's in development options.

    settings>applications>development>stay awake
    Check that box.
     
  3. DeMiNe0

    DeMiNe0 Active Member This Topic's Starter

    Joined:
    Jun 11, 2010
    Messages:
    30
    Likes Received:
    16
    I just solved this. I used Power Manager from the App market. Does exactly what i need it to do.
     
    iamviveksri likes this.
  4. axisofoil

    axisofoil Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    136
    Likes Received:
    19
    Sorry, must have missed that part. Glad to hear you solved the problem though.
     
  5. chemswede

    chemswede New Member

    Joined:
    Jun 2, 2010
    Messages:
    2
    Likes Received:
    1
    Another Solution that just worked for me that used a free app:


    Download the app "Setting Profiles Lite". Lite is free and only lets you create 1 rule at a time, but multiple profiles (Actions you want it to do when the rule is happening)

    1. Create a profile that simply changes the screen time out to "Screen Never Times out" Save it as whatever name you want.

    2. Create a rule. Under conditions add a condition for Battery that when "plugged into any charger", hit OK. Now add an action to Activate Profile, and choose the profile you made above.

    Bam! When plugged into the charger, the screen timeout goes to never, and the screen stays bright, unplug it and time out goes back to whatever you had it set at!

    I have been using this for about 10 min now so I'm a rookie but it seems to be working! Make sure if you screw around in it that you don't accidentally disable the rule (I did that because I tried to make another and the Lite won't let you make 2 rules, and it disabled the first one. Just had to long press to enable it again).
     
    iamviveksri likes this.

Share This Page

Loading...