1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Disable Backup Assistant?Support


  1. StaggerLee

    StaggerLee Well-Known Member

    Does anyone know how to disable Backup Assistant? The "disable" option is greyed out.

    Advertisement
    :
  2. Adara

    Adara Well-Known Member

    I realize this isn't a very good answer, but:

    1. I think it can't be done. But it doesn't seem to be using a heap of processor time, so no big deal.

    2. You can, at least, make it stop doing whatever it's trying to do. (In Settings > Accounts > Backup Assistant Plus, you may find that yours is set to back something up. I discovered that mine was set to backup my contacts, when I don't recall ever asking it to do.)

    3. You can get rid of it from the VZW end. Which is to say, you can log on to your account at Verizonwireless.com and eliminate Backup Assistant Plus as a feature on your account, although the app will remain on your phone. (I was forced to do this in the middle of Heathrow airport because, upon my previous phone's arrival in another country, it decided to send me very annoying alphanumeric text messages, which were somehow related to Backup Assistant and the stock email program. I never did figure out exactly what was going on, but getting backup assistant off my account stopped the problem. The whole process ended up killing my stock email, though, so use with caution. I switched to K-9 mail and never looked back.)

    Sigh. It's crap like this which makes me think I should have waited and ponied up the cash for the Google Edition of this phone. But I grit my teeth and accept that I'm just stuck with VZW bloat for the next two years.
  3. StaggerLee

    StaggerLee Well-Known Member

    Actually, its a great response. This is the first phone I have not been able to disable this junk.
    Stupid question time...Where on my verizon wireless account would I find the option?
  4. Adara

    Adara Well-Known Member

    I believe it's under "change features" or something like that.
  5. StaggerLee

    StaggerLee Well-Known Member

    Much appreciated.
  6. Podivin

    Podivin VIP Member VIP Member

    I presume you already know this, and choose not to do it, but rooting and running a custom ROM will get rid of the bloat. I realize though that doing this is not for everyone.
  7. Adara

    Adara Well-Known Member

    You're right; I probably should. On several occasions, I've seriously considered pulling the trigger on rooting, but then I hear about someone bricking their phone and wuss out. (Sooner or later I'll probably do it -- someone in these forums did the internet equivalent of holding my hand when I flashed ICS on my Bionic, and the world did not, in fact, come to an end.)
  8. WalkaboutDavid

    WalkaboutDavid Well-Known Member

    There is no way to disable it. However, if you click on "clear data" it will never run again and won't use any resources (Other than storage). You won't even know it is there.
  9. Adara

    Adara Well-Known Member

    I feel the need to add to this discussion based on the bizarre behavior I got out of backup assistant while I was abroad. (Why does it always mess with me when I'm paying by the MB?)

    OK, keep in mind that, because I was using international data, I didn't want my phone using any data unnecessarily. So, in Settings>data usage, I'd hit the settings button again and checked the box for "Restrict background data." I had also unchecked "Auto sync data." My plan was pretty much to turn on data every now and then, sync my mail (and whatever else I wanted to sync), and then turn off data.

    One day, while doing this, I kept getting an icon for an attempted (and failed) backup assistant backup. Specifically (when I'd pull down the icon to see what it was complaining about), backup assistant was trying to backup my contacts. This seemed odd as, under Settings>Accounts>Backup Assistant Plus, I had "Sync Contacts" unchecked. And, indeed, if I used that path to GO to Backup Assistant Plus, "Sync Contacts" was, in fact, unchecked. But when I pulled down the icon for the failed sync, it showed me a Backup Assistant settings screen where Sync Contacts not only was checked, but was greyed out so it could not be unchecked. Weird.

    Recalling WalkaboutDavid's post from this thread, I cleared data from the Backup Assistant App, but no joy. The damn thing kept trying to backup my contacts. Eventually, the problem was solved by the (standard) solution of turning the phone off and on again.

    Bottom line: no real harm. And it was probably some sort of fluke. But I do wonder where an app gets off trying to sync my contacts when: (1) I have specifically set it not to sync my contacts; and (2) I've specifically told it to restrict background data and NOT Auto Sync ANY data. Seriously, is Backup Assistant so powerful that it can OVERRIDE a "don't autosync anything" command? (One also wonders why Verizon would force such a POS app on its subscribers, and particularly why it thinks anyone with an Android phone would need its crappy app to backup contacts, seeing as google does this anyway.)

    (I guess this is just another rant.)
    Colchicine likes this.
  10. Colchicine

    Colchicine Well-Known Member

    As simple as this is, and despite having watched all of the IT Crowd, I still didn't think to do this and it fixed my problem.
    I have been getting poor battery life since the update, so I did a Factory Reset yesterday in hopes of resolving it.
  11. Rainbow2K

    Rainbow2K New Member

    On my Samsung Galaxy S4 I tried all of the above short of rooting and still Backup Assistant Plus kept trying (and failing) to sync. By chance I found another app to kill and finally solved the problem. Go to application manager from the settings menu and view the list of all apps. Find Sync Service, which has an icon very similar to Backup Assistant Plus. Clear data and cache and turn it OFF! Since doing this yesterday all the failed sync notifications have stopped! Hopefully this will help someone else too.
Loading...

Share This Page