1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Disable Lock Screen when at home?


  1. Ghost10bxl

    Ghost10bxl Well-Known Member

    OKay, after searching for more than an hour, I frustratingly came here to ask this. I would like Tasker to disable my pattern lock when I'm at home i.e when connected to my home Wi-Fi .

    This is what I tried:
    Context: State --> WiFi connected --> Chose my home one
    Task: Display --> Keyguard --> Off

    It worked for few minutes, I tried it few times and worked. Then it stopped so i searched and people and Wikidot something had an article on it.

    So I used Secure Settings
    Context: State --> WiFi connected --> Chose my home one
    Task: Plugin --> SS --> Keyguard Off

    Again it worked for few minutes, I tried it a few times and worked then it stopped working.

    I also tried WiFi Near but that doesn't work either

    So please help?

    Advertisement
  2. electricpete

    electricpete Well-Known Member

    I assume by "doesn't work" that you're at home connected and kg engages.

    I'd do some troubleshooting when that happens:
    Does the profile show as active (not just enabled but active). If so it'll show up green in tasker.
    If profile not active, examine %wifii to see if it thinks your connected.
    If not connected, you intermittently lost wifi
    If you are intermittently losing connectivity, you might also notice some page load errors in your web browser.
    The above troubleshoots in case you're having a problem sensning wifi.

    Also, some of the ways to adjust keyguard are a little flakey. It also varies by operating system as I remember. Flakier in the more recent versions like ICS, JB. Tell us about your phone / operating system.
  3. PthPndr

    PthPndr Member

    I am having the same issue and have also tried the two ways you mentioned.
    My profile is enabled and active but the lockscreen still won't won't disable.

    I am trying this on both a Nexus 7 running JB 4.2.2 and a Samsung Galaxy SIII running JB 4.1.1.
  4. SUroot

    SUroot Well-Known Member Developer

    For you, this is quite a simple fix. You're looking at Actions > Keygaurd in secure settings where as you need to be looking at Root Actions > Pattern Lock


    Pattern Lock is unfortunately, something that really needs root to control.
    Ghost10bxl and silentwitness like this.
  5. Ghost10bxl

    Ghost10bxl Well-Known Member

  6. SUroot

    SUroot Well-Known Member Developer

    Ah ok.

    S3 has many issues with pattern without root. Most notably the issue you have. It works for an extreme minority. I was one of those who needed root.
  7. Ghost10bxl

    Ghost10bxl Well-Known Member

    I might root again because I like root features but with TouchWiz and anyway I need it to use Triangle Away :)
  8. SUroot

    SUroot Well-Known Member Developer

    IMHO the touchwiz roms are better
  9. Mehta23

    Mehta23 Guides Guide

    I remember using an app that does exactly what is required in the OP. Problem is i cant remember what it was called
  10. Ghost10bxl

    Ghost10bxl Well-Known Member


    I may try Wanam because I wasn't happy with Omega
  11. oOMavrikOo

    oOMavrikOo Well-Known Member

    Will the pattern lock option work for the standard slider lock screen as well? I would like to disable my lock screen at home too.
  12. SUroot

    SUroot Well-Known Member Developer

    Pattern is for pattern only. Do you.have a slider and a pattern?

    I use a 3rd party lock screen so I'm not sure
  13. oOMavrikOo

    oOMavrikOo Well-Known Member

    Just slider. I WOULD use a third party one but no matter what I do to disable notifications over the lock screen, nothing ever works. It usually works for a while then I start seeing notifications when I press the power button. No application can seem to remedy this.
  14. Ghost10bxl

    Ghost10bxl Well-Known Member

    Hey SU I rooted my phone again (I missed the features but I still want stock TouchWiz so no ROM). So please explain this method. I tried but it does not work with PIN lock or Pattern Lock. What do I do?
  15. SUroot

    SUroot Well-Known Member Developer

    define "does not work"

    please export your profile.

    There are touchwiz roms available.
  16. cohoman

    cohoman New Member

    I also would love to get this working on my HTC EVO LTE. I've tried similar profiles as mentioned here, but I can't seem to disable the phone's PIN lock using Tasker. I've tried using the Secure Settings plugin also, but my phone will lock itself when it should have been disabled. I'm trying to have the PIN lock disabled when I'm home or in my car (connected via Bluetooth) and have the PIN lock enabled in all other instances.

    Any help would be appreciated! Thanks.
  17. cdikland

    cdikland Member

    My rooted Galaxy S3 worked everytime using the following:

    Context: State --> WiFi connected --> *myrouters1*/*myrouter2*
    Task: Secure settings -> Clear password

    Exit Task: Secure Settings Set Pin
  18. Scootmien

    Scootmien Well-Known Member Contributor

    Ucla74 and Pinmac1 like this.
  19. bruce73

    bruce73 Well-Known Member

    I have something similar but using Wifi Near (my home SSID) , so that I don't have to leave WiFi on all the time when the phone is off .
  20. electricpete

    electricpete Well-Known Member

    May I suggest a possible enhancement (depending on your preference)?
    Get rid of the enter task (for example just use stop instead). Then you will have to log in once after you get home (unfortunately). The advantage is that if you lose you're phone while away from home, the person who finds it won't be able to simply bring it to your doorstep to unlock. It's probably a very unlikely senario, but I like the peace of mind from knowing i'm protected from that scenario.
  21. cdr22

    cdr22 New Member

    I used the same thing and had the same problem. However, I added an exit statement to turn keyguard on and it seems to work now. Hope that helps!
  22. Methos1979

    Methos1979 Well-Known Member

    I struggled with this for a while too but it seems to be working right now. I'm rooted, Secure Settings and Helper installed, JB 4.1.2, RAZR HD MAXX using the following (I use pattern lock, btw):

    Profile: Keyguard

    Context: Wifi Near: NetgearXX (wifi name), *,*, 0,0, Off

    Task: Secure Settings: Pattern Lock Disabled, Secure Settings: Keyguard Disabled

    Exit Task: Secure Settings: Keyguard Enabled, Secure Settings: Pattern Lock Enabled

    The only thing I still have to do is the first time I leave the vicinity of my wife the keyguard is still not enabled. But after turning the screen on one time it then enables keyguard and patter lock. I'm pleased.
  23. Ghost10bxl

    Ghost10bxl Well-Known Member

    Is it possible to have the Swipe Screen lock as well as the password lock? Automated? You can do that with normal settings but I'm talking about when I'm out
  24. KitWasHere

    KitWasHere Well-Known Member

    That's how I have my phone set. With "Secure Settings" I toggle the patter lock, which has it set for the swipe lock screen at home, and pattern lock everywhere else
  25. Ghost10bxl

    Ghost10bxl Well-Known Member

    I think you didn't get what I mean. I want swipe and pin to work at the same time when I'm out. Swipe works perfectly at home but I want it to work as well as the pin.

Share This Page