disable signal dropped sound ?Support


  1. gkak

    gkak Well-Known Member

    not sure if solution would need root...
    is there a way to disable the signal dropped notification sound without having to turn off all notification sounds? I don't want to turn notification volume down because I want to be notified of texts but I don't need my phone "doo-doo-doo"ing every time I go into an elevator or to the basement at work.

    Advertisement
    mydian and Loota like this.
  2. Loota

    Loota Well-Known Member

    Yeah this is a huge pet peeve off mine...

    Sent from my SPH-M930BST using Tapatalk 2 Beta-6
  3. mydian

    mydian Well-Known Member

    I'm interested in this to. It happens to me every day on my way 2 and from work, or when I'm in a store. Everytime I hear it I think about how much I miss AT&T, except for the bill lol.
  4. Loota

    Loota Well-Known Member

    Mydian you're in no place to ask for anything until you put your androidify avatar back on!
    mydian likes this.
  5. mydian

    mydian Well-Known Member

    LOL done.
  6. Loota

    Loota Well-Known Member

    That's better!

    Sent from my SPH-M930BST using Tapatalk 2
  7. gkak

    gkak Well-Known Member

    maybe if someone knows the name of the sound file and where it is located we can delete it or replace it with a blank sound file
  8. Loota

    Loota Well-Known Member

    Did some research on this, I think we should logcat and lose service to see what is triggering it... gonna go try wrapping my phone in foil to see if it will make it lose signal...
    mydian and gkak like this.
  9. Loota

    Loota Well-Known Member

    It looks like dm app is what handles the phone service state...

    http://pastebin.com/d0kDk9Up

    Gonna see if I can find more info on this..

    Sent from my SPH-M930BST using Tapatalk 2
    mydian and gkak like this.
  10. gkak

    gkak Well-Known Member

    system/media/sound has a ui folder with ogg sound files for stuff like charger connecting. but of course not the signal dropped notification... that would make it too easy. I'm assuming if u create a blank ogg file (just record nothing and convert the sound file to ogg) and rename it chargerconnect.ogg and swap it with the one in ui folder that it would be played whenever charger is connnected. so probably same can be done if notification sound file for system dropped is found. I looked everywhere and I can't find it. but I'm just a noob that screwed around with qbasic and fortran in highschool...
  11. Has anyone figured this out fully yet. It's rather annoying as I work in an area that has ZERO coverage by boost Mobile, and even turning notification sounds off, while I am listening to music I still get a notification warning, but instead of a beep it simply cuts out the music. I am new to the Android OS, so I may need instrustions for dummies if there is a solution.
  12. Loota

    Loota Well-Known Member

    No solution yet.. but do what I do and turn on airplane mode if you know you aren't gonna have service for an extended period of time.. it'll save you A LOT of battery too..
  13. tobanrob

    tobanrob Well-Known Member Contributor

    i think i found a solution. at least it seems to be working so far.

    using holo launcher long press on an empty spot on screen and tap shortcut.

    then tap Activites

    then tap phone icon. it was the first one for me.

    then scroll down to Roaming. there's 3 of them. Tap the third one.

    now click the shortcut. i unchecked everything in that menu. i doubt the internation ones have anything to do with but i will experiment with it eventually.

    u can use adw launcher as well. has a similar method to do the same thing if i remember right.

    can't find a way on go launcher but i used holo launcher then went back to go launcher and even had holo launcher frozen and still no annoying call drop sound!!!

    hope it works and it wasn't a fluke.
    gkak and mydian like this.
  14. tobanrob

    tobanrob Well-Known Member Contributor

    mydian likes this.
  15. j61101

    j61101 Well-Known Member

    just to be sure, this wont work with boost will it? I dont think boost customers have the option to roam.
  16. tobanrob

    tobanrob Well-Known Member Contributor

    i'm on boost and i can get to the roaming options using the tricks posted above.
    mydian likes this.
  17. mydian

    mydian Well-Known Member

    Thanks for posting this! I made an activity shortcut to the roaming options and turned off roaming guard and no more dropped signal sound! I'll have to test it some more but just left a grocery store where I always have no service and it never annoyed me once. I also spent an hour screwing around with my phone getting into all kinds of menus I never knew about. APN settings, app usage stats, networks settings, etc. It's very cool. Thanks again!

    I'm on Boost btw, Android 2.3.4 using Xperia Launcher.
  18. tobanrob

    tobanrob Well-Known Member Contributor

    glad its working for other people too!!!
  19. gkak

    gkak Well-Known Member


    works great thanx! boost with adw ex...
  20. tobanrob

    tobanrob Well-Known Member Contributor

    awesome. thanks for thanks!

    something else i did was using Rom Toolbox i used its App Manager, swiped over to All Apps and long pressed on Phone.apk which was the first one for me and unchecked DataRoamingGuard and RoamingGuard.

Share This Page