Disabling the stock Android media playerSupport


Last Updated:

  1. MadFlava

    MadFlava Active Member This Topic's Starter

    Joined:
    Nov 2, 2009
    Messages:
    36
    Likes Received:
    2
    Anyone know of a widget or app or something that will disable the stock music player? Nothing is worse than starting the car and the phone immediately hijacking the audio and starting to play a ringtone or something.

    The stock media player is awful. I hope they have something better in the works.
     

    Advertisement
  2. SnotF

    SnotF Well-Known Member

    Joined:
    Feb 5, 2010
    Messages:
    454
    Likes Received:
    12
    Since it manages your ringtones and notifications, I'd assume completely disabling the thing would be a BAD idea ;)
     
  3. MadFlava

    MadFlava Active Member This Topic's Starter

    Joined:
    Nov 2, 2009
    Messages:
    36
    Likes Received:
    2
    I guess so.. Id be happy just being able to stop it from auto-starting every time bluetooth connects. Guess Im stuck until Google decides to actually offer some settings for the player.
     
  4. SnotF

    SnotF Well-Known Member

    Joined:
    Feb 5, 2010
    Messages:
    454
    Likes Received:
    12
    I would start by killing that Bluetooth. Leaving it on all the time ia a huge battery drain anyways. If you need it that badly, get a Bluetooth on/off switch widget from the app store.
     
  5. Buck Shot

    Buck Shot Well-Known Member

    Joined:
    Jan 13, 2010
    Messages:
    211
    Likes Received:
    11

    when u plug it into an aux port it automatically starts as well.
     
  6. ztmike

    ztmike Well-Known Member

    Joined:
    Feb 3, 2010
    Messages:
    138
    Likes Received:
    2
    Um..the Nexus has a bluetooth on/off button. Why would you download another one?
     
  7. MadFlava

    MadFlava Active Member This Topic's Starter

    Joined:
    Nov 2, 2009
    Messages:
    36
    Likes Received:
    2
    I use BT to stream Slacker so I really dont want to disable it. I just dont want music to start playing as soon as it connects to BT because I have two streams going and have to stop and turn off the stock media player.
     
  8. Buck Shot

    Buck Shot Well-Known Member

    Joined:
    Jan 13, 2010
    Messages:
    211
    Likes Received:
    11

    i never understood why people DL seperate switches, but to each their own. N1 has that stock bar with every switch u need IMO
     
  9. SnotF

    SnotF Well-Known Member

    Joined:
    Feb 5, 2010
    Messages:
    454
    Likes Received:
    12

    for convenience. instead of navigating through like four menus to get to the bluetooth on/off option, or putting it in airplane mode(i'm running sense so i don't remember how many button presses it really is), you can simply put a widget on your home screen adn flip a "switch that emulates that code.
     
  10. brokeoutangel

    brokeoutangel Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    60
    Likes Received:
    33
    Not to hijack the thread but..
    v2.0 comes stock with a widget that has on screen control for BT,wifi,sync, GPS (that actaully toggles rather than linking) and screen. Airplane mode is via a long pres on the power button on the N1
     
  11. gadzooks64

    gadzooks64 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    84
    Likes Received:
    12
    I have an Incredible that does the same thing.

    Hugely annoying to connect to my car's BT so I can listen to a podcast and have some song fire up in the player.

    Anybody figure this out yet?
     
  12. mudrock1000

    mudrock1000 Well-Known Member

    Joined:
    Jan 9, 2010
    Messages:
    288
    Likes Received:
    13
    Well isnt there a setting for that in the music player settings? if there IS not settings (it might be while the song is playing) Check the actual settings. When my nexus was on the stock ROM mine never did that. And answer to the rings problem is Rings Extended
     
  13. Schwin97

    Schwin97 Well-Known Member

    Joined:
    Apr 6, 2010
    Messages:
    170
    Likes Received:
    12
    Sounds like someone clicked a default setting to start playing music on bluetooth connect... Doesn't happen on my nexus one - my problem is actually getting my music to play through bluetooth when it is already connected.?
     
  14. cigar3tte

    cigar3tte Well-Known Member

    Joined:
    Nov 4, 2009
    Messages:
    267
    Likes Received:
    14
    Sounds like a settings problem. Mine doesn't automatically play music on BT nor AUX when connected.
     
  15. Teknologic

    Teknologic Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    969
    Likes Received:
    93
    Mine used to, but it doesn't anymore.. don't know what fixed it.
    I use a different media player then stock so what I did is load a 1sec silent audio file onto my SD and put it as a playlist on my stock media player. So every time I plugged it into AUX in my car, instead of blasting a second song through my speakers it just started playing a 1 sec silent loop (it also used to restart randomly when a minor vibration would hit my audio plug).
    But like a week after using this fix, the stock media player stopped opening on it's own.. now all is well.

    Question: Would uninstalling the stock media player (root) kill my ringtones and such?
     
  16. badger98

    badger98 New Member

    Joined:
    Feb 2, 2010
    Messages:
    4
    Likes Received:
    0
    I seem to remember having this problem on my first Droid, but only for a short while after I first got it. I used it for over 6 months without it happening. Now I have the Droid 2 and the problem is back. It just dawned on me what the difference was. I was running Advanced Task Killer on the old Droid and I know for a fact I allowed it to actively kill the Music application and ignore ACast (the only audio source I use). Thus, when the bluetooth connection was made, the only running audio app was ACast, and it would start.

    Not sure I want to start using a task killer on the Droid 2, but I'm seriously considering it as a workaround to this hugely annoying, and as yet unresolved, issue.
     

Share This Page

Loading...