DNS not working while tethering with mobile hotspotSupport


  1. uofitorn

    uofitorn New Member

    Hi all,
    I have Verizon and a new Samsung Galaxy S4. My laptop can connect to my S4 via mobile hotspot just fine. I'm assigned an IP address and I can ping the gateway. However, DNS is not working at all. So I'm unable to access websites by name. I can access websites if I use the IP address directly. Likewise, I can ping hosts fine if I use the IP address but I can't if I use the hostname.

    I tried manually setting my DNS servers to Google's DNS servers in my wireless adapter settings, however, the connection appears not to honor those settings.

    If I do an nslookup while connected to the hotspot, it uses the configured gateway address as the dns server:

    C:\Users\pzurek>nslookup Yahoo!
    Server: UnKnown
    Address: 192.168.43.1

    *** UnKnown can't find Yahoo! No response from server

    C:\Users\pzurek>ipconfig
    Wireless LAN adapter Wi-Fi:

    Connection-specific DNS Suffix . :
    IPv6 Address. . . . . . . . . . . : 2600:100e:b004:fc2f:2565:5146:c809:129c
    Temporary IPv6 Address. . . . . . : 2600:100e:b004:fc2f:e897:6468:d765:c2
    Link-local IPv6 Address . . . . . : fe80::2565:5146:c809:129c%12
    IPv4 Address. . . . . . . . . . . : 192.168.43.99
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : fe80::ce3a:61ff:feb0:1808%12
    192.168.43.1


    When I'm connected to my home wireless lan it uses Google's DNS server as expected:

    C:\Users\pzurek>nslookup Yahoo!
    Server: google-public-dns-a.google.com
    Address: 8.8.8.8

    Non-authoritative answer:
    Name: ds-any-fp3-real.wa1.b.yahoo.com
    Addresses: 2001:4998:f00d:1fe::3000
    2001:4998:44:4::c:9101
    2001:4998:44:4::c:9102
    2001:4998:f00d:1fe::3001
    98.139.183.24
    98.138.252.30
    98.139.180.149
    98.138.253.109
    Aliases: Yahoo!
    fd-fp3.wg1.b.yahoo.com
    ds-fp3.wg1.b.yahoo.com
    ds-any-fp3-lfb.wa1.b.yahoo.com

    Any idea how I get DNS working while tethering via mobile hotspot?

    Thanks!

    Advertisement

Share This Page