Do I need galaxy s3 windows 7 drivers?


  1. Gargus

    Gargus Member

    I got a galaxy s3 today and when I plug it in and go into the camera folder under the dcim folder to see pictures Ive taken it shows the images but it doesnt give me the preview pics. Like where I can see all the images and it shows me which each looks like on the tile instead of all just being a generic looking image tile.

    Do I need drivers or something? My old incredible phone once it installed it showed them with no adjustments needed.

    I have 32bit windows 7, a samsung galaxy s3 phone and under my computer it for the phone it says "sch-I535".

    Advertisement
  2. chanchan05

    chanchan05 The Doctor Guide

    Plug it in via mass storage mode. You're probably in Kies or MTP mode. On your phone go to menu>settings>wireless and network>USB Settings>Set it to Mass Storage. Your phone will then appear as a generic flash drive, and everything works like one (you see thumbnails).
  3. Gargus

    Gargus Member

    When I go into settings I dont see anything about USB settings on there or changing it to mass storage.

    Ill keep looking but I cant seem to find it. Even looking in the wireless/network part I dont see it.
  4. lunatic59

    lunatic59 Moderati ergo sum Moderator

    On the S3 with JB or ICS, it's under menu>settings>more (under wireless & networks)>USB Utilities.
  5. Max_Headroom

    Max_Headroom Well-Known Member

  6. Max_Headroom

    Max_Headroom Well-Known Member

    On the S3 there is no mass storage option only -

    Device (MPT) or Camera (PTP)
  7. Gargus

    Gargus Member

    Id looked a dozen times over and I dont see the option you guys are talking about at all.

    When I go to wireless and network in the settings and click more settings all I see is...airplane mode, kies via wifi, vpn, tethering, nfc, s beam, wifi direct, nearby devices and mobile networks. I see nothing about mass storage.

    Only thing I found that mentions mtp is when I have the phone plugged in via usb to my pc and the usb icon comes on in the task bar at the top of the screen when I drag it down and click on the other options it says I can pick either mobile device mtp or camera ptp. I tried both and neither are letting me view previews in the thumbnails on my pc.
  8. komputer

    komputer Member

    Ya, the posters above mean well but are CLUELESS.

    They either do not have any experience with the S3 model we have or are just reading from somewhere ie a book or ?.

    It must be experience with a different model cell phone.

    So no our USA Gphone S3s do not have those settings
    BTW you must have the Verizon version of S3 I have the Sprint version ie locked, no SIM card.

    As the video linked below states (BTW she does not look like jail bait to me and I would not shy away from her just because of her young looks), this works with the international does, not the US version. Depending on the Kernal. It has only been tested on the International Galaxy S III so far, but it could very well be compatible with other devices with similar configurations. Link to download the apk app is here but first read all the post and links.
    The most current ver should work with our US phones.
    But now to learn how to install apk files/apps. ( always a never ending learning curve, huh?)

    From experience ..It can not be done! Unless you follow and do what is on the video below.

    Why? Cause Samsung changed from UMS to MTP
    uh?? You say!
    That was my first reaction.
    A change for Ice Cream Sandwich users. That change was the removal of USBMass Storage. USB Mass Storage, or UMS, was replaced by Media TransferProtocol, or MTP. Each one has their uses, pros and cons.

    I will not go into why this was done, going to MTP. The links will tell you. Too much info to put here


    BTW how /what kind of format did you use for the SD card?
    NTFS
    Fat32
    exfat
    use ex fat, works better.esp with large files transfers/copying


    1. Info on what USB is:
    USB Mass Storage for the International Galaxy S III – xda-developers

    2 . Why use MTP instead of USB Mass Storage?


    Ice Cream Sandwich explained: MTP - what is it, why use it, and how to set it up | Android Central


    3.
    Mobile Transfer Protocol (MTP) v.s. USB Mass Storage (UMS) - xda-developers

    This might work, watch the video below

    4. Watch this video.
    Easy UMS, USB Mass Storage and Media Transfer Protocol - YouTube


    5. LINK to download AltMounter > [APP][v1.5beta (+US)] SGS3 Easy UMS - Mount external microSD card as USB mass storage - xda-developers


    What the app does: Makes the SD card on the Galaxy S III a USB Mass Storage device for users who wish to get around the restrictions of MTP.


    6. Another app to do USM stuff, Alt Mounter > Info here
    Alt Mounter Simulates USB Mass Storage Back on Ice Cream Sandwich – xda-developers

    More info here > Alt Mounter: Mount SD Card/Mass Storage, even on OS X - xda-developers
    Download it here The Nexus
    Galaxy44 and mcm180 like this.
  9. dvhttn

    dvhttn Well-Known Member

    Alternatively you could use MyPhoneExplorer to check your files. I use it on an HTC (running various ROMs - it works with all I have tried - and no, it's not an SIII ....) and you can browse the files on the sdcard from your PC (via cable or wifi - I use wifi - much more convenient). If you click on a jpg file it shows a thumbnail for that jpg. It doesn't, however, show thumbnails for all photos in the folder. Not that I've founf anyway, and I think that's what you're after.

    Mind you, that's fine for me as I always upload my photos and delete them from the phone.

    Dave
  10. komputer

    komputer Member

    You said it DAVE, works on an HTC but that is not what WE HAVE, a Gphone S3.
    If you read my post ( and it is a lot of reading) you will know why!
    Hint, change from UMS to MTP on the Ghone S3 running ICS
  11. Max_Headroom

    Max_Headroom Well-Known Member

    On my phone i do not see mass storage so the advice below was correct, perhaps its you that is CLULESS .


    On the S3 there is no mass storage option only -

    Device (MPT) or Camera (PTP)
  12. bluemanta

    bluemanta New Member

    Have you looked at the Samsung support site?

    Updating the USB driver should pop up the phone and SD card (if inserted) as 2 folders under the phone.

    worked for me on SCH-I535 (Verizon)

Share This Page