Does anyone else have this weird problem?


Last Updated:

  1. grn4frk

    grn4frk Active Member This Topic's Starter

    Joined:
    May 16, 2010
    Messages:
    43
    Likes Received:
    0
    Everytime I put my X on the charger (on computer, car or in wall) the screen no longer works properly. It wont respond to my touches until i turn screen on/off a few times and then when it starts recognizing my touch, it goes crazy! Clicks random things, sends my phone through a seizure or something? I called Verizon a few days ago and forced them to send me a brand new replacement that will be here on Monday.

    Just wondering if anyone else had this problem, or if it was just my phone or just something that happens with the X.

    Thanks
    Aaron
     

    Advertisement
  2. ericnail

    ericnail Well-Known Member

    Joined:
    Dec 27, 2009
    Messages:
    632
    Likes Received:
    137
    Sounds like you got a bad case of the phone-ghosts.
     
  3. deftdrummer

    deftdrummer Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    318
    Likes Received:
    11
    I have also seen this happen with debugging mode enabled and the phone plugged in via usb with the Moto Droid.
     
  4. RichSz

    RichSz Not Entitled VIP Member

    Joined:
    Jul 9, 2010
    Messages:
    2,087
    Likes Received:
    1,174
    Mine does that as well. It seemed worse when I first got it, but maybe I'm just getting used to it. Only happens when plugged into the wall, the computer charge is fine.
     
  5. grn4frk

    grn4frk Active Member This Topic's Starter

    Joined:
    May 16, 2010
    Messages:
    43
    Likes Received:
    0
    hmm well i think i got a bad phone too, I got it the first day they came out so I'm hoping this one has the bug fixed. It's quite annoying because everytime I want to answer a call or text; I have to unplug it and then replug it in. needless to say, it doesn't get charged that much except like 3-8am lol
     
  6. jerbeck24

    jerbeck24 Well-Known Member

    Joined:
    Jul 26, 2010
    Messages:
    186
    Likes Received:
    6
    My Droid X did this the first couple days too (I've only had it about 5 days). I'd plug it into my computer though when I had this problem and the screen just goes blank. You can tell it is still slightly back lit, but I can't do anything to it (not even turn it off). I also got the debug screen as well. Should I ask them for a replacement? I also am getting terrible battery. I charged it completely last night and I unplugged it from the charger and it immediately dropped to 90%. I checked one voice mail and an hour later, it was down to 80%....
     

Share This Page

Loading...