Does choosing "Charge Only" when you plug into a USB port act like "Disk Drive" also?


Last Updated:

  1. tracerit

    tracerit Well-Known Member This Topic's Starter

    Joined:
    May 7, 2010
    Messages:
    638
    Likes Received:
    42
    Even though I choose "Charge Only" when i plug the phone in, it still treats it like if I had chosen "Disk Drive". I'm not able to access my SD card when i want to do things with the phone.
     

    Advertisement
  2. QuickDraw

    QuickDraw Well-Known Member

    Joined:
    Jun 12, 2010
    Messages:
    328
    Likes Received:
    29

    To answer your question, no, it is not supposed to do that.


    Go into "Settings" + "Connect to PC" + "Default connection type" and pick what you want. It sounds like it may already be on "Disk Drive" and you're not choosing "Charge only" fast enough when it comes up to ask you and therefore going right to the default .. which in your case is probably "Disk drive". So what is your default set at?
     
  3. PSULightingGuy

    PSULightingGuy Active Member

    Joined:
    Jun 6, 2010
    Messages:
    27
    Likes Received:
    1
    Also, I had this problem occasionally and the only thing I can think of was somethng to do with the ROM I was running (Rooted) plus USB Debugging... Or maybe it was an App and USB Debugging... What ROM are you on (if any) and is USB Debugging turned on?
     
  4. tracerit

    tracerit Well-Known Member This Topic's Starter

    Joined:
    May 7, 2010
    Messages:
    638
    Likes Received:
    42
    i looked at the default already, its on the correct setting. Default is "Charge Only" and I have "Ask Me"checked also because sometimes I want to choose.
     
  5. tracerit

    tracerit Well-Known Member This Topic's Starter

    Joined:
    May 7, 2010
    Messages:
    638
    Likes Received:
    42
    no ROM, and USB debugging is off.
     
  6. Misbehavin'

    Misbehavin' Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    107
    Likes Received:
    26
    You don't have to use the "Ask Me" option. Pick your default, then if you want to change, just drag down the notification bar after you plug it in, and click on the USB icon. You can change it back and forth using this method, and yet not have to acknowledge what you want to do when you first plug it up.
     
  7. mark0695

    mark0695 Member

    Joined:
    Dec 24, 2009
    Messages:
    22
    Likes Received:
    2
    I get this all the time too and i choose charge only. what i do is once it mounts it i just go back and choose as a disk drive and then go back again and do charge only and then it frees up the sd card.
     
  8. blckz28

    blckz28 Member

    Joined:
    Jun 11, 2010
    Messages:
    14
    Likes Received:
    18
    Do you have DoubleTwist installed? It has a setting to automatically enable USB drive mode.
     
    fozzie, Loonytunes, scudder and 2 others like this.
  9. mark0695

    mark0695 Member

    Joined:
    Dec 24, 2009
    Messages:
    22
    Likes Received:
    2

    good find. That fixed my problem and i dont have to do the whole steps as i stated before. now i can just choose charge only and it works right
     
  10. tracerit

    tracerit Well-Known Member This Topic's Starter

    Joined:
    May 7, 2010
    Messages:
    638
    Likes Received:
    42
    i do have doubletwist installed! and turning it off fixed my problem! thanks! :)
     
  11. tjubb

    tjubb Active Member

    Joined:
    Apr 5, 2010
    Messages:
    38
    Likes Received:
    13
    THANKS! That worked! I was going nuts as to why my connection was going DISK DRIVE every time I connected even though CHARGE ONLY was set as my default.
     

Share This Page

Loading...