Does my workplace have to support me in order for me to connect with Exchange ActiveSync?


Last Updated:

  1. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    I came from Blackberry to EVO. Blackberry had the Blackberry Enterprise Server, which is equivalent to the Exchange ActiveSync Server. BES was an extra $30/month. Does EAS cost extra per month, too?

    Is EAS something I can just configure once I figure out the right information for the domain and everything? Or is this something that actually HAS to be supported by my company in order for it to physically work. Like BES was.

    I'm obviously a n00b. Any help is appreciated.
     

    Advertisement
  2. marctronixx

    marctronixx Moderator Moderator

    Joined:
    Oct 12, 2009
    Messages:
    5,699
    Likes Received:
    3,503
    you need to contact your IT department and make sure they are OK with allowing Android devices on their network and if they are OK make sure they have your email account setup for EAS.

    once thats all settled, they will give you the domain and you may need a cert installed to your device... thats up to them.. then use your login info and domain and your set.
     
  3. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    My company does not support Android devices. So I was wondering if I could just link it up anyway. Sounds like it's like the BES, where you can't do it without IT also turning the key.
     
  4. neodorian

    neodorian Well-Known Member

    Joined:
    Jan 5, 2010
    Messages:
    1,113
    Likes Received:
    276
    I just entered domain and login info and it worked fine.
     
  5. Jordus

    Jordus Well-Known Member

    Joined:
    May 5, 2010
    Messages:
    283
    Likes Received:
    70
    You probably can but if your company doesnt allow android devices, is it worth losing your job?

    IT sets policies for a reason. Sometimes its just to be lazy but not always ;)

    Oh and BES is not the same as ActiveSync. Its just an extension of some activesync hstuff and other management stuff for the blackberries. Its a POS if you ask me.
     
  6. paradox183

    paradox183 Well-Known Member

    Joined:
    May 31, 2010
    Messages:
    104
    Likes Received:
    12
    He said his company didn't support Android; doesn't necessarily mean they don't allow it. Could be an "at your own risk" kind of thing.

    Android 2.1 does not natively support Exchange mobile security policies, so if your company has these in place, you will need to wait for 2.2 or pay up for Touchdown.
     
  7. myersn024

    myersn024 Well-Known Member

    Joined:
    May 15, 2010
    Messages:
    46
    Likes Received:
    9
    As long as you know all the relevant information, you can set it up yourself. Unless you have a real dick of a network admin, you shouldn't have any problems. I'm a network admin, and I could care less what devices people connect to our Exchange server. As long as they aren't bugging me, I'm happy. :D
     
  8. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Yes, my IT contact tells me it is like an "at your own risk" thing. I guess I just don't know how to set it up. I don't know what my domain and server names are!! Feeling a little foolish about that. Googling is not helping. Oh well.
     
  9. myersn024

    myersn024 Well-Known Member

    Joined:
    May 15, 2010
    Messages:
    46
    Likes Received:
    9
    If you've ever used Outlook Web Access to get to your work email via a web browser, you most likely already have all the info you need. When logging into OWA, you have to enter your user name in the from of domain\username. If you don't have to put the domain in front of the user name, then leave domain blank. The mail server address is USUALLY the same as what you'd type into the browser to access OWA.

    Hope that makes sense.
     
  10. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    I appreciate the advice. I tried the above. My workplace's OTA does not require anything but a username from me, so I left the domain blank. I put the web address in the Server Address field. I've tried it with the https:// preceding it and by just starting with www.

    My username and password are filled in. I've tried it with the Secure check box selected and deselected.

    I know there is something easy I am missing, but I am stumped! It says "Verifying account information..." then it pups up a window. "Authentication failed. Please verify username and/or password."

    Is it possible that my password or username is not the same as what it is OTA?
     
  11. expalpo

    expalpo Active Member

    Joined:
    May 24, 2010
    Messages:
    32
    Likes Received:
    6
    I use settings, similar to below...

    Email: user@domain.local
    Server: domain.local
    Domain: <blank>
    Username: user@domain.local
    Password: <password>
    SSL Required: Checked

    I've also read about some people needing the username to be "\user@domain.local"
     
    Sprockethead likes this.
  12. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Thanks for the info. Mine just won't connect. I wish there were a way to verify my Outlook password. I'm just using my domain password. Outlook just automatically pops up once I'm logged into my computer.
     
  13. Jordus

    Jordus Well-Known Member

    Joined:
    May 5, 2010
    Messages:
    283
    Likes Received:
    70
    your exchange password is the same as your computer logon password.

    Whats probably catching you is that your exchange domain and your email domain are likely different.

    Your email is probably lke john@company.com while the exchange domain is company.local.

    On your work computer, open a command prompt (start > run > type cmd, press ok) and type ipconfig and press enter. Look at "connection specific dns suffix". That should be your exchange domain. Do this while at work connected to your works network if you are using a laptop.
     
    Sprockethead likes this.
  14. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Thanks so much for that advice. So I ran what you said, and my Connection-specific DNS Suffix is company.com

    I'm connected at work. That means that my server address is company.com, and my Domain is <blank>. Correct?
     
  15. Jordus

    Jordus Well-Known Member

    Joined:
    May 5, 2010
    Messages:
    283
    Likes Received:
    70
    If that showed the same as your email suffix then it would be

    email: you@company.com
    exchangedomain: company.com
    server: this is the external URL required for you to hit the exhange CAS. Probably the Outlook Web Access url without the /OWA on the end.
     
    Sprockethead likes this.
  16. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    OK- so tell me if this would make sense. The following fields are on the EVO, and here is what I am trying:

    email: you@company.com
    Server address: https://webmail.company.com
    Domain: <blank>
    Username: you@company.com
    Password: <same password you log into your computer with>

    This at least is giving me a message that says it doesn't trust the certificate. But then I get the same "username/logon failed" message.

    Am I understanding the above settings correctly?
     
  17. Jordus

    Jordus Well-Known Member

    Joined:
    May 5, 2010
    Messages:
    283
    Likes Received:
    70
    You need the domain to be filled in, and your username is probably domain\username or just the username, not the @company.com.
     
  18. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Thanks. I hope I'm not abusing your goodwill here. So I tried the following:

    email: you@company.com
    Server address: webmail.company.com
    Domain: company.com
    Username: company.com\you
    Password: <same password you log into your computer with>

    I also tried the username without the leading "company.com" And I tried the server address with both an "http://" and "https://" No dice. I also tried the check box at the bottom checked and unchecked for each configuration.

    What the heck?
     
  19. expalpo

    expalpo Active Member

    Joined:
    May 24, 2010
    Messages:
    32
    Likes Received:
    6
    Can you log into Outlook Mobile Access (OMA) from your desktop? What URL do you use? Mine is similar to below...

    https://www.domain.local/oma

    When you log into OMA, does your browser complain about the certificate?
     
    Sprockethead likes this.
  20. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
  21. expalpo

    expalpo Active Member

    Joined:
    May 24, 2010
    Messages:
    32
    Likes Received:
    6
    I would guess the settings for the server should be

    Server: webmail.company.com
    And Require SSL... should be checked...

    There shouldn't be a need for adding a 'http://' or 'https://' before the server name

    Can you attempt to log into OMA with the following URL...

    https://webmail.company.com/oma
     
  22. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    I typed https://webmail.company.com/oma into internet explorer. A pop-up login window displayed (rather than the website itself with a logon field).

    I typed my logon name and password. The following webpage loaded:

    [​IMG]

    Text: "The device type you are using is not supported. Press Ok to continue." "Ok" "Ok, and do not warn me again" "User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; MS-RTC LM 8; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)"

    I clicked "Ok"

    The following displayed (cropped):

    [​IMG]

    So... It works, but barely!!

    What does it mean?
     
  23. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Oh, wait. It's starting to sink (synch?) into my thick skull. That is the mobile over-the-air site. Aaaa haaaa....

    So if that just worked, then it means that my user name and password are correct. And I know that my email is my email.

    The problem has to be with the Server Address and/or the Domain. Correct?
     
  24. expalpo

    expalpo Active Member

    Joined:
    May 24, 2010
    Messages:
    32
    Likes Received:
    6
    lol.. That&#8217;s right... I would try the following settings

    Email: user@company.com
    Server:
    webmail.company.com
    Domain: <blank>
    Username: user@company.com
    Password: <desktop password>
    SSL Required: Checked


    If that doesn&#8217;t work try

    Email: user@company.com
    Server:
    webmail.company.com
    Domain: <blank>
    Username: \user@company.com
    Password: <desktop password>
    SSL Required: Checked


    If that doesn&#8217;t work&#8230; do you know if your mail server require &#8220;user certificates&#8221;?
     
  25. Sprockethead

    Sprockethead Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Ok - That did not work. And, unfortunately, I do not know whether my company uses certificates for Outlook. I would assume so, however. I had to install a certificate for remote access (access.company.com). I also had to install a certificate for Outlook's "Office Communicator" chat program.
     

Share This Page

Loading...