Don't forget, you can get 2.3.15 w/o OTA


Last Updated:

  1. SaurusX

    SaurusX Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    179
    Likes Received:
    35
    Yes, thanks to P3Droid you can get the 2.3.15 update without all of the Motorola bootloader BS. If you're still on the original leak, 2.3.9 build, and haven't done any further removing of apps or theming, then go to the link below and follow the directions to the "t". I went from the stock original leak to the latest version by that method just now with absolutely no problems. I even kept root with superuser being in xbin. Screw Moto and their games.

    http://androidforums.com/droid-x-all-things-root/179646-new-froyo-2-3-15-a.html
     

    Advertisement
  2. Pointguard1122

    Pointguard1122 Well-Known Member

    Joined:
    Aug 15, 2010
    Messages:
    213
    Likes Received:
    14
    I am running the same. I guess some people were wrong about P3's file being a Fraud.
     
  3. SaurusX

    SaurusX Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    179
    Likes Received:
    35
    I had my doubts at first, but I'll admit when I'm wrong and I absolutely was. P3Droid is totally on the level and a real asset to the Android community.
     
  4. lexluthor

    lexluthor Well-Known Member

    Joined:
    May 15, 2010
    Messages:
    4,161
    Likes Received:
    402
    Don't you not get the new radio this way though?
     
  5. tcallahan

    tcallahan Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    102
    Likes Received:
    3
    i would like to go about it this way... not really thrilled with moto's actions on that ota. Now question i have is ... can you follow these instructions from rooted 2.1 or no???
     
  6. sund0wn

    sund0wn Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    775
    Likes Received:
    175
    i dont believe so. i believe you have to install the original 2.2 leak first. dont quote me on this, but i'm about 86% sure.

    as a matter of fact, i'm about 96% certain that would put you in a bootloop, which makes my previous percentage of certainty really curious. :p

    simple answer, no. install the original leak first, then install 2.3.15.
     
  7. tsanuri

    tsanuri Well-Known Member

    Joined:
    Apr 5, 2010
    Messages:
    541
    Likes Received:
    44

    You do not but until I can see some numbers as to what the radio has done I am not even worried. I almost suspect that instead of doing something with the radio they just changed the numbers at which bars are being shown. Hope I am wrong with that but it would not shock me.
     
  8. pm1066

    pm1066 Well-Known Member

    Joined:
    Jul 14, 2010
    Messages:
    656
    Likes Received:
    136
    If running a deodexed 2.2 leak, do I still need to go back to the original 2.2 leak? And why the need to wipe data? Previous updates could retain data using the advanced setting in Clockwork Recovery...
     
  9. SaurusX

    SaurusX Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    179
    Likes Received:
    35
    You have to start out from the original stock 2.2 leak and then follow the steps linked to in the OP. You can get to original 2.2 stock by downloading the bootstrapper and ROM Manager, then apply 2.2 through ROM Manager. That's the easiest way, IMO.
     
  10. SaurusX

    SaurusX Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    179
    Likes Received:
    35
    I'm not sure if you can start out being already deodexed, but I'd read through the linked thread as it may work just fine. The instructions seem to be pretty explicit, however, and people have had trouble when not starting from the stock 2.2 leak. You must wipe data in order to ensure a clean install. No shortcuts can be taken on this update for some reason.
     
  11. pm1066

    pm1066 Well-Known Member

    Joined:
    Jul 14, 2010
    Messages:
    656
    Likes Received:
    136
    Good to know, thanks!

    Now to figure out if the update makes any sense. I haven't seen a strong reason to upgrade yet.
     
  12. tcallahan

    tcallahan Well-Known Member

    Joined:
    Jun 19, 2010
    Messages:
    102
    Likes Received:
    3
    if anyone could be so kind to post a link with directions on how to take 2.1 rooted to the original 2.2 leak that would be wonderful!! Then ill be able to follow the directions to get to the newest leak and not the ota! F**** YOU MOTO!
     
  13. BuTbKa

    BuTbKa Well-Known Member

    Joined:
    Mar 27, 2010
    Messages:
    825
    Likes Received:
    134
    download rom manager, install kousg bootstrap. In rom manager under 'download rom' u will see 2.2 stock image.
     
  14. mrempp

    mrempp Active Member

    Joined:
    Nov 12, 2009
    Messages:
    30
    Likes Received:
    3
    when i follow the directions it gives me an error that it cant mount sd card, so i cant select the update from the sd card. an ideas?
     
  15. SaurusX

    SaurusX Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    179
    Likes Received:
    35
    What are you trying to do? Go to the original stock 2.2 (2.3.9) or from there to 2.3.15? That matters.
     
  16. mrempp

    mrempp Active Member

    Joined:
    Nov 12, 2009
    Messages:
    30
    Likes Received:
    3
    from 2.3.9 to 2.3.15
     
  17. mrempp

    mrempp Active Member

    Joined:
    Nov 12, 2009
    Messages:
    30
    Likes Received:
    3
    any time i try to install anything in recovery i get
    Installation aborted
    E: Can't mount /dev/block/mmcblk0 (or /dev/block/mmcblk0p1)
    (Device or resource busy)
     
  18. Pointguard1122

    Pointguard1122 Well-Known Member

    Joined:
    Aug 15, 2010
    Messages:
    213
    Likes Received:
    14
    Did you Wipe Data, Wipe Cache and Mount System before installing?
     
  19. mrempp

    mrempp Active Member

    Joined:
    Nov 12, 2009
    Messages:
    30
    Likes Received:
    3
    yea i wiped data, wiped cache and mounted system, then when i went to select the update from the sd card i got that error.
     
  20. Pointguard1122

    Pointguard1122 Well-Known Member

    Joined:
    Aug 15, 2010
    Messages:
    213
    Likes Received:
    14
    not sure. I was having some issues after installation so I SBF'ed back to 2.1 and updated to 2.3.9 then 2.3.15. All is well now.
     
  21. mrempp

    mrempp Active Member

    Joined:
    Nov 12, 2009
    Messages:
    30
    Likes Received:
    3
    that will probably be my next step
     
  22. Dark Matter

    Dark Matter Well-Known Member

    Joined:
    Jul 24, 2010
    Messages:
    184
    Likes Received:
    41
    I got my replacement X today...it came with 2.1, which I was hoping for..Im gonna stick with Tranquility 2.3.15..until things settle down..dont wanna brick my phone again..
     
  23. Pointguard1122

    Pointguard1122 Well-Known Member

    Joined:
    Aug 15, 2010
    Messages:
    213
    Likes Received:
    14
    Congrats Dark Matter. I am really hoping mine arrives with 2.1. I have to wait until they are in stock at Amazon.
     
  24. dengar

    dengar Member

    Joined:
    Sep 24, 2010
    Messages:
    5
    Likes Received:
    0
    Thanks everyone for the work you do.

    Now to my question :) Do I have to wipe the data to go from 2.3.9 to 2.3.15? I really dont want to if I dont have to.

    Thanks.
     
  25. SFWB

    SFWB Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    427
    Likes Received:
    27
    I'm running the 2.3.15 leak with Beasley's OTA build prop file.. .Works great.
     

Share This Page

Loading...