1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Downgrade 2.3.4 Gingerbread to 2.3.3 to prepare for root


  1. magdelaine

    magdelaine Well-Known Member

    The Incredible 2 cannot be rooted from 2.3.4 Gingerbread, however from 2.3.3 it can. The first step is to take your Incredible back to a 2.3.3. OS.

    Roll it back
    This can be accomplished through a tool called Downgrade VivoW with hboot .98. I don

    Advertisement
    :
  2. valorian

    valorian Well-Known Member

    Very well written. I hope the Mods make this a sticky.
    magdelaine likes this.
  3. pockings

    pockings Well-Known Member

    Thank you for the detailed write up. I have 2.3.4 and do plan on rooting in the near future. This write up definitely helps a root newbie like myself :)
  4. austinv

    austinv New Member

    Thank you so much, I read so many other tutorials and couldn't figure it out. This detailed explanation saved me. I was pretty upset when I upgraded from the htc incredible and couldn't update. This worked perfectly :)
  5. starscream

    starscream New Member

    everything seems to go smoothly but when i reboot and go into about phone it still shows i am running 2.3.4
  6. valorian

    valorian Well-Known Member

    Make sure you did this step.

    Open CMD.exe as Administrator
    In Windows 7, the easiest way to do this is to put
    starscream likes this.
  7. starscream

    starscream New Member

    Thanks for your reply.. I did do that step.. started having issues with "adb out of date" I will retry again tonight when I get home... I am thinking my sdkmight be in need of updating. Is that a likely problem?
  8. mrw5641

    mrw5641 Well-Known Member

    magdelaine likes this.
  9. modena

    modena New Member

    Hello! I just want to make sure of something, does this work for the regular Incredible model? I'm guessing it does since it's just software but I couldn't find info about this elsewhere.

    Thanks!
  10. valorian

    valorian Well-Known Member

    No, this will not work for the original incredible. Even though it's just software, the Incredible 2 software is not the same as the Incredible. Each phone has it's own root methods. You will have to head over to the Original Incredible's forum section and find the root method for that phone.
  11. Nucco

    Nucco Well-Known Member

    So I've been wanting to go root on my Dinc2 since I got it, but installed the 2.3.4 update as soon as I got the phone so was kind of stuck. Found some tutorials on how to downgrade, but was really uneasy about.

    But I hop back on AndroidForums for a night, and find this. Rocking 2.3.3 and S-Off now. :) Thanks for the simple and easy tutorial bro.!

    EDIT: So I had not noticed because I was on WiFi, but I have no mobile network now. Doing a factory reset now, to see if maybe it was just a flook. Will update shortly.

    EDIT2: The factory reset didn't fix anything. Anyone have any idea what may be going on?

    EDIT3: Well I feel like a complete noob to the Dinc2. I had taken the battery cover off to do a battery pull and not put it back on. The cover has the antenna mounted on it. So yea, no back results in no service lol My bad.
    magdelaine likes this.
  12. mlee19841

    mlee19841 Well-Known Member

    for some reason it runs then reboots then at the end of the script on cmd.exe is keeps stalling out at c:\android>fastboot oem reboot RUU
    <waiting for device>

    doesn't go past that point any ideas on what im doing wrong?
  13. jmar

    jmar Nexican VIP Member

    So I used the downgrade tool and it continually failed. The most likely cause of this is that I did not have all of my tools in the correct file paths...or something else that I cannot determine. I made this clear over at XDA: if your SDK, ADB and file paths are not setup properly, the vivow hack will most likely not work. My work-around was to paste each command...it worked for me, though it is more time consuming. Hope this helps. :D

    jmar
  14. magdelaine

    magdelaine Well-Known Member

    I had that problem until I reinstalled the drivers. Have you had any luck since trying the other day?
    bberryhill0 likes this.
  15. Jswagmore6722

    Jswagmore6722 New Member

    im having trouble when it gets to flashing the ruu file, it just stops and just sits there. Any ideas??
  16. hansel711

    hansel711 New Member

    I think I have my extracted folder set up correctly. When I run the program (hack-vivow.cmd), it goes to completion and the device restarts, but when I check the software version, it still says 2.3.4. I tried entering the code manually to see if I could find out where it is going awry. In the second to last step:

    (c:\vwhk-12102011-c>fastboot flash zip RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.
    605.3_Radio_1.09.01.0622_NV_VZW1.92_release_199487_signed.zip)

    I get this:
    [​IMG]

    does this mean that "sending 'zip" failed? or does this suggest that an earlier step went wrong?
  17. bberryhill0

    bberryhill0 Well-Known Member

    Did you check the MD5 of the RUU file?
  18. hansel711

    hansel711 New Member

    i checked the md5 of the original zipped file (vwhk-12102011-c) and compared it to the one listed on xda, and they matched. This is what I get when I enter the code manually:

    [​IMG]
    [​IMG]
  19. hansel711

    hansel711 New Member

    What a crazy fool I've been! The woman I bough the phone from yesterday took the sd card out before she sold it to me. once I put a microSD, this process went over without a hitch. Learning curves can be steep...
  20. royalstar

    royalstar Member

    My device was Incridible S710d.
    OS version 2.3.4
    Hboot 1.04
    Room version 3.06.1401.3

    I try to downgrade with this instruction but nothing changes.Please help me.See the below screen shot.

    [​IMG]
    [​IMG][​IMG]


    [​IMG]


    [​IMG]
  21. lwmiller

    lwmiller Member

    Good morning,
    I just received my Dinc2 on Monday and would like to root it so I can get rid of all of this bloated crap on it, but the RUU zip file that is contained within the vwhk zip is always corrupted. I downloaded it on 4 different machines with 3 different OS's(albeit they were all Winders - XP, Vista and 7), on two different networks.

    Is anybody else having any problems?

    Thanks,
    Leonard
  22. lwmiller

    lwmiller Member

    Ok, I think I know what's wrong, I'm just an idiot and my dog keeps trying to get me to play with him, it's very distracting.
  23. dub4lyfe19

    dub4lyfe19 New Member

    having trouble with this. it goes through all of the steps and then on the final step it says error unable to load RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.
    605.3_Radio_1.09.01.0622_NV_VZW1.92_release_199487 _signed.zip)

    and then it just reboots to normal. any help would be appreciated
  24. raiif

    raiif New Member

    Just got a tablet so rooting my DInc2 was a must for the free hotspot.. this is a great guide, i'm a first time rooter and it definitely helped alot (especially the videos!)

    A slight issue/problem I've had, perhaps it's my own fault I'm not sure. When I started the process I was on Gingerbread 2.3.4 with an assortment of apps, GoLauncher fully setup, etc. After I reverted back to 2.3.3 it was a completely fresh factory install....... Therein lies my problem. After spending several days researching I was under the impression that I could use Nandroid to backup my current phone's "image" for reverting back to previous if I wanted. It's too late now, but I wanted some advice because I plan on dual booting this phone (with Cynogen and HTC Default/Factory).

    What did I do / Where did I go wrong???
  25. bberryhill0

    bberryhill0 Well-Known Member

    You can't nandroid until you are rooted so you didn't do anything wrong.
Loading...

Share This Page