Downgrade 2.3.4 Gingerbread to 2.3.3 to prepare for root

Last Updated:

  1. justineaton

    justineaton Member

    I will try again after work tonight and see if it works, if not I will look for an error message and hopefully someone here will be able to help. Thanks for responding.

  2. justineaton

    justineaton Member

    That means nothing to me. Hopefully someone can make sense of it and tell me what to do.
  3. valorian

    valorian Well-Known Member

    What means nothing to you? Did you see an error when you tried it again? We need some details on what is happening to help you.
  4. bberryhill0

    bberryhill0 Well-Known Member

    The "error opening input file" at the end looks bad to me. I think that's where it pushes the 2.3.3 image.
  5. justineaton

    justineaton Member

    It go's through everything ok but after the phone reboots it still says 2.3.4 there are a couple error messages in there but i dont understand what they mean.
  6. justineaton

    justineaton Member

    Any idea what would cause that? I downloaded from the links in this post and it don't look like anyone else had any trouble with them, maybe something didn't extract properly? I'm going to delete the Android folder I put everything in on the c drive and try extracting and doing it over from that point. Any other ideas?
  7. bberryhill0

    bberryhill0 Well-Known Member

    I couldn't see the whole line above the error. Look there to make sure the input file is in the right place.
  8. justineaton

    justineaton Member

    Ok, i tried it again and took a better picture this time.
  9. justineaton

    justineaton Member

    I extracted vivow and then pasted everything in a folder titled Android on the c drive including everything in the tools folder so that the Android folder dont have any sub folders that is what I was suppose to do right?

    i deleted the android folder from c drive and tried to re-extract in case there was a problem extracting something and it still didnt work, i did notice that after extracting there was a second zip file entitled RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.605.3_Radio_1.09.01.0622_NV_VZW1.92_release_199487_signed

    i extracted that and a bunch more zip files poped out. i havent done anything yet but am i supposed to extract all these and post everything in them in the android folder on c drive as well?
  10. ademidio453

    ademidio453 Member

    I cant get this to work can someone please help me with my errors at the bottom!!

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>cd \

    C:\>cd Android

    C:\Android>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    HT17HMA03552 device


    C:\Android>if /I NOT EXIST C:\Windows\adb.exe copy tools\win\adb.exe C:\Windows

    C:\Android>if /I NOT EXIST C:\Windows\AdbWinApi.dll copy tools\win\AdbWinApi.dll

    C:\Android>if /I NOT EXIST C:\Windows\AdbWinUsbApi.dll copy tools\win\AdbWinUsbA
    pi.dll C:\Windows

    C:\Android>if /I NOT EXIST C:\Windows\fastboot.exe copy tools\win\fastboot.exe C

    C:\Android>if /I NOT EXIST C:\Windows\sleep.exe copy tools\win\sleep.exe C:\Wind

    C:\Android>adb shell rm -r /data/local/tmp/*

    C:\Android>adb push zergRush /data/local/tmp/zergRush
    1327 KB/s (21215 bytes in 0.015s)

    C:\Android>adb push misc_version /data/local/tmp/misc_version
    495 KB/s (15837 bytes in 0.031s)

    C:\Android>adb shell chmod 777 /data/local/tmp/zergRush

    C:\Android>adb shell chmod 777 /data/local/tmp/misc_version

    C:\Android>adb shell /data/local/tmp/zergRush

    [**] Zerg rush - Android 2.2/2.3 local root
    [**] (C) 2011 Revolutionary. All rights reserved.

    [**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.

    [+] Found a GingerBread ! 0x00017118
    [*] Scooting ...
    [*] Sending 149 zerglings ...
    [+] Zerglings found a way to enter ! 0x10
    [*] Sending 149 zerglings ...
    [*] Trying a new path ...
    [*] Sending 149 zerglings ...
    [*] Trying a new path ...
    [*] Sending 149 zerglings ...
    [*] Trying a new path ...
    [*] Sending 149 zerglings ...
    [+] Zerglings caused crash (good news): 0x401219c4 0x0054
    [*] Researching Metabolic Boost ...
    [+] Speedlings on the go ! 0xafd26019 0xafd39ee7
    [*] Poping 24 more zerglings
    [*] Sending 173 zerglings ...

    [+] Rush did it ! It's a GG, man !
    [+] Killing ADB and restarting as root... enjoy!

    C:\Android>echo Sleeping 10 secs while adb restarts on the device....
    Sleeping 10 secs while adb restarts on the device....

    C:\Android>sleep 10

    C:\Android>adb shell /data/local/tmp/sh -c '/data/local/tmp/misc_version -s 2.18
    error: device not found

    C:\Android>adb reboot bootloader
    error: device not found

    C:\Android>fastboot oem rebootRUU
    < waiting for device >

    I dont't know what im doing wrong and its so frustrating!
  11. bberryhill0

    bberryhill0 Well-Known Member

    @Justin: the RUU is the 2.3.3 image and should not be unzipped.
  12. ademidio453

    ademidio453 Member

    never mind just got mine to work. I had to go into every file in the extracted file and set permissions to complete control for every file for admin and my admin user. Worked for me running windows 7. Going to root now!
  13. justineaton

    justineaton Member

    Ok thanks, I didn't try it with RUU unzipped so i guess I'm back where i started. At least I know what i didnt do wrong though.
  14. justineaton

    justineaton Member

    It looks like my problem is right there at the end with the RUU it says failed data length is to large. I'm guessing that is my problem. It's right there on the bottom of my last picture, anyone have any ideas for me of what I am doing wrong?
  15. bberryhill0

    bberryhill0 Well-Known Member

    I would guess the error at the top of the picture is the problem. I have no idea what partition 17 is. And then 'cache' isn't found. Those lines wouldn't be in the batch file if they weren't necessary.
  16. cnjncnkngr

    cnjncnkngr New Member

    I'm not sure what I'm doing wrong but when I get to the part where i type in 'adb devices' and hit enter I get 'adb' is not recognized as an internal or external command, operable program or batch file. I am running windows vista instead of windows 7. would this have anything to do with it?
  17. ademidio453

    ademidio453 Member

    Give this a shot. Copy files to root (main part)of folder from either win or Lin depending on your operating system if you haven't already. Also before you start entering commands when you open up cmd as admin unmount your sd card from your phone and then remount it from your phone and then start doing the commands. Hope it works.
  18. ademidio453

    ademidio453 Member

    You haven't downloaded the SDK to your computer yet. You need this before adb can be recognized.
  19. bberryhill0

    bberryhill0 Well-Known Member

    The package has adb and fastboot in it.
  20. justineaton

    justineaton Member

    I will try it this weakend, I bought a rooted dinc2 and it was diffrent from the phone i have now, I took it in and asked about it and was told mine is an incredible 1 phone with the upgrade on it and the new one is an incredble 2. Could this be the problem? Second question is the new phone I bought was rooted with cynagen mod but the activation screen won't bring up a keyboard to follow the prompts (that is activateing by dialing *228 the Verizon guy said it don't have the keypad because the mod isn't programed with one and he cant trasfer my acount and activate the phone unless he does a factory reset and takes the root off. Any ideas?
  21. ademidio453

    ademidio453 Member

    I'm you have one phone or 2 phones? Is one the incredible and the other the incredible 2? Or did you buy an original incredible thinking it was the incredible 2? They are completely different phones. I don't think you can root the original one this way sibce this method is for the new one. If you have the original one I would unroot since your having problems and then root it again. The original incredible is easier to root for most people. For info on how to root incredible 1 go to the incredible forum.

    If it is an incredible 2 I would unroot and then activate it. Then start the root process over.
  22. Jungleman528

    Jungleman528 Member

    So I'm following the walkthrough and I'm running into a snag. At the part where I'm supposed to "Exract All" of the zip file, it's not giving me the option to do that. When I extract the files out, all of the files just appear on my desktop. I'm using Windows 7, will this cause issues?
  23. justineaton

    justineaton Member

    I now have 2 phones I was told my first phone that I have been trying to root was an incredible 2 when I bought it but I just found out it is an original incredible. I figured the new one out with some help from the cyneganmod forum and finally have root. my wife's phone is the original incredible as well so I still want to figure it out now that I know why I have been Having trouble with it I will go to the correct forum. I still have to roll it back from 2.3.4 though so hopefully it is different than the incredible 2 is to roll back and I wont have any trouble.
  24. Flairy

    Flairy New Member

    I am having trouble downgrading to 2.3.3 in order to obtain root on my Incredible 2. I have installed the newest ADB and am running CMD in admin (tried in non-admin just to see if it'd work. it'd didn't), and keep getting "List of Devices Attached" upon adb devices command, but my device is not listed.

    My phone is in charge only, I uninstalled the HTC driver to keep it from trying to connecting as a hard drive, and debugging is on. Fastboot is off.

    We've been trying for hours to get the device listed, and no amount of googling is helping.

    I understand that not many have been able to achieve root post the 2.3.4 OTA, but I also know it's not impossible. Anyone run into this, or know how to fix it?

    Windows 7.

Share This Page