Download Maps IssueSupport


Last Updated: 2011-08-27 15:13:53
  1. MovingAlong

    MovingAlong New Member

    Hi all,

    I have searched and wasn't able to find anything - please point me in the right direction if there are already threads about this.

    On a daily basis I get 2 notifications appear on my phone (and they've been appearing for the past 2 months or so). The 1st is 'Map Update Required - Tap to download the latest maps'. The 2nd is a Location Download warning - I assume warning me that a lot of content is going to be downloaded.

    When clicking Map Update Required it takes me to a 'Download Maps' page where countries are listed (broken into regions of the world). For some reason the maps for United Kingdom, Ireland, France, Albania and Andorra have green progress bars next to them.

    I've sat on wifi on a numerous occasions allowing these progress bars to complete, but the following day I get the same notifications and the same attempts to download the same maps.

    I've tried clicking the progress bars which gives me the options to cancel or pause the download. However clicking neither of these seems to make any difference.

    FWIW I'd expect to be downloading the United Kingdom maps as this is where I'm based - however I've never knowingly selected anything to do with Ireland, France, Albania or Andorra - I certainly have no need for these maps.

    Anybody got any advice for how to get out of this never ending cycle. I've not got any mapping software on my phone other than the in-built Google Maps app.

    Using an HTC Desire Z and think I'm on Android 2.2 (certainly never 'rooted' it or done any other experiments with it).

    Advertisement
  2. daveybaby

    daveybaby Well-Known Member

    This doesnt sound like google maps to me - You can choose to download 10x10mile regions, but this isnt done automatically and isnt done by country.

    What network are you on? I know some (e.g. orange) provide satnav/mapping as part of their customisation.
  3. MovingAlong

    MovingAlong New Member

    Hi,

    Thanks for the reply.

    I'm on Orange.

    Update - I've since googled Orange Maps etc.. and whilst looking through my list of applications I can't see anything that looks like it installed. I have however come across an app called OruxMaps which I don't recall installing or using (but guess I must have). It seems to provide an option for storing offline maps - so sounds like a good candidate for this issue.

    However going to the Market and trying to install doesn't seem to be doing anything. Just trying a restart of the phone now to try again. If it fails to uninstall - any ideas how to force an uninstall?

    Update 2 - Found Settings->Applications-> and managed to uninstall from there. Will monitor for the next few days and see if it solves the problem.

    Cheers
  4. pmatil

    pmatil Member

    The map update is for the Locations app. And yes, the update process is a pain. I spent several weeks downloading the maps as the download kept disconnecting and the notification kept coming and every time I "download the updated maps" it started the download from the start. I guess the Locations app doesn't handle broken downloads well. The key is not to "click" the notification every time it appears. Check the Locations app and from there map licenses etc. there should be some progress bars depending on what areas your license applies to.
  5. MovingAlong

    MovingAlong New Member

    Excellent stuff. Thanks for your help.

    Just to be complete - after reading the notification of this post email on the phone true to form the Locations Update notification appeared - so I guess OruxMap are in the clear - apologises to them.

    FWIW - because this has been annoying me so much and consistently happening for near on 3 months I've literally sat on a very good WiFi connection on 3 occasions keeping the phone alive (as in screen active) whilst its done its downloads. The next day exactly the same thing happens.

    Whilst I know I don't need to click the notification I really am getting pissed off with it appearing all the time. I guess today I'm looking to try and root my phone in order to remove this application unless anybody knows how to remove the inbuilt apps on a Desire Z without the need to root?
  6. phipsi

    phipsi New Member

    I've the same problem. Today i tried the following: with the File Manager i changed to /mnt/sdcard/.data/navigator/Data/Maps

    In that directory all the maps from the Locations-app are downloded. On my device that were 1.5 GB. I deleted all maps. After that I tried to use the function from Contacts to show the location: it was shown without a Map.
    So: it is the right directory

    Next step: i renamed /mnt/sdcard/.data/navigator to /mnt/sdcard/.data/navigator-old (you also could delete the directory)

    Next: Starting locations-app asks you to download needed application data, about 40 MB. Say YES...

    If i now use locations-app, it downloads the map-squares needed in a temporary directory. But it doesn't ask me to update any map-download:).

    For future: i duplicated the newly installed directory /mnt/sdcard/.data/navigator to navigator.orig; so if I ever get again this stupid update-dialog, I just can copy the .orig-files.
  7. phipsi

    phipsi New Member

    @MovingAlong: Did you root your phone and did it work?

Share This Page