Droid 2 Global and Rooting/SuperUser issues


  1. RShea

    RShea New Member

    I have a Droid 2 Global running Android 2.3.4 (system version 4.5.629.A956.Verizon.en.US) and it was rooted before using the Motorola One Click Rooting app. Worked fine allowing me to run apps that required root access like Titanium Backup (not Pro), and most importantly Droidwall to control the access of applications on 3G data. I also use 3G Watchdog to control apps access over 3G vs wifi. Since the last round of updates (Google Play downloaded to replace the Android marketplace, etc.) I have had reports that the phone is not rooted (most recently via trying to install Titanium Backup update. I have Super User showing and the 3 apps listed are the SuperUser, Droidwall, and Titanium Backup.

    Just to be safe I also just redid the Rooting with Motorola One Click that I used before to root the device (which does in fact state for 2.3.4 in the application box when launched) in January. When I launch Titanium Backup 4.8.4 it reports "Sorry, I could not acquire root privileges. This application will *not* work! Please verify that your ROM is rooted and includes BusyBox, and try again."

    I did download BusyBox and it also is reporting that the Installer was not allowed root access (there are 2 BusyBox and BusyBox Installer and I did both)

    I also downloaded Root Check Basic and it too reports that this device does not have proper root access. I also tried the SuperUser Update Fixer and it reports no problems but if I force the fixer to run it failed and recommends downloading updater.zip from SuperUser web site.

    Any ideas on this. Fortunately the Droidwall and 3G Watchdog seem to be working and controlling the 3G data still. I'd like to get the Backup going again, since I can't use the Verizon Backup Assistant due to being on PagePlus prepaid....

    Advertisement
  2. silver6054

    silver6054 New Member

    As mentioned in many android forums, the latest D2G update to 4.5.629 (nothing to do with Market->Play) has blocked all currently known root exploits (as does 4.5.621 for the Droid X, and doubtless all the other updates being rolled out now for the X2 etc). Worse, you can no longer SBF back to an earlier version, trying will really brick your phone.

    Some have reported success with RootKeeper type options, but these only work if you use them prior to installing the update. Otherwise, we need to wait for a new root exploit, but it's not clear how much developer focus there still is on these aging (in phone years) models....
    RShea likes this.
  3. RShea

    RShea New Member

    Thanks for the reply. At least I know which of the updates caused the issue now. I did a few Google searches but did not find the discussion on the 4.5.629 now blocking root. I of course do not have the Rootkeeper installed prior so looks like I maybe out of luck unless they do come out with some updated rooting (yes I know it is not one of the newer models).
  4. Pilot2

    Pilot2 Member

    I hate to ask a newbe question, but why is there such a big fight to block people having root access to their own telephones? Do they just want to have a bunch of pesky little programs eating-up our data plans or... ? :rolleyes:
  5. Pilot2

    Pilot2 Member

    Developers have left the forum. :(

Share This Page