1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Droid 3 Calendar Sync to Google CalendarTips

Last Updated:

  1. droidwalker

    droidwalker Member

    The Droid-3 Calendar has "two" Calendar Account Domains. One of them will 'not' sync to Google Calendar. The fix is to "disable" one Account Domain.

    Example: (1) Gmail Acct Domain (your-acct@gmailcom); (2) Phone Acct Domain (Local@Phone). The difference is, the Local domain calendar event entries stay within the phone, will not sync to the Google web server.

    The solution... Disable the Phone Calendar Acct domain (and only to use the Gmail acct domain).

    Steps to disable the Phone Calendar Acct domain.

    1. Launch Calendar app.
    2. tap "Menu", "Settings", "Manage Calendars".
    3. You should see "two" Calendar Accts... at the end of each acct is a "sync & eye" icon switch.
    If you tap on the "sync & eye" icon, it will toggle into "4" stages...

    a. (both the "sync & eye" icon is bolded) or
    b. (only the "sync" icon is bolded) or
    c. (ony the "eye" icon is bolded) or
    d. (both the "sync & icon" is grey out).

    4. Calendar Accts
    a. Gmail Calendar Acct
    i. be sure the option is (both, "sync & eye" icon is "bolded").

    b. Phone Calendar Acct
    i. be sure the option is (both, "sync & eye" icon is "grey out").
    If you already created Calendar event entries using the "Phone Calendar Acct Domain" and do not want to manually delete each and re-type each into the Gmail Calendar Acct domain, you can download a free App to "convert" those calendar events into Gmail acct domain.
    You can download this app:
    "Business Calendar Free" by AppGenix Software Free.
    This calendar app will allow you to convert the "Droid Calendar Phone" domain to the "Gmail Calendar domain" (so that you can view the calendar events from a Desktop or Laptop via the Google Calendar web service log-in.

    herbanwisdom and Unicorn512 like this.
  2. yvonnehearn

    yvonnehearn New Member

    Thanks Droidwalker. My phone calendar is now syncing with my Google calendar!
  3. AdamDroid3user

    AdamDroid3user New Member

    If you already created Calendar event entries using the "Phone Calendar Acct Domain" and do not want to manually delete each and re-type each into the Gmail Calendar Acct domain, you can download a free App to "convert" those calendar events into Gmail acct domain.
    You can download this app:
    "Business Calendar Free" by AppGenix Software Free.
    This calendar app will allow you to convert the "Droid Calendar Phone" domain to the "Gmail Calendar domain" (so that you can view the calendar events from a Desktop or Laptop via the Google Calendar web service log-in.

    I did this. But cannot figure out how to convert one to the other as you say above.
  4. AdamDroid3user

    AdamDroid3user New Member

    I've done what was recommended above. I downloaded the recommended app and played around with managing calendars. Yet, it still does not show up on my google calendar online.
  5. Jgsinc

    Jgsinc New Member

    Do you want to sync from a Microsoft Outlook to Google?
    If so you need to down load the Google Calendar sync app Getting started with Google Calendar Sync - Google Calendar Help

    Then you need to do a one (1) way sync from Outlook to Google. Depending on how far you go back it can take awhile, (mine took awhile since I was done loading back about 3 years.) Now it only does the changes. Once that is done you can do a two way sync if you choose. (I keep mine on Outlook to Google for the simple fact I do more changes on my Oulook since that is what I use on a daily basis.) Not all color coded events will show the color assigned. (example I have blue assigned to the grandson it shows up as a brown color) As for the information not showing up on your calendar in Google make sure that you have your calendar checked. If you have more than one make sure that it the events did not go to another calendar.

    For contacts you need to go into Outllook and export them as a Comma Separated Value (CSV). Then save the file.
    Then go to Google and in Google under your mail area you will see contacts, under that you will see import. Find the file that you save and select the file you want to upload. This will place the contacts in Google as well as on the phone.

    Then run the sync with Google. Make sure that you have contacts and calendar checked in your account on the phone. (go to settings>accounts>gmail account, click on it and look to see what is check) Then do the sync for the icon for Google.

    There are programs out there that you can sync with Outlook without using Google. And I have tried most of them. I was using CompanionLink but they could not nor would not fix a problem where it was not showing all the appointments dealing with my grandson, even when I told them where the problem could be since it started happening after the 5.6 update to the Droid 3.

    SyncCell is another one I have tried it does not work at all.

    There are others in the market but when I read them I look for how the review is written some of the companies have a habit of having someone sit and write rave reviews for their software and the truth is just the opposite.

    If I can be of any other help please let me know. I do check back with the forums at least every couple of days.

  6. dubowsky

    dubowsky New Member

    I have gone to this site on my phone calendar settings but the phone calendar only toggles between the eye and nothing selected. Sync is greyed out and will not toggle on. Any suggestions.
  7. droidwalker

    droidwalker Member

    To convert phone acct to Google acct, first, you would need to go back to "manage calendar" and make sure "both" accts are "bolded" (meaning you want to be able to see both acct events). Next, launch the Business Calendar App. Then, at the bottom of the screen, tap the "phone" acct, be on the bottom left side. Now go into one of your phone calendar event and open. Then tap the "pencil" icon (to Edit mode). Next, near the top of screen is the calendar acct drop list arrow, tap the arrow. Then choose the Google Acct. Next, at the very top is the "save" icon, tap "save", and you're done. After you convert your phone acct events to Google acct, then you would go back to Droid 3's "manage calendar" setting and "grey out" the Phone acct. From this point forward, do 'not' use your phone acct, just use the Google calendar acct. Other notes, calendar acct events are color coded, example, phone acct is green, while Google acct may be "red". Google acct color theme is set in Google calendar via desktop or laptop log-in from your web-browser.
    LOTL likes this.
  8. droidwalker

    droidwalker Member

    My original post was, I assume you already have a Google acct setup at a Verizon store when you bought your droid phone. If you do 'not' already have a Google Gmail Acct setup on your Droid phone, you can "add" an acct. (1) Tap "menu", "setting", "accounts", "add account". The next screen should display all types of accts you can add, like "email", "google", "yahoo mail", "facebook", "twitter", "flickr", etc. Then follow screen instructions.
  9. jreid69

    jreid69 New Member

    I have followed the above instructions. The calendar does not sync. I load things on my Droid calendar, I never see them on my google calendar on my laptop. Every time I have to replace my phone - I loose all future events. I am frustrated that this appears that it should be easy and yet it feels extremely convoluted and difficult. I also appear to NOT be the only one struggling based on my internet search for the answer to this problem. I just had to replace my Droid3 with another Droid3 and now I can't even locate "calendar sync" - on precious Droid3 I did not have syncing and eyeballs. I'm very frustrated if it isn't obvious and I have bigger and better things to be frustrated about rather than spend so much time being frustrated over this. Alas I am aging and my calendar is now my memory - at this point in its functionality I would be considered demented.

    Jen R
  10. Unicorn512

    Unicorn512 Well-Known Member

    If you set your Google Calendar options show show another users calendar or one of the "Holiday" calendars, they will show up in your calendar lists.

    My wife and I share our calendar data via Google and both calendars show on our DROID 3's.

    She uses OUTLOOK on her PC and I use Time & Chaos with Thunderbird on my PC. We keep the PC's in sync with Google using CompanionLink and IMAP mail connections. Works very well...

    With this arrangement we are always aware of what the other person has scheduled, so we don't inadvertently double book ourselves, and mail dealt with on the DROID doesn't have to be dealt with again on the PC (or the other way around.)

    The Business Calendar Free looks like a good replacement for the stock D3 calendar. I plan to use it for a while and see....

    Happy New Year!
  11. droidwalker

    droidwalker Member

    The "manage calender" setting screen is only available in Droid 3's native Calendar app. So, if you already downloaded & installed other calendar apps, you would still need to launch the "native" Droid 3 calendar to get to this setting. There are various ways to launch the native Calendar. You might already have the app shortcut on one of your home screens. Or, you can do it in the sequential way.

    To launch the native calendar:
    1. tap "app launcher" icon at bottom row of your phone screen.
    2. next screen at top left corner is a "filter" icon (tap that, and choose "All Apps" so "all apps are visible).
    3. tap "31" icon (native Calendar) app.
    4. Your Droid 3 native Calendar should display.
    5. touch "menu" at the very bottom of your phone (left most icon key).
    6. tap "Settings".
    7. tap "Manage Calendars".
    8. At this point, you should see "Gmail Acct" and a "Phone Acct" (each has "sync & eyeball" switches).

    In my original post, you would 'greyed out" the "Phone Acct" switch, and "bold" your "Gmail Acct" switch, so that all event entries are only visible for the "Gmail Acct".

    At times, on this "manage calendars" setting screen, you can also "greyed out" the "Gmail Acct", then, "bolded" again, to force a fresh sync between Google Web server and your phone.

    One other note, I have the unlimited "3G" Verizon plan, so, I am almost always at sync with Google. If you only have limited "3G" plan, and you have "wi-fi" turned out to conserve your "3G" monthly data limit, be sure your 'wi-fi" connection is clean at that moment during calendar sync.
  12. WebKat

    WebKat Well-Known Member

    I have about 15 different calendars that show up in my "Manage Calendars" settings. My main gmail account, my work gmail account, my family gmail account, my husband's schedule, my son's schedule, some of my coworkers' calendars(!?!?)... I've made sure that the ones I want showing and synced are set so... and yet every time I want to look at my calendar I have to go into my main phone settings > Accounts > [my gmail account] > sync calendar. I have to do this for gmail, too, or it won't sync. I'm quite pissed about this situation and the VZW help people were no help--they say I have to do a factory reset on my phone to fix it!
  13. doogald

    doogald Guides Guide

    Well, just to ask the question, in settings->Battery & data manager->Data delivery, do you have "Background data" enabled? And, you say that you go into settings->accounts->your Google account, to turn on Sync Calendar. Are you saying that this checkmark isn't persistent - it keeps turning itself off?
  14. WebKat

    WebKat Well-Known Member

    All three boxes are checked, so yes.
    There are no check boxes to check. Just a list: Sync Google+ Notifications, Sync Books, Sync Contacts, Sync Gmail, Sync Calendar, and under each one it says "touch to sync now" and gives the date of the last sync (usually several days old).
  15. doogald

    doogald Guides Guide

    That's not how it normally looks. There should be a check mark for all of those items. Is this the only Google account on the phone? If not, can you remove the account and then reinstall it?
  16. WebKat

    WebKat Well-Known Member

    I have 6 accounts on the phone, but the main one--the important one--is the primary account for the phone--the one I used to set the phone up. In order to remove the account to re install it, I have to factory reset the phone.
  17. doogald

    doogald Guides Guide

    Try putting the Power Control widget on a home screen somewhere, just temporarily. The fourth icon from the left is the sync control - it looks like a circle with two arrows pointing to each other's ends. My guess is that this is turned off. If so, try tapping, and then settings->accounts->google account should have those check marks.
  18. WebKat

    WebKat Well-Known Member

    I did that and it was off when I added the button. I clicked it on and then removed the widget--will that do it, do you think? I have PowerControl on my homescreen already, just not with that button. I may have to edit it to include that one if it insists on reverting to wonkiness.
  19. doogald

    doogald Guides Guide

    Yes, it will stick.

    Stock Android has a setting in settings->accounts to toggle autosync on and off, but Motorola appears to have removed that (or, likely, customized that settings control without including the autosync checkbox.) However, it also seems to be something that can be toggled from a widget.

    The powercontrol widget that ships with the phone always includes the autosync control - I see no way to edit what the widget shows. There are third-party widgets that can edit the controls that are shown.

    All that said, I'd keep the widget around if you have space for it, just to make sure that it isn't being turned off by something else (which could be an app like Locale, Tasker, Setting Profiles - JuiceDefender may even turn off autosync - I don't recall, as it's been a while since I ran that.)
  20. WebKat

    WebKat Well-Known Member

    Thanks for the tips. I think I'll add the button to the widget I have. Just to be able to reassure myself that it's still on, if nothing else!
  21. rufireproof

    rufireproof New Member

    I am having this same issue. I had to replace my defective Droid 3, and now it will not sync the calander.
    I have the phone calender grayed out for sync and show. The myaccount@Gmail calander and US Holidays are both Bold for sync and show.
    I am using the default calander program.
    I can not enter events into my phone. If I do, it acts like it is saving it, but nothing shows up. I make sure that at the top the drop down menu is set to myaccount@gmail, which is the only option. If I enter an event with my PC, it shows up, but if I enter it on my phone, it does not show up at all...
    Is there a way to disable the "phone only" calander and just have it run the Google calender?
  22. WebKat

    WebKat Well-Known Member

    I had to order a replacement this weekend. It should be here by tomorrow. I hope that solves my problems. *sigh*
  23. droidwalker

    droidwalker Member

    Eversince Android 2.3 Gingerbread released, it appears that some Android phones are having calendar sync problems with Google Calendar Web server. It could be version 2.3 in the Android has a built-in "phone acct" that is designed 'not' to sync (could be for privacy purposes). One of the tips I give to my friends is to do reverse engineering. Before they buy an Android phone, use their laptop and go into Google to setup a Gmail account. Then, when they buy the Android phone, setup the Gmail account during their phone registration and initiation.

    As for your one-direction sync (from Google web calendar back to phone, but 'not' the other way around), not sure if you have installed some apps to your Android phone that has some "settings" that may block or restrict 'outgoing' sync from phone to google web server. Review your other app settings, to see if there are any 'data' exchange restrictions or "check boxes" that you can check.
  24. unafndilla

    unafndilla New Member

    Some things on my Google calendar sync with my Android calendar and some don't. It seems very random and it's very frustrating.
  25. whysman

    whysman New Member

    the solution posted states there are 2 calenders. only 1 shows on my phone. what next? It is phone calender and the sync function will not turn on.

    Tried this---didn't work
    1. From the home screen, click the "menu" button (bottom left corner of phone).

    2. Click Settings

    3. Click Applications

    4. Click Manage Applications

    5. Click All (at top of screen)

    6. Scroll down and click Calendar Storage

    7. Click Clear Data

    8. Exit out and wait for calendar to sync. When I did this, it took only a few seconds and all the calendars were showing.

    This is where I got the answer - it is for the Droid, but worked with the Stratosphere too.

    Droid X: Calendar Doesn’t Sync | Technipages

    by clearing data I have now lost all events on phone which is where I enter events. ouch. since it wasn't syncing with google calender I am up the creek and have no idea what my schedule is.

Share This Page