Droid - Cannot connect to Exchange Server after 2.2 UpdateSupport


  1. bbatters

    bbatters New Member

    I got the upgrade to 2.2 earlier this week on my Moto Droid. I haven't been able to get my email or calender working since. My IT guy at work does not have a solution for me. It is not an issue with the corporate server. My phone just shows an error that says it cannot connect to the exchange server for the email and calender functions. I turned the phone off and restarted a couple times, didn't work. I tried removing and re-installing my exchange account (bad idea).

    VZ Wireless had no answer. Motorola had a wait time of 2-3 hours for their technical support. Please help. I have been using the Touchdown app for a temporary fix.

    Please help! I do not want to have to sit on the Motorola tech line for 2 hours.

    Advertisement
    :
  2. Ellis

    Ellis New Member

    same problem. any solutions yet?
  3. bbatters

    bbatters New Member

    nothing yet??
  4. docdl

    docdl Active Member

    +1

    This is really a problem...
  5. bbatters

    bbatters New Member

    Motorola has told me that my Exchange server should "enable non-provisionable devices". So, my IT guy looked at the server and this was already enabled. The only solution I have seen anywhere is to get a non-SSL. I guess my company would have to go out and buy a security certificate from godaddy.com or something. This would change the settings for everyone else in the company.

    This cannot be Motorola's 1 and only answer for this problem. IT WORKED BEFORE. IT SHOULD WORK NOW.

    ANYONE ELSE HAVING THIS ISSUE OR HAVE A POSSIBLE SOLUTION?
  6. docdl

    docdl Active Member

    My sync with Exchange crapped out when I updated to Froyo too. Last night, I installed Google Sync so I can at least have my calendar available. My Outlook calendar via my desktop client now syncs with Google Calendar every 10 minutes (as long as I'm using my PC). I wasn't using the Google Calendar for anything else, so it isn't a big deal for me on that front. I made sure the settings are NOT to make events publicly available even though I'm not concerned because I don't keep any sensitive info on the calendar.

    An IT guy for my employer heard my complaints and I'll put them in an email so he can pass them up the food chain. Basically, I don't think policies that are not enforced on a personal laptop/netbook should be enforced on a personal phone. And there should definitely be a clear policy available online so I know what I'm agreeing to were I to give the access asked for (remote wipe, etc.). I think it (sync) still doesn't work even if I grant access - really two separate issues for me. One is that it won't sync and the other is that I have to agree to "black box" policies. I do understand there is a good argument for enforcing some security policies.

    Maybe the Google calendar sync workaround will help some who find this thread. I realize it is an incomplete solution and really Exchange should just work like it did before!
  7. fevillago

    fevillago Member

    I called motorola tech support because my corporate calendar disappeared after the 2.2 upgrade and they said I should do a master reset. I do not think this will fix it. This upgrade really screw us. I am so disappointed:(
  8. fevillago

    fevillago Member



    I did a master reset and it solved the problem. I had to re-install all my aftermarket apps so that was a bummer. but at least everything works again
  9. EvilNat

    EvilNat New Member

    I am having the same problem after the second froyo update.. I did a hardware reset and now when I try to setup and login for the first time, the e-mail application force closes..
  10. golfprowantabe

    golfprowantabe New Member

    I had the same problem with 2.2 not working with Exchange...Verizon told me it was just me and my server settings (I am a network Engineer)... They even sent me out a new phone and told me a work around was NOT to upgrade... WOW... what a solution!

    Got a new security upgrade today and now my exchange is working!!!

    Crap...what was I thinking... now I have no excuse not replying to any emails
  11. wilceaux

    wilceaux Well-Known Member

    Could you explain what you mean when you say you got a new security upgrade? Do you mean through your company IT, or through Verizon?
  12. smo8233

    smo8233 New Member

    My Droid received the 2.2 update OTA about 2 weeks ago and everything was working fine. Then this morning, another update was pushed OTA and since then, my exchange crapped out. Went to Verizon and had them do a hardware reset - no help.
  13. smo8233

    smo8233 New Member

    My OTA update that pushed the latest 2.2 (build FRG22D) seems to have broken my ability to use the "out of the box" email app with my exchange server at work. Read another forum that suggested using either K-9 or Touchdown. I tried Touchdown (since others on the Forum said K-9 didn't fix them either) and I like it works.

    I actually like it much better than the "out of the box" app... I've been having countless problems with the "out of the box" app (synching calandars, etc). This is actually a good app, well worth the $20.
  14. wnofearw

    wnofearw New Member

  15. justenhansen

    justenhansen New Member

    Did anybody try that? I just got my Droid X today and am scared to do any updating on the advice of one person when I've never updated it before.
    And just to make sure I'm on the right page, I linked my Droid with my work's Microsoft Exchange which worked for my email but my Droid calendar doesn't show any of my appointments. That's what y'all are talking about right?
  16. Ste-v-B

    Ste-v-B New Member

    THAT WAS EASY! (like all things Droid :D) On reboot the patch loaded so quickly, I was not sure it even worked, but as it was starting-up I got that reassuring tone that tells me that I've received a new mail (I have a love/hate relationship with that tone).

  17. omahaduke

    omahaduke New Member

    I saved this to my SD card as update.zip. Put the card back into phone and restarted, still no email. Do I need to save it someplace special on the SD card?

    My email was working fine before the update came through for 2.2!
  18. TalShiar

    TalShiar New Member

    I updated my Droid successfully but still no e-mail. Any thoughts?
  19. droidAyers

    droidAyers Member

  20. theGlide

    theGlide New Member

    I tried this on my Moto Droid and it didn't work...using the Touchdown trial for the moment (which is a great app).
  21. kcd3

    kcd3 New Member

    After applying the update in my company, 40 employees lost the ability to access e-mail from their phone. Thankfully TouchDown works, but that is only a temporary solution.

    I spoke with Verizon and Motorola countless times, and even sent them debugging logs of the force close, but they were not helpful in any way.

    Anyways, I believe I may have found a solution to this problem, at least in my case.

    Phone: Droid 1, running FRG22D

    After setting up my friends Gmail as an exchange account on his i*hone, I decided to try the same thing on my Droid. I was able to finish configuring my account without any force close errors, so I knew it was something on my server.

    Using a new activesync policy, with only "Allow non-provisioning devices" select and I could add my exchange account back on the phone. Due to my company's security policy we are required to have a password on all phones, so I copied the settings from our previous policy and it broke the e-mail app.

    Here it was I had enabled in my policy:
    Require Password
    Enable Password Recovery
    Allow simple password
    Number of failed attemps allowed: 10
    Minimum password length: 4
    Time without user input before password must be re-entered (in minutes): 60

    ^I found out that this last option is causing the e-mail app to crash when it applies to the phone. After reducing the time to the default of 15 minutes, I was able to setup my phone with no problem.

    My recommendation:

    1) try setting up your Google account as a Coporate sync, using m.google.com as the exchange server, and your e-mail address as the username to verify if the e-mail app works

    2) Test a fresh activesync policy on your phone with only "Allow non-provisioning devices" selected

    3) Enable the settings of your previous policy one by one to determine if any of them are breaking your phone, and adjust accordingly.

    I hope this helps.
  22. djtheriot21

    djtheriot21 New Member

    I found a workaround. If your email address is joe.somebody@mycompany.com try entering joe.somebody@gmail.com and then it will get you to the next step in the process. Then you can change the exchange server from gmail.com to mycompany.com and set your username. I am not sure but it is possible that this problem is being caused by the username being different than the first part of the email address. My username used to login is jsomebody while my email address is joe.somebody@mycompany.com.
  23. smyle205

    smyle205 New Member

    Yes, I have the very same problem. I seriously hope to find a solution by 6/2/11 noon, or I will be returning the useless piece of excrement.
    yescivic likes this.
  24. jcesar

    jcesar New Member

    This is b#^sh!t. Why don't these guys test this before putting it out there. I mean seriously, almost everyone has Exchange for work email. I am going back to iphone, I've had it with this donkey kong.
    yescivic likes this.
Loading...

Share This Page