Support Droid DNA Won't Connect to Internet While on Wi-Fi

Discussion in 'Android Devices' started by Kyle2595, Dec 14, 2012.

  1. Kyle2595

    Kyle2595 Member
    6

    Dec 14, 2012
    7
    4
    6
    Just got my HTC Droid DNA and have been using it for 2 days. The first day, everything worked fine. The second day I tried connecting to the Wi-Fi at my school which is secured with EAP and it would connect to the network but would not get a connection to the internet. No browser, no Play Store, no nothing. Same story with any other network I try. Any suggestions?
     

    Advertisement

    Timc166293 likes this.
  2. AntimonyER

    AntimonyER AF Addict
    VIP Member
    1,333

    Jun 18, 2010
    13,646
    8,004
    1,333
    Statesboro, GA
    I had this problem with my Nexus, but it was only my school network, not anywhere else. In my case it was the schools problem, as no mobile device could connect...
     
  3. Kyle2595

    Kyle2595 Member
    6

    Dec 14, 2012
    7
    4
    6
    That's what I thought at first, but my school's network does not have a history of problems and my previous phone (Droid X) would work at the school. But now with the DNA it will not get an internet connection on any Wi-Fi network, even my unsecured home network or at my local Starbucks.
     
  4. unccman

    unccman Well-Known Member
    43

    Jul 18, 2010
    91
    70
    43
    Charlotte, NC
    Well, you can always try to take it to VZW or call them --- but they're most likely going to have you do a master reset before considering swapping it out for a new one because of defective hardware.

    I'd recommend a master reset and see if it's working.
     
  5. djbibiloni

    djbibiloni New Member
    5

    Dec 14, 2012
    1
    0
    5
    Same problem here! I was literally registering to post the very same issue. I'm definitely interested in what your outcome is. For now I'm sick with4g only...not all that bad I guess.

    If it matters any I disabled ask off the Amazon apps, Slacker, and Ammex.
     
  6. Kyle2595

    Kyle2595 Member
    6

    Dec 14, 2012
    7
    4
    6
    Glad I'm not the only one with this problem.
    I had emailed HTC about this and here is part of their response:

    "It may be caused by task killers, a non compatible application or software issues. As a matter of basic troubleshooting, please boot your phone in Safe Mode. It is a method that allows the device to run without non-essential applications."

    So I tried booting into safe mode by holding the power button until the option to Power Off, Airplane Mode, and Restart came up. I then long-pressed the "Power Off" option and rebooted into safe mode. Still the same problem. I had installed Advanced Task Killer from the Play Store before the phone started having problems, so I rebooted the phone normally (no longer in safe mode) and uninstalled ATK and rebooted again. Still no luck.

    I finally gave up and did a factory reset and all seems to be ok for now. But the phone only started experiencing problems after the second day so I will wait to see if resetting actually fixed it. I will also not be installing ATK and see if that helps...
     
  7. stkorn97

    stkorn97 Well-Known Member
    38

    Jul 17, 2010
    156
    24
    38
    IL
    Yeah, no need for task killers regardless on most phones now. Not saying that was the issue, but it wouldnt hurt to lose that app anyways.
     
  8. Timc166293

    Timc166293 New Member
    5

    Dec 15, 2012
    1
    0
    5
    Same here. First day issue had to hardreset.

    Two other times power cycle fixed after about one week of use.

    It is looking like a software issue.
     

Share This Page

Loading...