Droid Maxx WiFi ProblemsSupport


Last Updated:

  1. cornelius2008

    cornelius2008 Member

    I've had a Maxx for some months and suddenly it would start dropping wifi, and not be able to pick it back up. My phone screen was cracked so I had to get another one on an insurance claim. The one that arrived connected a few times and now will not at all. I have my Laptop, Xbox, kindle, and other cellphones on the wifi without problems.

    The phone is allowing me to turn on wifi, it allows me to save the password but, when it can finally see my home network, which it doesn't always even though when it does it has it at excellent strength, It wont connect. When I hit connect the network suddenly drops to low strength or the connect option simply goes away without doing anything.

    I have switched routers thinking that was the issue, from an old Belkin to a new TP-Link and the problem stayed the exact same. I have factory reset my phone to no effect. I have deselected 'avoid poor connections' and 'Keep Wi-Fi on during sleep' is on always. I am on Android version: 4.4, and system version: 19.6.3.obake - maxx _ verizon . Verizon . en . US,

    Advertisement
  2. doogald

    doogald Guides Guide

    It sounds like a hardware problem. Call to tell them about it and get a new replacement.
  3. cornelius2008

    cornelius2008 Member

    My first maxx had the same issue and it wasn't fixed with a replacement.
  4. doogald

    doogald Guides Guide

    Is the wifi router set to 2.4 or 5 ghz? Set to which authentication (wep, WPA, wpa2) or none? Set to n only or b/g/n?
  5. cornelius2008

    cornelius2008 Member

    I'm out of town right this second. I'll get all the data on sunday
  6. cornelius2008

    cornelius2008 Member

    It says mode: 11bgn mixed. Security: wpa2-psk,with a aes encryption. I don't see where the router is set to 2.4 or 5. But the phone is set to auto.
  7. doogald

    doogald Guides Guide

    bgn mixed is definitely 2.4 GHz. You can try changing the phone to 2.4 GHz only. You can also try changing the channel that the router is using (the channels in the US are 1-11 on 2.4 GHz, but they span about 5 channels, so most people use 1, 6, or 11.) It could be that the channel you are using is in common use in your neighborhood or area and you have some channel conflict.

    That's a setting on the router, not on the phone.
  8. cornelius2008

    cornelius2008 Member

    I've changed the phone to 2.4 GHz and cycled through the channels to no avail. I even changed the channel width from 20 to 40MHz.
  9. doogald

    doogald Guides Guide

    Time for a warranty replacement, then, I think. I have no trouble at all with WiFi on any router or access point that I've tried from a variety of vendors (Apple, Asus, Netgear, Linksys and D-Link.)
    Thom likes this.
  10. cornelius2008

    cornelius2008 Member

    This phone is a warranty swap. The last phone I had had these same exact issues as well, I swapped it out due to a cracked screen though.
  11. doogald

    doogald Guides Guide

    I think that you need another replacement. You've tried the phone on two different wireless routers that are serving other clients without problem. That just isn't right. It sounds like you have bad luck with handsets and WiFi so far.

    The only other thing I can think of is to start in safe mode to rule out interference from a third party app. This post has the instructions for entering safe mode: http://androidforums.com/motorola-d...y-automatic-reboot-occurring.html#post6611139
  12. cornelius2008

    cornelius2008 Member

    Tried the safe mode. No success. I guess I'll have to try the warranty swap. The thing that makes me hesitant is that it connects to my University network no problem. At least non that I've noticed.
  13. wooddale

    wooddale Member

    I'm having the same problem just got phone used connects sometimes and sometimes not then it will all of a sudden connect up again
  14. Miss_Crystalix

    Miss_Crystalix New Member

    I'm having this exact problem too, and I'm also already on my warranty replacement phone (other had screen crack). Did you ever find a solution to this, and do you have any idea whether Motorola is aware of this issue? I want to just get another phone, but apparently Maxx is the top >:-(

    Also, since they might be related, is your bluetooth also behaving this way? Randomly dropping or refusing to connect with paired devices?
  15. doogald

    doogald Guides Guide

    You don't happen to have any flashlight apps installed on the phone? If so, I know of a known issue with those preventing WiFi and BT connections.

    To rule out any other app issues, I'd suggest restarting the phone in safe mode and run the phone for a while to see if there are WiFi issues. Safe mode will prevent third party apps from autostarting at boot.

    Long-press power, just as you normally would to power off, but then long-press on the "Power-off" field until you see a message about safe mode. When you acknowledge that, the phone will restart in safe mode. To restart normally, just do a normal power off/power on from safe mode...
    Thom likes this.
  16. Westphotog

    Westphotog Member

    This doesn't appear to be a new problem. My phone and my wife's have been acting up just in the last few weeks. Won't detect WiFi even though I know my laptop is connected. But when I run a cache cleaner and clean up my processes (ccleaner) suddenly my WiFi wakes up and reconnects. Any ideas what process would be running on two different droid maxx phones that blocks my WiFi and goes away when I kill old processes?
  17. EarlyMon

    EarlyMon The PearlyMon Moderator

    Thom likes this.
  18. Westphotog

    Westphotog Member

    How can you separate knowing if it was clearing the cache partition like this, or simply the act of rebooting in order to get to the cache clearing function that fixed the problem.

    The reason I ask is I can use ccleaner to clear my cache and nothing happens, but when I clear just the processes and leave the cache alone my WiFi picks back up and reconnects.
  19. EarlyMon

    EarlyMon The PearlyMon Moderator

    CCleaner is clearing individual app caches.

    Android has two caches of it own - and those cannot be cleared by an app.

    If either of those get tangled up you'll chase your tail until the end of time because everything you'll do will be under the assumption that the operating system is ok. If either operating system cache is hosed that assumption will be wrong.

    You're describing a weird problem and an irrational response by the phone.

    It's possible that you both have contracted an app that can shut down wifi. Short of Tasker, Llama or other automation software where you program your phone to do that, I don't know what that could be (and you'd have probably gone to it and stopped it if so).

    From my experience (tap my name for statistics) I've found without exaggeration that more than 9 out of 10 of these cases are caught by an operating system cache problem, and in a good portion, it's the main cache that can only be cleared from recovery. Motorola knows it too, that's why they include the facility and public instructions.

    The other, called the Dalvik cache, can only be cleared on a non-rooted phone by a factory data reset. I've personally suffered that one, and the reset will erase your data.

    Some people can run for their life of the phone and never see the problem. But by its very nature, it's not a matter of if the main cache will get messed up, it's a matter of when.

    If wiping the main cache doesn't fix it, it's still not a wasted effort. In such a case, it still needs clearing in case it's a contributor or to eliminate it from consideration.

    And as I said - it's safe to do.

    The reason you don't want to make a habit of cleaning app caches is because it slows your phone down and is rarely needed - they're not junk files. If you want to do that, you do it infrequently and only when clearing individual app caches isn't cutting it in the face of a specific problem. And by then, you want to clean the main cache.

    http://androidforums.com/threads/pu...k-killers-ram-optimizers-and-the-like.896663/

    Wifi just working on a reboot or because you stopped some apps isn't rational.

    Attack the problem in order of probability of cause, here's how -

    - wipe cache from recovery

    - still failing, hold volume down + power for 10 to 15 seconds until it powers off - this is like an old school battery pull and will clear out any stuck bits in silicon

    - failing that, start in safe mode and run for at least a day.

    -- if it's good you have a misbehaving app and if you can't find it by process of elimination or deduction, you'll have to do the dreaded factory data reset and reinstall apps one by one

    -- if it's not ok running in safe mode, you must do a factory data reset

    -- if it's not ok after a factory data reset and no new apps installed either your operating system has become corrupted (the write-protected storage had a protection problem) or the hardware is failing

    As you go further down the list with both phones resisting being fixed, the probability increases that this was caused when both were charging at the same time when a power line spike happened.

    But right now the probability is highest that you need to wipe cache from recovery.

    And heed my advice about avoiding any of the popular helpers I described - despite having millions of endorsements, the thread above will reveal they're just snake oil.
    Thom likes this.
  20. EarlyMon

    EarlyMon The PearlyMon Moderator

    By the way, volume down +power to reset silicon varies by phone model - I looked yours up for you.

    On mine it's volume up + power, on others it's just a long power press, so don't expect that same button trick to work by default on your next phone.
    Thom likes this.
  21. Westphotog

    Westphotog Member

    Okay. I was not aware of the differences in what exactly went in to "clearing the cache partition."

    I'm clearing the cache and will refrain from using any of the app killers (ccleaner) and see if that corrects my issue. It was just really odd that both my phone and my wife's phone started doing the WiFi thing at about the same time. So if this works, great. If not, you may be right and there was a spike of some sort during the night while they were charging.
    EarlyMon likes this.
  22. EarlyMon

    EarlyMon The PearlyMon Moderator

    Please keep us all posted, someone may recall something I might have missed.

    And best luck! :)
  23. Thom

    Thom Guides Guide

    ... about what EarlyMon said ... if the problem disappears when you are in Safe Mode it is caused by an app that you added. Find the bad app.

    I muck about a lot with my phone ... I don't recommend this to everyone ... I personally do maintenance on my devices every Saturday ... one of the things I do every Saturday is to Wipe Cache Partition (it takes 7-10 minutes on my Droid Turbo).

    ... Thom
    EarlyMon likes this.
  24. Westphotog

    Westphotog Member

    I'll keep you posted. It shouldn't take more than a day to see if things have improved in the connecting to WiFi, because I would clear the processes with CCleaner, and it would connect. Then I'd drive to work and have to run CCleaner again to get my phone to connect to the work WiFi. If I don't have to run it over and over just to get back on wireless, it'll be an improvement.
    EarlyMon likes this.
  25. doogald

    doogald Guides Guide

    Here's a thread on androidcentral for somebody who had a similar problem who was trying to avoid a factory data reset. A cache partition wipe did not help; running in safe mode did.

    This person ended up deleting and reinstalling all of his apps, a few at a time. Even after reinstalling all apps, the phone stayed fixed.

    Anyway, see http://forums.androidcentral.com/showthread.php?p=4608277
    EarlyMon likes this.

Share This Page