Droid MAXX - Won't Type ContractionsSupport


  1. Hey all,
    I've had the Droid MAXX since it was released, and I've never had a problem with it as far as typing contractions goes. Recently, there was an automatic update that took place on my phone, and now the keyboard has changed. There's an emoticon button where the return button used to be, some punctuation marks are moved, and now suddenly, I can't type common contractions (specifically "don't", "they're", "you're").

    I have to choose from the suggestion box, which is kind of annoying (first world problems, right?). Anyways, I've tried nearly everything I can think of to fix this. And yes, I have tried the shortcut method, which doesn't work for some reason. If anyone else has had this problem, please let me know. Also, if you know how to correct this problem, please let me know as well.

    Thanks in advance!!

    Advertisement
    :
  2. doogald

    doogald Guides Guide

    In settings-language & input. Tap the gear icon next to google keyboard. Under text correction, auto-correction, is it set to modest (where mine is set), aggressive or very aggressive, or is it off? If it's off, does setting to modest fix this?
  3. Mine is on modest. Perhaps I'll try even lower. I'll let you know how that goes. Thanks for your advice!
  4. I tried all of the settings, and it still hates me haha
  5. Rumma

    Rumma Active Member

    You might consider SwiftKey or any other keyboard app from the store. It works great for me.
    Droid maxximus likes this.
  6. Somniferum

    Somniferum Well-Known Member

    +1 for SwiftKey. Although of course you shouldn't have to use a third-party app to type contractions, that's just crazy. It's a great keyboard though for many reasons (better predictions and cloud backup for example).
  7. doogald

    doogald Guides Guide

    I've also been using Swiftkey for a long time now, but just switched to the Google Keyboard, and typing "dont" auto-corrects to "don't" when I hit the spacebar. (It's also in the middle position above the keyboard.)

    I'm not sure what the issue could be. I suppose that you could try going into settings->apps, scroll down to Google Keyboard, and try one of two things:

    - tap "clear data" and see if that returns contraction replacement
    - tap "uninstall updates" and see if it works with the old version
  8. Somniferum

    Somniferum Well-Known Member

    I just stumbled across another reason to consider a third-party keyboard: Google is now banning words it considers inappropriate from the keyboard's predictions. The link is to a Wired article that looks at some of the 1,400 words (and counting) Google has banned, and how some of their choices make absolutely no sense. Kinda crazy.
  9. seVer

    seVer Well-Known Member

    that's why you type the word you want, press it in the word selection bar, and add it to your personal dictionary.
  10. SNeitzel

    SNeitzel Well-Known Member

    From the article...

    "The filter can be disabled in the Google Keyboard settings, which makes all words both swipeable and available for autocomplete."

    At least they are giving users that option, for now.
  11. For now, I downloaded the free trial of Swiftkey, but once it expires, I'm gonna give this advice a shot. It sounds like a really plausible solution, and I appreciate your input!
  12. I tried this option as well, and no matter what I did, it wouldn't let me add the words to my personal dictionary. It was so strange, because it used to allow for this option. :/
Loading...

Share This Page