Droid not connecting to WinVista


Last Updated:

  1. Thomas184

    Thomas184 Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    16
    Likes Received:
    0
    Here's the deal. Downloaded Motorola Media Link. I open it up select connect so I can connect my Droid to my pc ofcourse. This is were the problem starts to occur. When I select connect it tells me 1 handset found being my droid. I do mount the phone from the notification bar and always end up with detection failed. I have the option to click here to learn more and all it tells me is make sure you mount your phone. Any suggestions.
     

    Advertisement
  2. Thomas184

    Thomas184 Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    16
    Likes Received:
    0
    Another addition. I try to open it by selecting the drive, but again to no prevail.
     
  3. Groid

    Groid Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    358
    Likes Received:
    88
    I have Vista32 and had problems mounting also. I d/l the Moto drivers and still couldn't mount. I deleted the moto drivers. On the phone, i choose Settings, Applications, Development, and turned on USB Debugging. Now I connect flawlessly. If I turn off the USB debugging, I cannot connect. Also, at some point I opened Device Manager on the pc and found a usb root hub that showed an error condition. I deleted it, restarted, then mounting worked with usb debugging on.
     

Share This Page

Loading...