Droid not "seeing" music


  1. TheBeachBoy

    TheBeachBoy Well-Known Member

    So, my Droid is rooted running Lithium Mod 0.0.5 and everything is running just fine except that I can't "see" my mp3's. I've tried it in the default Music player and in DoubleTwist. I have the music folder in the root of the sdcard, but have tried moving it into a Media folder on the sdcard. I've moved the folder within the file explorer and through Windows Explorer when connected to my laptop via USB. When I go to the folder in the file explorer I can play them, but only 1 at a time. I've tried different ROMs and they all have this issue, so it may just be the fact that I'm rooted. Anyone run into this issue or have any ideas how to fix this? I've just been listening to Pandora in the car since I can't pull up my mp3's.

    Advertisement
    :
  2. PatHoge

    PatHoge Well-Known Member

    I've flashed most of the current ROMs and never had this problem. If nothing else works I'd copy everything from the SD card to my computer, then format the SD card and copy it all back. It might work.
  3. ndoren

    ndoren Well-Known Member Contributor

    None of your music apps look directly at the music files on your SD card. Instead, they look at a tagged database generated by a system process called "media scanner service" (android.process.media). Thus, if this process hasn't run, you won't see your mp3s in any music app, nor in fact your videos or images in the gallery. The media scanner runs at startup (reboot) and should also run once the SD card is remounted. Depending on how much music you have on your SD card, this process can take 20 or more minutes to complete.

    So, for whatever reason, this background process may not be running. Reboot your phone and go into settings->applications->running_services. You should see an entry called media scanning service (may look different from within a custom ROM... I use rooted FRG01B). If it's not listed, it's not running. You can also use the market app "autorun killer" to see if "media storage" is running after reboot.

    I don't know a thing about Lithium mod, but this process should be there. One way to jump start it is to download the market app "rescan media root" and click "re-enable media scanner." That might fix your issue.

    Also, as Pat Hoge pointed out above, if the media scanner is running, you may simply have an issue with your SD card. I will add one thing to his comment... you could also have a bad (ill-formatted) mp3 file. This could kill or hang the media scanner service. In this case it won't be enough to unload and reformat your SD card and restore your mp3s, as you will be restoring the mp3 that hangs the scanner. You may want to remove all of your mp3s and just try a few to see if they get recognized. The fact that NONE of your ROMs scan the SD card for mp3 media, may in fact point to an SD card issue or a bad mp3 file on that card. It has nothing to do with your being rooted. We are all rooted in this forum and we see our mp3s from within our audio apps (at least I do). Neall
    marvinrock likes this.
  4. TheBeachBoy

    TheBeachBoy Well-Known Member

    Thanks for the info; I'll try those ideas.
  5. TheBeachBoy

    TheBeachBoy Well-Known Member

    Fixed it...it was bad mp3's or something. Deleted the sub-folder they were in and now it shows everything else. Thanks for the help, everyone.
  6. ndoren

    ndoren Well-Known Member Contributor

    Glad to hear you are back in business! Neall
  7. marvinrock

    marvinrock Well-Known Member

    Almost 2 years later, this is still relevant - this solved the problem I've been having. All my notifications and ringtones changed to podcasts I had on my SD card... it was weird. My phone couldn't see any of my media, but there it was working in File Explorer!?

    here is where you can get the "Rescan Media ROOT" app
Loading...

Share This Page