Droid Razr says it's charging but isn't. Need helpGeneral


Last Updated:

  1. tpain569

    tpain569 Member This Topic's Starter

    Joined:
    Sep 4, 2012
    Messages:
    6
    Likes Received:
    0
    I got a Razr a few weeks ago and rooted it, all was fine until a few days ago it stopped charging. When I plug it in the charging icon starts but the percent never goes up and the phone continues to die. This is the third time in as many days that it's happened. I've tried AP SBF flash booting and pretty much every other boot option and eventually it starts working after enough tries.

    Anybody have any idea why this happening and/or how to fix it?
     

    Advertisement
  2. carracerz14

    carracerz14 Well-Known Member

    Joined:
    Feb 4, 2011
    Messages:
    1,154
    Likes Received:
    176
    Have you tried a different charger? My guess is your charger is shot. The phone would still recognize that it's plugged in so it would think it's charging even though it isnt
     
  3. MasterGadgets

    MasterGadgets Well-Known Member

    Joined:
    May 4, 2012
    Messages:
    152
    Likes Received:
    13
    Are you using a charger made for the Razr?? Many 'off brands' do not provide enough current to properly charge the phone.
     
  4. tpain569

    tpain569 Member This Topic's Starter

    Joined:
    Sep 4, 2012
    Messages:
    6
    Likes Received:
    0
    I first noticed it while using my friend's HTC charger which it has worked on before. I'm not plugged in using my old Commando charger that I've been using since I got it.
     
  5. razrclive

    razrclive Well-Known Member

    Joined:
    Aug 26, 2012
    Messages:
    181
    Likes Received:
    14
    Try plugging the usb lead from charger into a USB socket on your computer it should charge then. If it does then your charger plug is faulty.
     
  6. tpain569

    tpain569 Member This Topic's Starter

    Joined:
    Sep 4, 2012
    Messages:
    6
    Likes Received:
    0
    I tried using my computer but I get the same thing-- Charging, 20%-- still have the green light but no charging progress
     
  7. razrclive

    razrclive Well-Known Member

    Joined:
    Aug 26, 2012
    Messages:
    181
    Likes Received:
    14
    How long are you waiting for % to increase as it can take some time to see any charge increase.
     
  8. tpain569

    tpain569 Member This Topic's Starter

    Joined:
    Sep 4, 2012
    Messages:
    6
    Likes Received:
    0
    Hours
     
  9. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
    Sounds like you need a warranty replacement.
     
  10. euph_22

    euph_22 Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    2,634
    Likes Received:
    595
    Just to be clear, you have tried using a different cable to charge it, right?
     
  11. tpain569

    tpain569 Member This Topic's Starter

    Joined:
    Sep 4, 2012
    Messages:
    6
    Likes Received:
    0
    warranty isn't an option and I have tried different cables. I'm getting some response in BP only if i plug the charger in before in boots. But it seems like I only get another 10% every time I do it
     
  12. carracerz14

    carracerz14 Well-Known Member

    Joined:
    Feb 4, 2011
    Messages:
    1,154
    Likes Received:
    176
    Why isn't warranty an option?
     
  13. tpain569

    tpain569 Member This Topic's Starter

    Joined:
    Sep 4, 2012
    Messages:
    6
    Likes Received:
    0
    I bought it off ebay and I rooted it. So unless there's a way around that
     
  14. quickaudi

    quickaudi Well-Known Member Contributor

    Joined:
    Jul 15, 2010
    Messages:
    3,054
    Likes Received:
    407
    might try to see if there is anything in the charging port on the phone, and maybe pry out the connections a little for better contact
     

Share This Page

Loading...