Droid Tethering for all Operating Systems! (tested in Linux)


Last Updated:

  1. bthoward

    bthoward Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    243
    Rooting not required! Amiga, OS/2, and several others need not apply but this will cover most of you. Providing most of you have Windows, Mac, or Linux.

    I simply used these instructions:
    Tether an Android Phone Using Proxoid - Linux Magazine Online

    Code (Text):
    1. Only difference is that instead of putting what he did into his file put this:
    2. SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bb4", ATTRS{idProduct} =="0c01", MODE="0666", OWNER="brett"
    3. SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bb4", ATTRS{idProduct} =="0c02", MODE="0666", OWNER="brett"
    4. SUBSYSTEMS=="usb", ATTRS{idVendor}=="22b8", ATTRS{idProduct} =="41db", MODE="0666", OWNER="brett"
    Change brett to your username. You may have to reload the rules (or just reboot) before things finally fully take off for you but I'm posting this tethered through my phone using this capability in Ubuntu 9.10 right now.
     
    Advertisements
  2. blazingwolf

    blazingwolf Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    214
    Location:
    Virginia
    Very nice find. Thank you. :D
     
  3. Ainvar

    Ainvar Active Member

    Joined:
    Nov 9, 2009
    Messages:
    31
    Location:
    NoVA USA
    Thanks will try this on my EEE 901 running Ubuntu 9.10
     
  4. bthoward

    bthoward Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    243
    I wasn't able to get pidgin to connect properly in what little testing that I did. I also can't get vpn access to work properly as network manager isn't managing the connection and therefore wont let you initiate its vpn connections. If you get this stuff please post. Ill try again later but for now meh its there. Kinda worthless for me without vpn but we shall see. All in due time.
     
  5. aussiedude

    aussiedude Member

    Joined:
    Nov 16, 2009
    Messages:
    6
    Unfortunately it did not work for me :(
    I get device not found when I run adb
    At first I thought it was because my product id was different (which is 41d9 btw). Changed the rules file to reflect that, no go, even after restarting udev and rebooting my system with the droid attached as suggested on the developers page.
     
  6. NoisufnoC

    NoisufnoC Member

    Joined:
    Nov 22, 2009
    Messages:
    8
    Nice find. I'll give this a shot with my Dell Mini9 running Ubuntu 9.10 :D
     
  7. bthoward

    bthoward Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    243
    Are you sure that you turned on USB debugging and rebooted? Also if you're using any other USB cables try using the one that came w/ the Droid.
     
  8. aussiedude

    aussiedude Member

    Joined:
    Nov 16, 2009
    Messages:
    6
    Yep, did all of the above. I ended up replacing the device as it would no longer boot (unrelated to this for anyone concerned it might brick their phone). Will try again.
     
  9. aussiedude

    aussiedude Member

    Joined:
    Nov 16, 2009
    Messages:
    6
    Ok, so I tried again;
    error: insufficient permissions for device
     
  10. bthoward

    bthoward Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    243
    I think your configuration file is either setup wrong or you need to restart to make the file run...
     
  11. aussiedude

    aussiedude Member

    Joined:
    Nov 16, 2009
    Messages:
    6
    Rebooted both the phone and my eee-pc, same error. Here is the content of my config file:
    Code (Text):
    1. SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bb4", ATTRS{idProduct} =="0c01", MODE="0666", OWNER="graham"
    2. SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bb4", ATTRS{idProduct} =="0c02", MODE="0666", OWNER="graham"
    3. SUBSYSTEMS=="usb", ATTRS{idVendor}=="22b8", ATTRS{idProduct} =="41d9", MODE="0666", OWNER="graham"
     
  12. bthoward

    bthoward Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    243
    have you tried running adb w/ sudo privileges?
     
  13. iefbr14

    iefbr14 New Member

    Joined:
    Nov 24, 2009
    Messages:
    1
    I encountered the
     
  14. aussiedude

    aussiedude Member

    Joined:
    Nov 16, 2009
    Messages:
    6
    @bthoward Yes I tried running as sudo, same problem

    @iefbr14 Thanks, I'll give that a shot when I have an opportunity
     
  15. bthoward

    bthoward Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    243
    I'd think that what aussiedude mentioned was a restatement of what was in the article. So yea hopefully you can follow that and get there from here.

    The only issues i've got so far is that the connection isn't managed by NM so you can't use its VPN facilities and you can't properly resolve DNS addresses from the console because its trying to go out directly and its not accepting the system wide Proxy setting that I've already configured.

    I think that Pidgin wasn't working either.

    I find that usually I have an ability to get on from the locations where I frequent so its not all that needed. But one of these days when I really need it I'll move forward and debug that further.
     
  16. IslesFan

    IslesFan Member

    Joined:
    Nov 16, 2009
    Messages:
    5
    Location:
    Long Island, NY
    Works great in Mac OS X.
     
  17. Shannon_VanWagner

    Shannon_VanWagner New Member

    Joined:
    Dec 19, 2009
    Messages:
    3
    Location:
    Seattle, WA
  18. d-man

    d-man Active Member

    Joined:
    Dec 23, 2009
    Messages:
    25
    +1 for Shannon V.'s suggestion.

    azilink works great, and since it uses VPN rather than a proxy, you can use it with any internet applications on your laptop, not just http.
     
  19. 3devious

    3devious Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    1,362
    Location:
    Washington, DC area
    Is the source for that linux method available? I am hoping to recompile it to Xandros to work with my stock EEE PC. Is that a fool's errand?
     
  20. d-man

    d-man Active Member

    Joined:
    Dec 23, 2009
    Messages:
    25
    3devious - The only things you'll need to install on the Linux side is:
    1. The Android SDK - it's Java, so no compilation needed
    2. OpenVPN - it's open source of course - I don't know about Xandros, but it's probably easier to get the packages for your distro rather than compiling it yourself

    Have fun!
     
    3devious likes this.
  21. 3devious

    3devious Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    1,362
    Location:
    Washington, DC area
    I now have a project tomorrow morning. :) Thanks.
     
  22. farmerjohn73

    farmerjohn73 Member

    Joined:
    Feb 11, 2011
    Messages:
    9
    I am using motorola quench xt3 xt502. The above method is failing me. When I connect the phone to pc, it is not recognizing it. I had to buy the usb cable from the service centre, as no cable came with the phone. Is this a reason why my phone is not recognised ?

    pls help.
     
  23. rottenpixies

    rottenpixies Well-Known Member

    Joined:
    Nov 28, 2010
    Messages:
    53
    Location:
    New York

Share This Page