Droid won't power on w/o battery pull, any ideas?Support


Last Updated:

  1. jstapels

    jstapels New Member

    I've having an issue with my Droid and I'm hoping the experts on this forum can help. The problem is that every time my droid is restarted or powered off, it's very difficult to power on, often requiring a battery pull for an extended amount of time. However, once the phone is up and running, everything works fine again (until I reboot it).

    I've tried the following things to try and solve the problem:
    - Wipe all data, partitions, cache
    - New battery
    - Tried various recovery images
    - Eventually did a full RSDLite wipe using the latest FRG83G to back to "full stock"

    None of that helped so my assumption is that the hardware itself it to blame (eg. a bad capacitor or voltage regulator). However, before I completely give it up for "dead" I was wondering if any of the experts hear has any ideas...

    Thanks.

    Advertisement
  2. AngryHatter

    AngryHatter Well-Known Member

    Tried a different battery, I assume?
  3. jstapels

    jstapels New Member

    I did which didn't seem to have any affect. However, and this part is really strange, my phone suddenly started working normally again about 3 days ago after working incorrectly for about six weeks. I have no idea what changed unfortunately as I would like to let others with similar problems know the solution.

    My final guess is that this problem is the result of a poorly manufactured chip (such as voltage regulator), or perhaps a floating pin that was not properly grounded. If I find I more I'll update this thread.

    Thanks to all who may have spent a few moments thought on my problem.

Share This Page