Droid X ADB Issue - Ubuntu


Last Updated:

  1. anaphora68

    anaphora68 Well-Known Member This Topic's Starter

    Joined:
    Apr 20, 2010
    Messages:
    194
    Likes Received:
    38
    Hi All -

    Question. I am running into a weird issue with Ubuntu 10.0.4 and my Droid X. For some reason, I cannot get ADB to recognize the X.

    Can anyone tell me if there is a config file I need to edit? I have tried everything imaginable.

    And yes, I do have Win 7, but I want to be able to use Linux, it's personal preference. I have a laptop running Ubuntu that recognizes the X, is there a config file I need to copy?

    Any help is appreciated...
     

    Advertisement
  2. Dtatch

    Dtatch Well-Known Member

    Joined:
    Jul 23, 2010
    Messages:
    129
    Likes Received:
    25
    Check if JDK is present in your system because ADB will not work without out. Also make sure you have updated the packages within your SDK.
    If JDK is present in ubuntu and your packages are up-to-date place the SDK folder in your home directory so ADB will be easier access.

    (username)@ubuntu:~$ android-sdk-linux_86/tools/adb devices

    If the device still doesn't show up create a rules file.

    sudo gedit /etc/udev/rules.d/70.android.rules

    Copy and paste to the file:

    SUBSYSTEM=="usb", SYSFS{idVendor}=="22b8", MODE="0666"

    Save and exit

    Unplug your phone and plug it back it and search for adb devices again and hopefully your device shows up.
     
  3. hawaiian1der

    hawaiian1der New Member

    Joined:
    Oct 11, 2010
    Messages:
    3
    Likes Received:
    0
    Is it possible to make this thread a sticky or put along with all the other little howto's/guides? This was helpful for me, not sure if anyone else was helped by it.
     

Share This Page

Loading...