Droid X root last resort


Last Updated:

  1. SeanKillian

    SeanKillian New Member This Topic's Starter

    Joined:
    Apr 27, 2012
    Messages:
    2
    Likes Received:
    0
    I have seen tens of these threads of people begging for help because they have read everything they need to do, and they still cannot get their phones rooted/flashed, and yet, here I am making the very same request! I've just now "SBFed" my Droid X back to the stock Android 2.2. I've successfully rooted my phone using "z4 root" and have tested it by using "su" in a terminal and getting the pound-sign. I can also remount system rw and create a file in system. I cannot, however, flash "Clockwork Mod" from ROM manager, because every time I do, it goes through the installation, and says everything worked. When I hit "Reboot Recovery," however, I simply reboot android. No recovery at all. When I use adb to reboot to recovery, I just go to stock recovery. I don't entirely know what I need to do to get this to work. I've used "Droid X Bootstrapper" and that got me into Clockwork, but when I flash *ANY* ROM, it doesn't work. I'm stuck at the Motorola "M" logo indefinitely. I've tried wiping the Dalvik cache and wiping the cache in addition to a factory reset before and after flashing (in two different attempts) to no avail.

    Last week I was able to get Cyanogenmod 7.1 on it, but it was absolutely terrible. The camera didn't work and I couldn't play any videos.

    I'm just looking for something that's fast. I don't care about features- actually, if less features would make it faster, I'd be perfectly fine with that -if I could run it from a terminal, I'd be fine with that!
     

    Advertisement
  2. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    start over and SBF to GB not Froyo. Then proceed with rooting GB using it's method. After that you can use either the Dx bootstrap by unchecking usb debugging or you can just use the Droid2 bootstrap.
     
    SeanKillian likes this.
  3. WhoDoo Voodoo

    WhoDoo Voodoo Well-Known Member

    Joined:
    Mar 11, 2012
    Messages:
    283
    Likes Received:
    98
    Liberty can't be beat.
     
  4. ylexot

    ylexot Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    2,336
    Likes Received:
    404
    Define "indefinitely". 30 seconds? 1 minute? 5 minutes? 10 minutes? The first boot is veeeeeeerrrrrrrrrry long and you may not have waited long enough.

    I don't know anything about ROM Manager...never used it, so I can't help you there. I always used bootstrap.

    Also, why are you still on Froyo? You might want to consider upgrading to Gingerbread. That could also be a reason your ROMs are failing. You have to use a ROM that is designed for Froyo. The Gingerbread ROMs (all of the latest ROMs created) will fail if you are starting from Froyo.
     
    trophynuts likes this.
  5. SeanKillian

    SeanKillian New Member This Topic's Starter

    Joined:
    Apr 27, 2012
    Messages:
    2
    Likes Received:
    0
    Huh. My reason for going with FroYo is simply because after upgrading to GingerBread, my phone seemed slower and I lost root. Z4mod doesn't seem to work with GB. I'll try upgrading to GB again, but I was *not* a fan before :-\
     
  6. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    it's noted that Z4 only works with Froyo.

    With GB the methods are different. It's perfectly ok if you want to run Froyo just make sure you're flashing a Froyo rom on it and not a GB rom. The only problem is Froyo roms will be severely out of date.
     

Share This Page

Loading...