DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf)


  1. themib

    themib Well-Known Member

    edit:
    in cwm recovery use volume buttons to scroll
    camera button to select
    power button is used only to go page back
    if there is no page back, screen goes blank

    in android recovery
    volume buttons to scroll
    power button to select

    I think you have found, most of the ways not to do it
  2. izzy1665

    izzy1665 New Member

    I like hearing we can finally root Android 2.3.4/4.5.621 but I have worries as I installed LauncherPro from Google PLAY onto my DroidX a few hours ago and several of my apps do not show up on the display when I launch them, I have no control over the MP3 player while it plays a song or when it is over and while taking a video an hour ago using the stock camcorder app it froze completely,. I had to pull the battery just to restart it. I have since uninstalled the LauncherPro and everything seems fine now.

    I do admit that I am worried about what happens if the ROOT process bombs somewhere along the way. What are my options at that time?
  3. mgaylor

    mgaylor New Member

    I'm hoping you guys can help. i bought a used DX off ebay that already has .621 on it ive downloaded and burned the cd and have tried to root my dx several times but the first thing it says is rm failed for /data/preinstall_md5/magic md5/magic.md5. No such file or directory. and then proceeds thru the rest of the rooting process saying the installation everything else has failed. Any thoughts???

    Android Version
    2.3.4

    Baseband Version
    BP_C_01.09.15p

    Kernel Version
    2.6.32.9-g1282440
    mcbk83@il93lnxdroid08#1

    Build Number
    4.5.1_57_DX8-51
  4. themib

    themib Well-Known Member

    restart root program, try again
    depends on where in the process
    worst case you just don't have root

    you are enabling usb debugging?
    charge only mode? try pc mode
  5. izzy1665

    izzy1665 New Member

    I guess I neglected to say I have not ROOTed it yet. It is still stock. If the root process has problems, will it lock the phone up or somehow make it useless to me or can it be somehow flashed back to a usable Android version?
  6. themib

    themib Well-Known Member

    and you neglected, to read my post
  7. BSH

    BSH Well-Known Member

    You need not worry about bricking the phone. Go here, and you can restore back to a fully original state, without root, without mods. I've rooted, failed to root, had the phone flake out with crashes, and run this restore about 3 or 4 times now. I'm no Linux guy, but the instructions in the thread above are great. You have nothing to fear with this phone.
  8. BSH

    BSH Well-Known Member

    I ran into the same thing. If you followed the steps exactly, and the phone went through the entire process, you should find Superuser among your apps, and it should be rooted. You can try downloading Titanium Backup, which requires root to work, or Bootstrap (for Droid 2 NOT Droid X) which will install recovery where you can flash other roms, which also requires root. If they don't work, you don't have root. After going through this process a half dozen times in the past two weeks, I no longer notice the warning you notice above, because it doesn't matter.

    My understanding is this: the rooting script is trying to remove a directory that it needs to be gone before it can root. If the directory isn't there, it can't remove it (hence, rm fails), but since that directory isn't supposed to be there, the rest of the rooting process works. I'm a newbie, not a hacker, so I may be wrong. But I went through the same thing, and I've now rooted this phone several times in the past couple weeks with the method described in this thread.
  9. spikebball96

    spikebball96 New Member

    i used this method to root my droid and after i flashed a rom it went into a boot loop. can i get it out of the boot loop through this CD? i have already tried the obvious (factory data reset/wipe cache/flashing stock rom/flashing different custom rom) and nothing works. Please help
  10. BSH

    BSH Well-Known Member

    From my efforts, I find two CD's are necessary for solving any issue with the DX - SBF to a completely original state, and the root CD described at the top of this thread. Reset/wipe, root, fail, crash, SBF, reset/wipe, root. I've run through that sequence at least three times (and I hope I've got to a stable point, assuming I don't muck things up again). If you can get to the boot loader, you can restore this phone.
  11. ToXicBlonde

    ToXicBlonde Member

    My EX just gave me his old Droid X and I love am I am trying to do some things but it seems it all needs ROOT.....yes I am blonde and I'm Clueless about this. I am uneasy messing with the root system so I want to wreck my phone !! Any help??

    I am also getting serious battery drain issues so any help on that would be great too!!! I have read so many articles and forums and other stuff my head is spinning!!! :alberteinstein:

    Thanks everyone!!!
  12. themib

    themib Well-Known Member

    go to settings/system/about phone/system version
    should be 4.5.621.... or 4.5.602......
    use this if 4.5.621
  13. themib

    themib Well-Known Member

    sorry I'm watching over 20 threads on this root method
    Magic MD5 Root 2.3.4 for D2, R2D2, D2G, DX and 2.3.5 for DX2

    yes that is fine, it is just verifying that it has pushed or removed files as needed depending on where in the process it is

    will update op
  14. ToXicBlonde

    ToXicBlonde Member

    Yes it is 4.5.621 but i'm still even more confused...is there an app to get that will allow me access to the root for editing or being a novice w this should i leave it alone?

    Thanks for your help....not trying to overload you :(
  15. themib

    themib Well-Known Member

    use the program in op to root

    titanium backup, to backup or freeze apps

    d2 bootstrap, rom manager (to update cwm to dx 2nd init) to flash roms and make backup of system

    root browser or file manager, to re/move files
    ToXicBlonde likes this.
  16. ToXicBlonde

    ToXicBlonde Member

    Im sorry i don't understand any of this all this apps tell me I need root access! and I don't know how to get that i seem to have gotten the device stable enough to get more battery life which I guess was my original goal I just wanted to remove some of the factory installed apps that I don't want

    Thank you for your time....I best not mess with it anymore.

  17. ToXicBlonde

    ToXicBlonde Member

    PS....I did install File manager but I am not sure what "use the program in op to root" is. I appreciate your patience

    I also installed Watchdog the other day and was able to track an offending app and fix that. it seems to have helped the battery drain....4 hours of being idle then dead battery didn't seem right!

  18. themib

    themib Well-Known Member

    op= original post or poster
    in the first post is a link to a rooting program Droid2_D2G_DX_DX2-RootCD-2012.iso
    download burn to cd or usb drive
    follow instructions in op
  19. IndyRoadie

    IndyRoadie Well-Known Member

    This could not have been easier! Worked flawlessly..
    Thanks OP!
  20. mangler1055

    mangler1055 Well-Known Member

    Just do clarify, as i'm planning to do this for a friend's phone that's on 621. I'm only used to HTC and Samsung phones so i'm not familiar with bootstrap

    - Follow the disk instructions, which will give me root on the device.
    - Install the MotoDx2 Boot strap. Run this software i would assume and something happens...
    - Then run rom manager and update to recovery to dx 2nd init.

    Then i can boot into recovery and install either blur or aosp roms?

    What's the story with bootstrap anyhow? how does that work togther with rom manager? I've ready a bunch of different threads, but my head is spinning. Do i have to do anything special when i want to boot into recovery? Do i need to install dx2 bootstrap on every rom I flash?

    Thanks!
  21. themib

    themib Well-Known Member

    Install bootstrap apk, open app, tap install (top option), then Rom manager,
    Best to ask, in Rom's thread, but most Custom roms come with bootstrap installed, with power down options
    Power/power off/ reboot cwm
    mangler1055 likes this.
  22. mangler1055

    mangler1055 Well-Known Member


    So we ran the CD and successfully got root.

    Installed the DX2 bootstrap, ran it and hit the top button. Got the success message.

    Ran Rom Manager, installed DX 2nd Init recovery.

    at this point, we cant get it to actually boot into CWM recovery. We've tried pressing the reboot recovery option from rom manager (just reboots the phone).
    we tried rebooting into recovery using the button in the bootstrap app. That just powers it down.

    We also tried powering down, and then powering up holding the home key. and then doing the vol up and down keys. This just takes us to the android stock recovery.

    Any ideas?

    Thanks.
  23. themib

    themib Well-Known Member

    you may need to use bootstrap to get to cwm, but rom manager was the only way to upgrade cwm
  24. mangler1055

    mangler1055 Well-Known Member

    I think i tried that by pressing the 'boot recovery' button from bootstrap. Is that what you mean?

    thanks for the quick reply
  25. themib

    themib Well-Known Member

    which bootstrap did you install? dx2?
    use d2 bootstrap
    mangler1055 likes this.
Loading...

Share This Page