Easiest & Fastest way to get your MSL Code

Last Updated:

  1. AndroHackster

    AndroHackster Member

    This is the Easiest way to get your MSL code for your Samsung Prevail including all CDMA Android smart phones. Just go to your Android Market and download Terminal Emulator.

    And Type in "su" (for super user access)
    And then type "getprop ril.MSL" (then enter to get you Device's MSL code)

    akmsr, Vex8ion, Rarewolf and 4 others like this.
  2. wyelkins

    wyelkins Well-Known Member

    Did not work for me. Said only for HTC phones. It tried anyway but could not get it. Is there some way around this?
  3. hate

    hate Well-Known Member

    if your phone is rooted download terminal emulator from market.
    "su" turns $ to #
    "getprop ril.MSL" to get MSL number
    LzrdKng74 likes this.
  4. AndroHackster

    AndroHackster Member

    Ill look into it since I do remember seeing different versions of it. But it has worked on my prevail just fine.
  5. inigomontoyasr

    inigomontoyasr Well-Known Member

    I agree. This way is guaranteed to work.
  6. johnny424

    johnny424 Well-Known Member

    i too used this way to get my msl....very easy..didnt find out untill a few trys later that it is case sensitive...but other then that worked awsome
  7. redneckrebel

    redneckrebel Well-Known Member

    Same here. Easy as pie, and if you can't do it that way you probably ought not be messing with anything that requires the MSL anyways.
  8. AndroHackster

    AndroHackster Member

    I agree with all of you sorry for putting up the wrong info. probably the reason that mine worked is because I made a custom system with some HTC similarities.

    For now the fastest way Is to download terminal emulator from the market.
    Type "SU" allow super user access
    Then type "getprop ril.MSL". And enter to get the MSL code for your device.

    Sorrry for my wrong info in the first post.
  9. Topken

    Topken Well-Known Member

    Anything you do in linux is case sensitive. That is the way linux is coded and since android is based off a common base its coded that way as well.
    johnny424 likes this.
  10. Kamel

    Kamel Well-Known Member

    jmzpantera likes this.
  11. redgs95

    redgs95 Active Member

    Get connectbot from the market and then type( getprop ril.MSL ) don't us the quotes.
    jmzpantera likes this.
  12. johnny424

    johnny424 Well-Known Member

    i didnt know that lol...trial and error...the only way learn lol
  13. kolosus

    kolosus Well-Known Member

    I've come across some phones that if you do that you just get a blank line. No MSL number.

    I've done it on my phone and gotten it but on some others I didn't get it. Anyone else having this issue? Is it the version of Android the phone is on?
  14. lynx1

    lynx1 New Member

    The best way to do it on the prevail that I know of is by downloading alogcat from marketplace open it press menu > filter type in msl press the home key then dial ##data#. Then when asked to enter msl just enter random numbers press okay. Now go back to alogcat it should be there and look something like this: I/MSL_Checker( 220): MSL result : ******.

    For some reason when you enter the wrong msl it gives you the right one when looking at the logs with alogcat.
    This method works with both rooted and unrooted prevails.
    wyelkins likes this.
  15. chrislrob

    chrislrob Member


    I'm rooted. when I pull up the soft keyboard, it doesn't type anything--nothing appears on the screen. Any ideas?

  16. kolosus

    kolosus Well-Known Member

    I've had this problem too. getprop ril.MSL works... most times. Sometimes it only inserts a carriage return and exits with a blank line. Not helpful. There is the alogcat method mentioned just before your post but I have yet to make it work. :(

    I have another method.

    It is a bit long winded. But you're guaranteed to get the MSL for your device and it works even if your account with boost is inactive. Good luck.

    PS: Now if I only knew how to do this with non boost phones...
  17. sharney

    sharney New Member

    Yep, on my Samsung Transform Ultra (boost mobile), it does not show up in the 255 line long getprop results when getprop is ran with no arguments. It still shows up with 'getprop ril.MSL' however.

    The reason I am posting on this old thread is because I have developed a very simple app to display the MSL code, this way it can be accessed without a terminal app or adb shell.

    Ladies and Gentlemen, I present Get My MSL:

    It is free, and ad-free, and needs no extra permissions. At less than 50kB the apk does not take up much space, so I hope this may be of use to somebody out there!

    Sofar is tested on at least two samsung: SPH-M930 and SPH-D700, will work on any phone that has property ril.MSL set.
  18. wyelkins

    wyelkins Well-Known Member

    Thanks for the app! It works! This is now definitely the easiest and fastest way to get your MSL! LOL.
  19. rmivuxgc

    rmivuxgc Member

    Galaxy Pocket Rooted
    I also get blank line only
  20. EarlyMon

    EarlyMon The PearlyMon Moderator

    The logcat and getprop tricks are unreliable. Use MSL Reader or try the app listed above.
  21. thepiecesfit

    thepiecesfit Member

    This method no longer works on Jelly bean 4.1.2 the file physically does not exist on the file system. Rooted or not. I just called my carrier and got the MSL. F it! :)
  22. thejerk

    thejerk Well-Known Member

    muchas gracias. had my s2 flashes, couldnt get past this dumb MSL screen. thankfully, i was able to get the data i needed with your advice and i can access what i need to now :)

Share This Page