Root Easiest Root Method for Triumph(No Root App or Computer Involved!)

Discussion in 'Android Devices' started by b_randon14, Aug 20, 2011.

  1. b_randon14

    b_randon14 Well-Known Member
    163

    Aug 13, 2011
    910
    628
    163
    Pizza Delivery Driver
    Somerset, KY
    So after poking around on the Motorola Triumph for a little bit after rooting using Gingerbreak I noticed a couple things that caught my eye. First off I noticed that /system is mounted as read-write from boot, meaning no root needed to mount the system as read/write to modify files, however you still need to have root permissions to modify files with certian permissions where only root can write to the file(i.e. change the file). I was looking in /system/xbin and noticed that there was a file that came on the phone called sudo. Anyone who has used Ubuntu knows that sudo is the root access binary(much like su) that ubuntu uses to grant root privileges. After seeig this I got curious and opened my terminal emulator and typed in sudo, and it gave me the # symbol denoting I had root access. Just to be safe and test it out, I unrooted my phone(which removed the su binary and Superuer.apk from /system/bin and /system/app respectively.) I rebooted my phone and checked to make sure I did not have root access. Autokiller said it could not gain root, as did Titanium Backup. I then opened my Terminal Emulator and typed in sudo. It gave me the # symbol again. So i decided to try symlinking sudo to /system/bin/su and /system/xbin/su(the directories the su binary is normally located in) and sure enough after a reboot all my root apps worked! So essentially this phone was "rooted" from the beginning.

    So for everyone who doesn't want to fool with installing a root app to root thier phones(i.e. gingerbreak) or hook it up to a computer and use superoneclick or somthing of that nature, you can do it quickly and simply using Android Terminal Emulator(free on the market) and a couple commands. NOTE:(Rooting this way will not install Superuser.apk so you won't get prompts to allow apps root access, its much like the root that Joeseph Mother uses in his kernels.)

    Step 1: Download Android Terminal Emulator from the market.

    Step 2: Open up the Emulator and type in sudo, you should get the # symbol.

    Step 3: Type in the following code:
    Code (Text):
    1. ln -s /system/xbin/sudo /system/bin/su
    2. ln -s /system/xbin/sudo /system/xbin/su
    Step 4: Reboot and you should have root access. NOTE: This will not install busybox, so if you wish to have busybox you will have to install it from the market or manually. This just provides you with root access.

    If you have any issues pm me, and if you come across apps that do not work with this root method let me know and I will work to see if I can figure it out.


    *Video Guide by LucaBrassi. Thanks for putting this video together and getting my method noticed!
    Terminal Root Method by LucaBrassi
     

    Advertisement

    ryandpd, g60madman, Izzard and 10 others like this.
  2. ziggy46

    ziggy46 Well-Known Member
    213

    Aug 14, 2011
    1,688
    612
    213
    Being a pain in the a$$! LOL
    Chambersburg, Pa
    worked like a charm! i also unrooted and tried this... i also did a root check with joey krim's root checker app without rebooting. great find! :D
     
    mundane24 likes this.
  3. someguy43210

    someguy43210 Well-Known Member
    38

    Jul 20, 2011
    136
    24
    38
    Thanks for the tip. However you can install superuser.apk afterward and it'll work right?
     
  4. JollyRoger87

    JollyRoger87 Well-Known Member
    53

    Jul 27, 2011
    403
    85
    53
    UPS
    Phoenix, Az
    Jesus this thing really is an open door (locks never installed and the door knob drilled out lol)... WOW!

    Awesome find though
     
  5. ziggy46

    ziggy46 Well-Known Member
    213

    Aug 14, 2011
    1,688
    612
    213
    Being a pain in the a$$! LOL
    Chambersburg, Pa
    yes superuser will still work
     
  6. mcvanta

    mcvanta Well-Known Member
    16

    Aug 4, 2011
    98
    7
    16
    But how do i unroot with this method ?
     
  7. b_randon14

    b_randon14 Well-Known Member
    163

    Aug 13, 2011
    910
    628
    163
    Pizza Delivery Driver
    Somerset, KY
    Dude I don't even think there is a door there, it's just an open doorway lol!! They provided us with everything we needed. If you look in /system/app there is even a terminal emulator app but it doesnt show up in the app drawer so i dont know how to access it so i just downloaded android terminal emulator.

    To unroot using this method you just open the emulator and type sudo then type this:
    Code (Text):
    1. rm -rf /system/bin/su
    2. rm -rf /system/xbin/su
    I'm going to make a zip that symlinks sudo(which will give you root) and install busybox 1.18.4 to /system/bin and system/xbin so that you can get easy root & busybox from CWM recovery.
     
  8. LucaBrassi

    LucaBrassi Well-Known Member
    18

    Aug 9, 2011
    64
    10
    18
    Adult Foster Care Group Home Manager
    Northern, MN
    Hey guys im starting a video tutorial series with this phone if you feel so inclined check out my tutorial for this method

    Video Series

    Props to b_randon for figuring this out if anyone needs ill make a tutorial on unrooting this device using his unrooting method as well... any takers?
     
  9. mundane24

    mundane24 Well-Known Member
    43

    Jul 28, 2011
    144
    32
    43
    i was able to root but somehow this unroot method doesn't work for me. it says:

    Code (Text):
    1. rm failed for -rf, No such file or directory
    i typed 'sudo', got the pound sign # i then type 'rm -rf /system/bin/su' then i press the 'enter' button and that rm failed msg shows up. am i doing something wrong? :thinking:
     
  10. jjwla

    jjwla New Member
    5

    Aug 24, 2011
    3
    0
    5
    finance
    Los angeles
    Hello, I am not a programmer, but it sounds like your method is simpler than using Gingerbreak 1.2. I would prefer not to run that program, since I have already customized my launcher and downloaded many apps from the market--and don't want to lose the screen/app configuration.

    I am trying to barnacle tether the triumph(using the MTU=1472 solution from virginusers.com) so I can wifi with my Asus Netbook. Once I use your "root" method, can you describe the next steps I need to follow? Or do I just run Barnacle as is?

    Thank you.:)
     
  11. northeimcustom

    15

    Aug 21, 2011
    16
    0
    15
    How do i unroot after using this metheod?????
     
  12. northeimcustom

    15

    Aug 21, 2011
    16
    0
    15
    i have tried the method above,


    rm -rf /system/bin/su
    rm -rf /system/xbin/su


    and i also get a rm failed for -rf, no such file for directory message


    PLEASE HELP QUICK!
     
  13. Manicor

    Manicor Active Member
    16

    Apr 1, 2011
    26
    6
    16
    sudo

    rm /system/xbin/sudo /system/xbin/su
    rm /system/xbin/sudo /system/bin/su
     
    fofopuka likes this.
  14. northeimcustom

    15

    Aug 21, 2011
    16
    0
    15
    some how i got it unrooted, but now i cant get it back rooted

    i type sudo

    then get a failed permission error

    any ideas how to root now??
     
  15. b_randon14

    b_randon14 Well-Known Member
    163

    Aug 13, 2011
    910
    628
    163
    Pizza Delivery Driver
    Somerset, KY
    Probably run Gingerbreak. By any cahnge had you installed superuser after rooting this way? For some reason when superuser copies the su binary it uses over, it messes with the permission on sudo and makes it to where after unrooting, it no longer works. I wrote this guide and intended it to not be used with superuser, but you know how people are and they freak out without superuser even though its no more protection than not having it. Just run gingerbreak and you should be rooted again!
     
  16. ziggy46

    ziggy46 Well-Known Member
    213

    Aug 14, 2011
    1,688
    612
    213
    Being a pain in the a$$! LOL
    Chambersburg, Pa
    thats what i kinda thought! but i like superuser cause it makes me "feel" safer... LOL :D
     
  17. b_randon14

    b_randon14 Well-Known Member
    163

    Aug 13, 2011
    910
    628
    163
    Pizza Delivery Driver
    Somerset, KY
    Yeah i understand. My brother has a captivate, and he is a much better android/linux guy than I am(he was messing with linux like 10 years ago) and all the ROMs he's ever used for the captivate uses superuser so he is just used to it and he prefers it, but yeah malware uses root exploits(like gingerbreak psneuter, ratc, etc) to gain root privileges without calling on /system/bin/su or /system/xbin/su. So even with superuser.apk, you wouldn't see a notification when a malware app using gingerbreak gained root access and started deleting stuff lol!!!
     
  18. ziggy46

    ziggy46 Well-Known Member
    213

    Aug 14, 2011
    1,688
    612
    213
    Being a pain in the a$$! LOL
    Chambersburg, Pa
    so basically you can be under attack without even being rooted right? LOL :D what rom is your brother running on his captivate? and is it kb1 based or froyo based? i upgraded my moms phone to froyo and it has some bugs, so i want to revert to 2.1 and then install cognition 4 :p
     
  19. Claghorn

    Claghorn Well-Known Member
    43

    This may be new in newer versions of superuser, but after making the symlinks to sudo, attempting to install the market version of superuser wouldn't work. When I told it to check for updates to the su binary, it would always give an error that it couldn't find the existing binary.

    Removing the symlink, and making a copy of sudo to su, then chmodding su to be setuid worked like a charm though. I now have the market su on my Triumph. (Though I suppose if I want slightly greater security, I should now make the old sudo app a symlink to the new su).
     
  20. isaac32767

    isaac32767 New Member
    5

    May 25, 2012
    2
    0
    5
    This actually works! Mind boggling.

    Has anybody tried this on the Sprint version of the Triumph? They might be a little less sloppy than Virgin Mobile.
     
  21. Mobstergunz

    Mobstergunz Well-Known Member
    313

    Sep 5, 2011
    2,896
    1,444
    313
    Reading, PA
    Sprint Version of the Triumph??? they have one?
     
  22. agentc13

    agentc13 Daleks Über Alles
    VIP Member
    823

    Aug 31, 2011
    7,916
    5,482
    823
    Skaro
    No. There isn't such a thing.
     
    Mobstergunz likes this.
  23. Mobstergunz

    Mobstergunz Well-Known Member
    313

    Sep 5, 2011
    2,896
    1,444
    313
    Reading, PA
    Thanks for clearing that up i got confused for a sec and was searching for one
     
  24. sharpe351

    sharpe351 Well-Known Member
    43

    Jun 23, 2011
    232
    41
    43
    I think boost mobile offers the triumph now.
     
  25. agentc13

    agentc13 Daleks Über Alles
    VIP Member
    823

    Aug 31, 2011
    7,916
    5,482
    823
    Skaro
    Nope, I don't believe so.
     

Share This Page

Loading...