Root Easiest way to root GT540 running 2.1! Now EVERYONE can root!

Discussion in 'Android Devices' started by Nirob, Nov 19, 2010.

  1. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    Many(along with me) had failed to root their GT540 running 2.1 with the previous One-Click Rooter.. Don't feel down, now we can root too! With just one-click! This one is more simple... ;)

    -Enable USB Debugging Mode, Allow Mock Locations & Unknown Sources...
    -Download "z4root" from the Market...
    -Open the app, click the 'root' button...

    You are done! After some seconds the phone will restart on it's own & yay! It's rooted! :D

    ***z4root has been removed from Market, check post #12 for apk***
     

    Advertisement

    drvicked, Gebiet, kikislater and 21 others like this.
  2. ravv

    ravv New Member
    5

    Nov 22, 2010
    1
    0
    5
    thanks! it works! quick, 1 click!
     
  3. Kostas

    Kostas Well-Known Member
    16

    Oct 21, 2008
    74
    2
    16
    It doesnt work for me. It says USB debugging mode must be activated even though it already is. Pretty frustrating
     
  4. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    Try this: Disable USB Debugging Mode, restart, enable USB debugging mode and then try to root again...
     
  5. Kostas

    Kostas Well-Known Member
    16

    Oct 21, 2008
    74
    2
    16
    Thanks i tried it after doing a factory data reset (because my phone was beginning to lag badly) and it worked but i thought i can just go ahead and uninstall preinstalled apps but apparently i cant so i dont seem to have a use for it! Thanks anyway
     
    nikolas_dot likes this.
  6. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    Download "Titanium Backup" from the market... You have to use that to get rid of those shits...
     
    nikolas_dot likes this.
  7. Rooferkev

    Rooferkev Well-Known Member
    43

    Nov 13, 2010
    245
    27
    43
    Male
    Should be easy to work out
    England
    Will rooting wipe anything from my phone?
     
  8. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
  9. Rooferkev

    Rooferkev Well-Known Member
    43

    Nov 13, 2010
    245
    27
    43
    Male
    Should be easy to work out
    England
    cant find z4root in the market
     
  10. nill0076

    nill0076 Active Member
    16

    Nov 25, 2010
    26
    1
    16
    Student
    Rajkot, Gujarat, India
    Z4root is in Chinese language. I don't know the Chinese language
     
  11. Rooferkev

    Rooferkev Well-Known Member
    43

    Nov 13, 2010
    245
    27
    43
    Male
    Should be easy to work out
    England
    well sod that then :)
     
  12. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    z4root has been removed from the Market.. here's the apk from my system... hope it'll work. btw, this one is english... :D
     

    Attached Files:

  13. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    Hi Nirob..

    Before I try this, can you please let me know what the benifits are if I was to root my phone... I think it will allow me to install apps on my SD card is this correct? and if so it that all I need to do or will I have to download another app to do the SD card install? As you mighjt guess I'm new to this so any info you can give me will be a great help.

    Also how do you Enable USB Debugging Mode...

    Thanks, ACD1055
     
    mayooresan and nikolas_dot like this.
  14. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    Hi! Welcome to the forum! :D

    By rooting, you can remove the bloatware that carriers put inside(Use Titanium Backup, available in the Market), modify your system, replace/remove system apps, change bootanimation etc. Some apps need root access also...

    Yes, you need to be rooted & install apps2sd(check here: 1click app2sd now includes 1 click root - Android @ MoDaCo for instructions & solution to problems) to install apps in SD...

    To enable USB Debugging Mode, go to Settings>Applications>Developement and tick USB Dubugging Mode, untick to disable...

    Don't hasitate to ask for help if you need, we'll try our best to help.. :D
     
  15. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    THANKS..

    I have just looked at the thread you kindly posted. am I correct in thinking that all software I need is in the zip file to root and app2sd? It looks like I need to make files and change the size of the SD card to FAT32 do I need software of this? your post mentions Titanium Backup whats this?

    I only have a 2GB card (it came with the phone) is this ok to root and app2sd?

    I tried to download the user guide from the link but I have to register so I'll do that later (in work at the min)

    Thanks again
     
  16. Rooferkev

    Rooferkev Well-Known Member
    43

    Nov 13, 2010
    245
    27
    43
    Male
    Should be easy to work out
    England
    Thanks for the link Nirob

    thing is when i try to root it asks me to enable usb debugging mode when i have already got it on, any ideas?
     
  17. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    Ok. I have set up my SD card to FAT32 etc following the how to guide and minitool but now I'm stuck..
    I've downloaded the autoroot app2sd file and double clicked the batch file selected 2 for english and them there is a big list;

    r. root the phone
    u. unroot the phone
    1 standard app2sd data
    2 standard app2sd cache
    3 standard app2sd appdata
    4 full app2sd
    5 remove
    6 quite and restart the phone
    7 back to language
    8 check app2sdapp2sd
    9 exit

    which do I pick, I want to root and start saving to my sd card. so is it R to root?? and then 4 for the app2sd???

    once I have done this should I see a new app on my phone so i know it's worked?
     
  18. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    Untick USB Debugging mode.. then restart... Now, Tick Unknown Sources, USB Debugging Mode, and Allow Mock Location... now try if it works...
     
  19. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    I recommend z4root to root GT540, i saw some guys having trouble rooting with the "r" option... After you have rooted, 4 for installing apps2sd & then 6 to restart your phone... if it installed correctly you'll see the option "Apps2SD" in Settings>Applications

    Keep in mind that you can't remove your SD card after installing apps2sd.. if you remove it, or error occurs related to SD card, then you are screwed...
     
  20. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    Where can I find z4root, do you know? I did try to click on the file you attached but it said no application found and I have searched the market place without luck.

    Do I need to root my phone to run app2sd? I
     
  21. Nirob

    Nirob Well-Known Member
    93

    Sep 13, 2010
    539
    167
    93
    Planet Earth
    I think androidforums.com is having problems... i was starting a thread, tried to upload an apk but failed 3times... Google removed z4root from the market.. sorry, i don't know where you can download z4root.. i installed it when it was in Market, and the apk i uploaded is from my system...

    Yes, you have to root your device to install apps2sd... you can't install apps2sd if you are not rooted...

    I mentioned above what you can do when you are rooted... It's gives you full access to your system... You can modify you system, remove carrier crapwares, remove system apps, replace system apps with newer versions etc.. Apps like Root Explorer, Titanium Backup, Apps2SD requires root...

    I think you'll need to tick the "Apps2SD" options in Settings>Applications... if it's ticked then don't need to do anything...
     
  22. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    Cheers for the reply.

    I guess I'll have to search for z4root and install this then.

    I have done a google search and it returns hits but I'm always a little worried about downloading from unknown sites.
     
  23. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    [FONT=&quot]I can’t find z4root anywhere, well anywhere I think it’s safe to download from so I think I’ll try the option for rooting above by selecting R in the auotroot app2sd file .. How will I know if my phone has been rooted, will a new app show anywhere or do I need to download another app afterwords to explore and control my phone, if so which app should I download?[/FONT]

    [FONT=&quot]When you say once it’s been done don’t remove your SD card or your screwed.. what will happen will I break my phone or the SD card? if I wanted to remove the sd card for any reason would just need ot unroot the phone and then it would be safe?
    [/FONT]
     
  24. ACD1055

    ACD1055 Active Member
    16

    Dec 6, 2010
    25
    3
    16
    Hi,I think I have rooted my phone as I now have the superuser icon.. not sure what to do with it but it's there.. I'm having trouble installing the app2sd as each time I do it my phone won't work it keeps coming up with error messages and saying foce stop.

    any ideas,I really want to be able to save to my sd card.
     
  25. Rooferkev

    Rooferkev Well-Known Member
    43

    Nov 13, 2010
    245
    27
    43
    Male
    Should be easy to work out
    England
    All done and rooted now so managed to get rid of lot of bloatware and apps i dont need, used titanium backup to do it which is simple enough. Just wondering what else i can now do as i cant seem to find how to change boot screen and other little bits like that, do i need more root apps to mess with it more?


    Thanks for help again nirod
     

Share This Page

Loading...