1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Easiest way to root GT540 running 2.1! Now EVERYONE can root!


Last Updated:

  1. OscarOwen

    OscarOwen Member

    Joined:
    Dec 4, 2010
    Messages:
    14
    Likes Received:
    0
    Hey what's the advantages of rooting my GT540? Thanks :D
     

    Advertisement
  2. babazade

    babazade New Member

    Joined:
    Mar 19, 2011
    Messages:
    4
    Likes Received:
    0
    hi
    ı have problem buying any app from market because of turkey is not exsist...how can ı solve this problem

    thx
     
  3. YouTu_01

    YouTu_01 Well-Known Member

    Joined:
    Feb 19, 2011
    Messages:
    286
    Likes Received:
    40
    you can install, ROMs, apps that need root access, like Titanium Backup , SetCPU,Swapper, you can uninstall carriers bloatware,etc.


    you mean, you can't access the android market from turkey?, or the app, isn't available to buy?
     
  4. meman

    meman New Member

    Joined:
    Mar 27, 2011
    Messages:
    1
    Likes Received:
    0
    what files do you go in to get the root
     
  5. YouTu_01

    YouTu_01 Well-Known Member

    Joined:
    Feb 19, 2011
    Messages:
    286
    Likes Received:
    40
    you only need the z4root apk install it, run it., and let it do it's thing.
     
  6. jeff.webb

    jeff.webb Member

    Joined:
    Apr 1, 2011
    Messages:
    8
    Likes Received:
    0
    First post from an old guy who has read loads but is struggling a bit with all this so please be kind ;)
    I have a GT540 which I intend to root using your instructions. I have a 8gb class 6 sd card. Should I make two partitions on it as described, or just one? What are the advantages of saving apps to the sd card? Thanks for any advice,
    Regards, Jeff.
     
  7. Nirob

    Nirob Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    Do exactly as it's described... GT540's internal memory is very low, so you can't install many apps...

    If you are not concerned about voiding warranty, I recommend you update to 2.3... Because, Apps2SD may cause fatal problems...
     
    cookies and jeff.webb like this.
  8. jeff.webb

    jeff.webb Member

    Joined:
    Apr 1, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks for the speedy reply. Where is a safe place to get 2.3? Is it easy to install? Sorry to be a pain. Regards, Jeff.
     
  9. Nirob

    Nirob Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    Here's what you are looking for: CyanogenMod 7/Android 2.3 Is avaliable for GT540! - Follow the steps carefully... It's quite easy... If you don't understand a point or Facing a problem, ask in that thread & we'll try to help... Just don't hesitate to ask! :)

    Glad to help!!! :D :D :D
     
    cookies and jeff.webb like this.
  10. jeff.webb

    jeff.webb Member

    Joined:
    Apr 1, 2011
    Messages:
    8
    Likes Received:
    0
    OK. The old fellah is rooted but still in 2.1.
    A couple of questions if i may.
    New 8Gb SD card should be here tomorrow.
    I will partition with a swap partition just in case.
    Which should I do first, upgrade to 2.3 or sort SD card?
    Can I just copy files from old card to new?
    I have not backed anything up yet. Not bothered about contacts,I have them on another phone.
    Regards and apologies, Jeff.
     
  11. Nirob

    Nirob Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    In 2.3 you don't need to partition your SD... Just Copy the old SD contents to the new one & put it on your phone... Do it when you want to...
     
    jeff.webb likes this.
  12. jeff.webb

    jeff.webb Member

    Joined:
    Apr 1, 2011
    Messages:
    8
    Likes Received:
    0
    Just a quick thanks to all concerned. 2.3 installed. Everything ok. :D:D
    Regards, Jeff.
     
  13. Nirob

    Nirob Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    Enjoy!! :D
     
  14. Facyber

    Facyber New Member

    Joined:
    Apr 5, 2011
    Messages:
    1
    Likes Received:
    1
    Guys im having a problem...I turn on debug,connect phone with laptop,opet Astro file manager,instal z4root that is puted in #12,go on Perem root and it after 10 sec show me Aquare shell and after minut it turn back to astro manager without any message or anything,everything is the same.what should i do? :(
     
    cookies likes this.
  15. YouTu_01

    YouTu_01 Well-Known Member

    Joined:
    Feb 19, 2011
    Messages:
    286
    Likes Received:
    40
    Try agian and again until it says, ROOTED.
     
  16. jvukosav

    jvukosav New Member

    Joined:
    Apr 7, 2011
    Messages:
    2
    Likes Received:
    0
    i had the same problem but it seems i created the partition as ext3 instead of ext2 thus i had no application in my app list...just delete and create the partition again and your problem will be solved... hope it helps
     
  17. jvukosav

    jvukosav New Member

    Joined:
    Apr 7, 2011
    Messages:
    2
    Likes Received:
    0
    hey guys...i might seem as an idiot but my problem isn't that solved..


    ANYWAYS.. i installed app2sd, but when i start reboot my phone it takes ages and than finally it's written :process system isn't possible yadayada anyways i dont have the app in my app drawer and i dont know what to do... did everything as instructed.. multiple tries.
     
  18. YouTu_01

    YouTu_01 Well-Known Member

    Joined:
    Feb 19, 2011
    Messages:
    286
    Likes Received:
    40
    Probably, app2sd not working like it should , consider upgrading to 2.3, to get rid of these issues.
     
  19. S2580

    S2580 Member

    Joined:
    Apr 12, 2011
    Messages:
    10
    Likes Received:
    0
    hi. I'm properly new to all this. i have downloaded z4 already. but I'm not sure what to do next. is there anything else i should do before apart from the usb debugging and such.

    also what should i do afterwards apart from removing the useless apps.
    Any help will be more than appreciated
     
  20. Nirob

    Nirob Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    Just follow the steps & Do a "Permanent Root"...

    About removing apps, be cautious while doing it... Don't remove critical system apps... If you want to remove an app but not sure what it is, you can ask here & we'll try to help... Besides removing apps, you can do a lot of things... Just wonder around the forum... It's the first step to install custom ROMs, some apps need root access & if you want to do some modification you need root access... :D

    If you need further help, don't hesitate to ask! :D :D :D Enjoy GT540! :p
     
    S2580 likes this.
  21. S2580

    S2580 Member

    Joined:
    Apr 12, 2011
    Messages:
    10
    Likes Received:
    0
    thanks for the advice. i rooted and uninstalled some apps no problem.

    any advice on what are some good things to do with my phone now?

    sorry I'm a bit of a noob!!
     
  22. Nirob

    Nirob Well-Known Member This Topic's Starter

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    Now just spend some time with your phone, browse the forum & master the basics... Then, Install CyanogenMOD 7(This will void warranty)!!! :D:D:D:D
     
  23. punjabi1989

    punjabi1989 New Member

    Joined:
    Apr 17, 2011
    Messages:
    1
    Likes Received:
    0
    thanks a lot brother but 1 thing more my dictionary db file is formatted from sd card & i need it, wat can i do now ?????
     
  24. m2stech

    m2stech Member

    Joined:
    Mar 14, 2011
    Messages:
    11
    Likes Received:
    0
    So I rooted my phone using this topic and installed apps2sd using the method mentioned again in this topic but, I can't find any app2sd program to transfer my apps to SD and even tried installing a new app but it went into internal memory!!! what's the problem and how can I use app2sd on my rooted phone?
     
  25. DME43

    DME43 Member

    Joined:
    Apr 23, 2011
    Messages:
    8
    Likes Received:
    0
    Hiya, beginner/noob here. I rooted sucessfully with z4root, but after so I'm wondering how this has benefited me as I dont see any changes to anything in the menu or settings.

    I also installed busybox but its the same with that. all I'm looking to do is access the hardware of the phone such as the cpu/gpu etc

    thanks
     

Share This Page

Loading...