Easy Phone Sync - Stuck on "Preparing to Sync"Support


  1. rkdku

    rkdku Member

    Hi guys

    OPERATING SYSTEM: MAC OS X LION/MOUNTAIN LION
    PHONE: SAMSUNG GALAXY S3 RUNNING JELLY BEAN (ANDROID)

    I'm new to this forum and basically the entire Android world, so forgive me if this thread is in the wrong place etc. :)

    So basically, I'm an ex-iOS user who enjoyed the ease-of-use of iTunes before making the switch to an S3. Right now, it's a little frustrating to see the lack of a single solid program that can basically do everything iTunes did, but for Android.

    Wanting to transfer my iTunes library to my S3, I browsed for a bit and subsequently installed Easy Phone Sync both on my Macbook (OS X Lion 10.7.2) and my S3. Syncing worked like a charm.

    But then, over christmas I got the new iMac (like, the super-thin one) running Mountain Lion 10.8.2. The switch was pretty harmless, until I installed Easy Phone Sync on this new iMac and the problems started.

    Easy Phone Sync recognises my S3 when I connect to it, and everything is fine until I actually hit "Synchronize". Then it becomes stuck on the "Preparing to synchronize" display with that blue/white bar of death continuously running.
    I've tried basically everything; reinstalls, reboots, etc. Nothing works. The problem is consistent whether I set it to sync to my internal phone storage or my external SD card.

    I have Android File Transfer downloaded. That works. Kies is pretty buggy - but downloading that would make me sacrifice AFT (the two apparently cannot coexist and work together). Easy Phone TUNES does the exact same thing as Easy Phone SYNC. DoubleTwist doesn't have USB support for the S3.

    Please, any solutions/help would be GREATLY, GREATLY appreciated.

    Many thanks in advance.

    Advertisement
    :
  2. rkdku

    rkdku Member

  3. rkdku

    rkdku Member

    bump... please... anyone?
Loading...

Share This Page