Easy Way to Hookup Incredible to PC?Support


Last Updated:

  1. Trooper

    Trooper Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Hi guys,

    Ive done some searches and nothing seems to work. Some folks say you need HTC Sync, others the Android SDK.

    What happens on my machine is I get two devices in Windows Explorer saying removable disk. However if I click on them, it thinks its a CD or DVD by asking please insert a disk.

    I just need to copy a few files over, and for security reasons I don't want to email them to myself.

    Any help would be appreciated!

    P.S. Im running Windows 7 Ultimate x64 if that makes a difference.

    Thanks!
     

    Advertisement
  2. waynester

    waynester Well-Known Member

    Joined:
    Oct 11, 2008
    Messages:
    677
    Likes Received:
    65
    settings>connect to pc>connection type>disc drive

    you will still get them listed as disc drives, like so...

    [​IMG]

    Uploaded with ImageShack.us
     
  3. Lefort1

    Lefort1 Well-Known Member

    Joined:
    Apr 23, 2010
    Messages:
    266
    Likes Received:
    26
    Choose the option to "Mount the phone" as a disk drive.

    Two options popup because one (usually the first) is the Incredible's onboard memory and the other is your SD card in the phone. Drag and drop, you're done!
     
  4. Trooper

    Trooper Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Two things.

    1. I get what shows up in the pic. But if u read my post when I click on them its acting like a dvd drive.

    2. No options pop up when I connect it. I went to connect my pc and set it to disk drive manually. Still no go
     
  5. jgill

    jgill Active Member

    Joined:
    May 18, 2010
    Messages:
    27
    Likes Received:
    17
    right click the phone drives and click explore
     
  6. Reddog80p

    Reddog80p Well-Known Member

    Joined:
    Dec 23, 2009
    Messages:
    334
    Likes Received:
    39
    When you connect your DI to the pc you should get 2 popups showing the removable drives. Under each one they should have some options. Select the option that says open to display files or something like that.

    try to reset autoplay...

    There is an individual AutoPlay enable / disable setting for every type of Windows 7 media or device. Here is where you configure the default settings for each media.

    Click on the Start 'Orb', Control Panel, Hardware and Sound, AutoPlay.

    Try selecting "ask me everytime"
     
  7. Musky

    Musky Well-Known Member

    Joined:
    Mar 13, 2010
    Messages:
    1,830
    Likes Received:
    369
    You need to go into "Settings" then "Applications" and then "Development" and make sure that USB Debugging" is checked.

    Then rebooting the phone is sometimes needed.
     
  8. waynester

    waynester Well-Known Member

    Joined:
    Oct 11, 2008
    Messages:
    677
    Likes Received:
    65
    Not sure then, I'm using win 7 pro 64 bit, I double left click on L or M with the bar graphs (phone and SD card)
    and they open with all my files listed

    *oops, yes i have debugging checked, also unplug phone usb and and reconnect to pc
     
  9. kayst

    kayst Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    432
    Likes Received:
    63
    I have sort of the same problem. For some reason, every time I connect my Incredible to the PC, only the SDcard shows up. The /emmc card is there, there is a disk drive for it, but the label I assigned it doesn't show up and I can't access it.

    I've solved this problem by setting the default connection to be charge only. After I connect, I pull down the notification bar, press on the notice about charge only, and change the connection type to disk drive (be sure and press confirm, or select or whatever it says at the bottom). This time the emmc works properly on the PC.

    I have to do this every time I connect to make it work. Maybe it'll work for you too.
     
  10. MonsterMaxx

    MonsterMaxx Well-Known Member

    Joined:
    Apr 9, 2010
    Messages:
    49
    Likes Received:
    6
    When you connect, you should also get a popup on the phone. You need to choose 'disk drive' and 'done'.

    then you'll have full access to both device and card.
     
  11. kyle1745

    kyle1745 Well-Known Member

    Joined:
    Feb 12, 2010
    Messages:
    118
    Likes Received:
    3
    The app you need is on the root of the drive when you connect the phone. After that you can follow the info on the phone to pick how you want the phone to address the connection.
     
  12. Trooper

    Trooper Well-Known Member This Topic's Starter

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Just wanted to say thanks to everyone. After trying all of the above, rebooting the pc as well as the phone, I was finally able to get it to connect!

    Thanks so much!!
     
  13. linusvpelt

    linusvpelt New Member

    Joined:
    Sep 8, 2010
    Messages:
    3
    Likes Received:
    0
    I have had an issue several times now with my Incredible [ha] and it seems to have resolve itself on its own several times before but now it isn't. I was previously able to see both drives and move files back and forth. Now when I connect via USB it is as if the computer cannot reconcile the device it finds it,then looses it and just keeps cycling over and over. In Device Manager I noticed that it is trying to attach the "HTC Android Phone' as a DVD/ CDRom drive, there is also a device entry for 'Android USB Devices", and two 'Storage Volumes" The device manager window blinks on and off like a slot machine on payout. My PDANet registers that is sees the device then looses it. In Opera I was getting where a new VCast window would pop up everytime it went on and off but now that seems to have gone away. I am very frustrated. It did this to me last two weeks ago on Friday but when i came into work on Monday morning and plugged in everything went swell, without doing jack to the phone or computer. I do have 'USB debugging' enabled. I cannot even attach the device in 'Charge only' mode. I am thinking I should have stayed with my Blackberry. I have tried rebooting both the phone and the computer. Any helpful ideas?
     

Share This Page

Loading...