Support echo o o o o o

Discussion in 'Android Devices' started by stubey, Oct 13, 2012.

  1. stubey

    stubey New Member
    5

    Jul 10, 2011
    2
    0
    5
    Just got a Rugby for my father, whenever I call him I can hear my own voice echoing when I talk to him. He can't hear the echo on his end. It doesn't matter which phone I use to call the Rugby phone, the callers voice echos. Any help would be appreciated

    Thanks.
     

    Advertisement
  2. dtxzookeeper

    dtxzookeeper New Member
    5

    Oct 14, 2012
    1
    0
    5
    Just had the same problem, you have to return the phone for a replacement.
     
  3. kemonine96

    kemonine96 Well-Known Member
    18

    May 17, 2012
    76
    24
    18
    When you received the replacement did the echo stop?
     
  4. canyonfvr

    canyonfvr Well-Known Member
    26

    Mar 20, 2012
    80
    2
    26
    Under settings /call you will see additional settings there then check noise surpression it should get rid of the echo. But beware when you use a hands free bluetooth the setting gets un checked upou have to recheck it
     
  5. kemonine96

    kemonine96 Well-Known Member
    18

    May 17, 2012
    76
    24
    18
    I took care of some of this in my Cyanogenmod 9 build under the Phone App -> Settings -> Noise Suppression. If you leave the checkbox off the echo seems to go away even if you flip between headset and bluetooth.

    I noticed the stock ROM includes this set in Device Settings -> Call -> Additional Settings as you point out. Not sure on the full behavior of stock though. I used the echo problem as an excuse to get Cyanogen 9 going for the Rugby Smart.
     
  6. Hapuna

    Hapuna New Member
    5

    Mar 22, 2013
    2
    0
    5
    I bought this phone after doing extensive online research for a rugged phone. Seems some have this echo issue while others claims it's great. I've had the phone for 3 weeks now and I hate the call quality! A phone should be a phone first! My first 3 calls were met with "what in the world is that echo"! As an audio communication device it is a fail. I'm trying to find apps or ways to improve the call quality, but am coming up empty handed and I am too much of a newbie to root and do a different ROM. Any suggestions folks? I've tried the noise suppression setting off and on during same call, doesn't seem to help. I also deleted the cache for logs I believe in recovery mode, as I read it may help. It didn't.... I use a StraightTalk AT&T SIM. I'm disappointed and could use some solid advice.... If rooting can be proven to solve this issue I'd be willing to try it.. I think MotorHead was talking about version 9 addressing this exact issue... Help... I'm sad.. In retrospect I feel like I should have just ponied up for the Sony Xperia Acro S and been done with it.... Thanks in advance and have a great day!
     
  7. Motorhead1991

    Motorhead1991 Well-Known Member
    103

    Mar 7, 2012
    831
    133
    103
    Student, Clearfield Job Corps, Diesel program
    Pasco, WA

    As seen here, it was KemoNine that mentioned it, not I :p
    I am still directly and actively involved with this device though
     
  8. Hapuna

    Hapuna New Member
    5

    Mar 22, 2013
    2
    0
    5
    My mistake Motorhead it was Kemonine....

    Going to try and return it from vendor and get something different, no rhyme or reason to when the echo happens and it is frustrating.... IMHO... call audio quality should be first and foremost on a cell "phone"... Love everything else about the phone though.. :)
     
  9. rileyluke

    rileyluke Member
    16

    Jul 25, 2013
    15
    1
    16
    is there a fix for this yet?
     
  10. canyonfvr

    canyonfvr Well-Known Member
    26

    Mar 20, 2012
    80
    2
    26
    Did you try checking the noise suppression box?
     

Share This Page

Loading...