EDGE network problems?Support


Last Updated:

  1. That Deaf Guy

    That Deaf Guy Member This Topic's Starter

    Joined:
    Oct 13, 2008
    Messages:
    12
    Likes Received:
    0
    I got my g1 phone yesterday but was unable to activate it until this morning. From what I see, the g1 doesn't really hold the Edge network signal too strong? I live in Lafayette, Louisiana which is only Edge network right now. (the closest 3g network is in Houston, Texas)

    I really hope this network problem is only temporary problem with the launching of the g1s. Right now, I am only on my WiFi connection which I can't receive or send texts since it is not a "UMA" connection.

    Any ideas on why the Edge Network isn't working to great with the G1?

    Should I wait few days or call T-mobile to address this problem?
     

    Advertisement
  2. Windchill

    Windchill Well-Known Member

    Joined:
    Oct 21, 2008
    Messages:
    110
    Likes Received:
    5
    I am not sure why its not holding the edge network for you. I would call the tmo tech support and see what they have to say about it. As someone who always buys the newest phones when they come out, I know its possible for a bad apple to slip thru every once in awhile. I am not saying that is your case, I am just saying its possible. Especially when you think of the volume we are talking about.

    If you do call tmo, please let us know what they say. This may help someone else out who comes across this problem.
     

Share This Page

Loading...