1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Email Alert ProblemGeneral


  1. iPhandroid

    iPhandroid Member

    Just picked up a Galaxy Nexus (my first Android...not counting the unfortunate accident I had with a Note 2 last week) and have set it up with Jellybean 4.1.2 Yakju. (I've also installed the 4.2 apk for the new clock, in case that matters.)

    Problem:
    I'm using two email client apps. EMAIL for my work (Exchange) account, and GMAIL for my personal Gmail account. I went into each app and set it so that notification sounds are set to silent, and no vibrate.

    When I receive an email from Gmail, it shows up in the notification bar without making a sound. That's just how I want it.

    When I receive an email from my work account, it shows up in the notification bar but it also sounds an alert. Not what I want; I want it to be silent!

    Interesting notes:
    1) If I completely turn off notification for EMAIL, then when I receive an email, it will not show anything in the notification bar...but the alert sound will still occur!
    2) If I change the EMAIL notification from silent to some other ringtone, when I receive an email, I will hear that newly selected ringtone...AND then I'll also hear the same ringtone that it has been making all along.

    This is driving me crazy, because a few hours after midnight, the server from work emails me logs from a variety of processes which results in a series of alerts, meaning that I can't leave the phone by my bed.

    Can anyone help me out? If I can't figure out the root cause, I'll have to try to mask it by installing some kind of Tasker-type app that disables EMAIL syncing overnight.

    Thanks in advance for any responses.

    Advertisement
    :
  2. iowabowtech

    iowabowtech root@android:/ # Moderator

    I think there might be a couple ways to skin this cat. Instead of disabling the email alert altogether, how about choosing the ringtone lableled "silent". Hopefully you have that, I'm on a custom rom but I'm assuming it's a stock option also. It's located right under "default ringtone" in the list of availables.

    If all your trying to do is stop the notifications at night, I very highly recommend the app Sound Profile. It has an option for calls only during whatever hours you choose so you can still get phone calls if desired, but not notifications. That app has been a life saver for me because I'm in that same boat and most sound management apps don't work right on Jellybean but this one does.
  3. iPhandroid

    iPhandroid Member

    Thanks, already tried that. Ringtone is set to "silent."

    Thanks for the suggestion. I found out some more info about this problem.

    If I delete my work account from the EMAIL app, so that I can't even check my work email, it STILL makes that alert sound when my work email account gets an email! Weird.

    So I re-installed my work email account and during the install, it said that my work account also requires administrator access to some other stuff. I think that might have something to do with the problem, and may have placed some other settings onto my phone which removing my work account didn't also remove. Anyway, I am going to wipe my phone and re-install everything from scratch, but will NOT set up an account for my work's Exchange server. I'll see if that solves the problem or not.
  4. iPhandroid

    iPhandroid Member

    Weird: I wiped all the data off my phone. When I set it up anew, I told it NOT to restore from my Google backup. When I ran the EMAIL app for the first time, it did not have any accounts, so that was good. The GMAIL app had my Gmail account, of course.

    When I sent an email to my work account, it STILL made that damned alert noise!

    I also tried using the Sound Profile app but that couldn't stop the sound from happening, either. Even with all volumes turned off, that alert still kept happening.

    Next, I set up my work account again in the EMAIL app. I set it to check emails every hours, rather than using push. But as soon as I sent an email to my work account, that alert sound triggered again, but there was no notification icon in the notification area. This is so weird.

    I looked at my Gmail account and don't see any tie-in between my Gmail account and my work account. I can't figure this out.

    Anyone got any ideas????
  5. llasris

    llasris Member

    Just fixed that problem in my GS2. The phone thinks you are in your car. Turn off driving mode in the Speech menu under "text-to speech."
  6. iPhandroid

    iPhandroid Member

    Thanks, I'll give that a try. I kind of resolved the problem by buying a Note 2 ;) but I'll start up my Galaxy Nexus tonight just to see if I had that option turned on.
  7. Juliansdad

    Juliansdad Member

    I tried all of the above measures with my Samsung Note II and I'm still running into the same problem. Grrrrrrrrr.......
  8. iPhandroid

    iPhandroid Member

    I never had that problem with my Note 2...are you using Gmail or the Touchwiz email client? I'm using the Touchwiz (or Samsung) client.
  9. Juliansdad

    Juliansdad Member

    I'm using the Gmail email client that came installed as an App in the Verizon version of the phone. I'm an Android veteran and never had this problem with other versions.

    Perhaps the problem will go away if rather than using gmail's app, I use the standard email program that comes installed in the phone and install gmail within that. Is that what you're suggesting?
  10. iPhandroid

    iPhandroid Member

    Yeah, give the stock email client a try, and connect to your Gmail account using it, INSTEAD of the Gmail email client app.

    I'm using the stock email client to connect to a Zimbra and a Gmail account and haven't had that alert noise problem.

    Unfortunately, I forget what combo I was using with my Galaxy Nexus when I had that alert problem (I have since reset that phone back to stock). I know I was using Gmail AND the stock email client, but can't recall what combinations I tried.
    Juliansdad likes this.
Loading...

Share This Page