Email app - don't want to sync with server


  1. billrosenblatt

    billrosenblatt Active Member

    I just got the Samsung Galaxy S3 (running Ice Cream Sandwich). Fantastic device, but one thing about the stock email app bugs me. I have a POP email server and use Outlook on my PC. Outlook downloads email to my PC and deletes it from the server.

    The stock email app on the S3 insists on syncing with my email server. This means that whenever messages are downloaded into Outlook, they disappear from my handset. On my previous device (Moto Droid 2, Gingerbread), the email worked "the old-fashioned way," i.e. just downloaded messages from the email server and kept them on the device for N weeks (whatever I set N to).

    I see no way to change this on the S3's stock email app. Not sure if this is a stock ICS email app or if it's Samsung's. Anyway, I would appreciate any tips on whether this is fixable in the existing app or if there are other email apps available that will do it the way I want.

    BTW, it is not possible to configure the email server to keep messages for N weeks and then delete them itself.

    Thanks for any help!!

    Advertisement
  2. Harry D

    Harry D New Member

    On my Galaxy S Plus, I've got my email app configured to:
    - retrieve the emails
    - do not synchronise (as this deletes any removed messages)
    - do not delete from server (as other applications also need access)

    On my laptop, I've then got my Windows Live mail account configured to:
    - retrieve the email
    - delete retrieved email after 5 days.


    This allows all my devices to get the mail in & it only get's in the 5 day queue for deletion after the laptop has had it's chance to get the mail.


    Hope this helps: I trust, you'd be able to make the same phone settings on your S3 & in Outlook?

    Cheers,

    Harry D.
    Crashdamage likes this.
  3. dvhttn

    dvhttn Well-Known Member

    I use the same setup. Outlook is set to 'download emails and delete from server' (or whatever the actual command is ... ) and my phone (using K-9 at the moment but also worked with the stock HTC email app) is set to 'sync server deletions' (so if Outlook has them on my desktop, the phone copy gets deleted - just 'cos that's the way I work 'at the moment') and to 'not delete message on server if deleted on phone' ('cos I want ALL my messages to get to my desktop - I also have a 'bcc myself' set on all sent messages from my phone).

    To do what you want I'd just 'un-tick' the 'sync server deletions' box.

    HTH

    Dave
  4. billrosenblatt

    billrosenblatt Active Member

    Thanks but unfortunately this does not help. The S3's email app does not have a "do not sync" option. The only sync option is "period to sync email" (1 week, 2 weeks, 1 month, 1 month or 100 emails). I have it set to 1 month but it syncs regularly anyway.
  5. Harry D

    Harry D New Member

    In that case, you may want to have a look at the K9 email app - it's the one I'm also using. It just seems to have a little more configuration options that the stock apps (although the stock app on my S Plus did allow the above described function)..

    By the way, to use the "zooming" function in K9, you'd need to activate it in the configuration menu's - it appears to be switched off by default. Just in case you'd decide to give it a go. ;)
  6. dvhttn

    dvhttn Well-Known Member

    Don't have the S3 but it sounds to me as if you're confusing the 'period over which to sync emails' with 'how often do you want to sync the phone with your server'. It really is a shame that most apps are written by IT folk who have no clue about how to put things into plain English, or Russian, or Spanish, or .... you get the idea ...) ..... :mad:

    Oh, nearly forgot. I've just loaded a custom ICS ROM onto my Desire HD and found that you need to choose 'yourusername@gmail.com' as the contacts and calendar to sync, rather than as it was under Android 2.x, the 'phone' contacts/calendar.

    Dave
  7. billrosenblatt

    billrosenblatt Active Member

    OK, well, I tried a few apps including K-9 and MailDroid, and found things about both that I didn't like. So I went back to the stock email client.

    Then I found an option in Outlook that lets me do what I want: it can be set to leave messages on the server and delete those that are more than N days old. I turned this on and set it to 30. This means that when my S3 syncs with the server, it will get up to a month's worth of emails, or more if I don't use my PC for more than a month -- which has never happened, not even close, but with the excellence of the S3 I can see using my PC less and less...
    erniez likes this.
  8. philcheung1847

    philcheung1847 New Member

    I have the same problem with my S3 and outlook which was not there with my old HTC Desire HD. Guess I will have to revert back to your method of leaving mail in the server for an x period of time to overcome this problem. I am a little luckier in the sense that I have my domain to send a copy to hotmail at the same time and the mail seems to stay in hotmail so I can see access previous email with S3 after opening them in outlook.
  9. erniez

    erniez New Member

    I had the same problem. This post was perfect for my help. I registered just to say thanks!

Share This Page