Email inbox showing junk email


Last Updated:

  1. CiudadDuerpo

    CiudadDuerpo New Member

    I have my work email running through the stock email app using an exchange server. I use Outlook at work, and it does a pretty good job of sending junk email to the junk folder. However, on the email app on my phone, all incoming mail is sent to one inbox. I don't want my INBOX.junk to show in my main inbox. I keep getting notifications saying I have new mail, but it's just spam.

    I've tried messing with the settings of the app and looking in the folders, but can't figure out how to set up a filter so only non-spam gets sent to the inbox and the spam is filtered to its own junk folder. I've been Googling this for about 30 min with no solution either.

    I have an htc EVO running Cyanogenmod 7. I use the Gmail app for my personal email, and would prefer not to route my work email through Gmail for this. Thanks for any suggestions.

    Advertisement

Share This Page