Email not updatingSupport


Last Updated:

  1. OhOneWS6

    OhOneWS6 Well-Known Member

    I have 4 email accounts set up on my evo 3d. 2 yahoo, 1 pop3, 1 exchange. Non of the accounts update unless I actually go into the mail app. The unread message count on the icon never changes unless I open the app. I am using the stock mail app that came on the device. I have all accounts set to poll mail every 15 minutes. Any suggestions?

    Advertisement
  2. desserted

    desserted New Member

    Do you have background data or auto-sync turned off? You can check those under Settings -> Accounts & Sync
  3. OhOneWS6

    OhOneWS6 Well-Known Member

    Both are turned on.
  4. marctronixx

    marctronixx Moderator Moderator

    once you set these up did this issue start form the beginning or did it happen later after the accounts were setup?

    did you remove the account(s) and re install? have you checked your off peak and peak times? did you change the "Fetch" times? you say 15 minutes, what about every hour? etc?
  5. OhOneWS6

    OhOneWS6 Well-Known Member

    After the initial issue with Yahoo accounts the mail seemed to work correctly. I just noticed this issue a couple of days ago. I had a client send me an email at noon. When I didn't reply they called at 5:00 PM to see why. I went into the mail app at that point and a few seconds later the mail populated. The email was there with a 12:15 time stamp and then the icon updated with the proper unread mail count. I have paid closer attention the last couple of days and it never updates unless I manually go into the mail app. I have deleted and re configured the yahoo accounts but not all the accounts. I will try changing the fetch time and see if it changes.

    EDIT: My wife just informed me she has the same issue. She only checks one Yahoo account.
  6. marctronixx

    marctronixx Moderator Moderator

    remove the battery for one minute and re-install.
  7. OhOneWS6

    OhOneWS6 Well-Known Member

    Peak is set 8 AM to 8 PM. Peak is set to fetch every 30 min. Off peak every 4 hours. It was only the exchange account that was set to 30 minutes.

    EDIT: I just changed peak to end at 10:00 PM and set all accounts including exchange to fetch every 30 min on peak and every 4 hrs off peak. I'll update with the results tomorrow.
  8. marctronixx

    marctronixx Moderator Moderator

    look in accounts and sync. do you see the green circle? should not be grey. also should not be any (!) marks either.

    perhaps clear cache in the mail account also.
  9. OhOneWS6

    OhOneWS6 Well-Known Member

    All accounts are green circles. I will do a battery pull. How do you clear mail cache?
  10. marctronixx

    marctronixx Moderator Moderator

    lets leave yahoo accounts out of it since there is a known issue with them. see thread for reference: http://androidforums.com/htc-evo-3d/361016-help-cant-get-yahoo-account-set-up-evo-3d.html

    so lets just focus on your other POP accounts. if you have direct yahoo account issues, post in the above thread.

    clear the mail cache in the applications tab in the settings menu. you may have something hosed up in there.

    do you have any apps that could possibly take over the mail service? seems you had them working and then they just stopped?
  11. OhOneWS6

    OhOneWS6 Well-Known Member


    Cache = 0.00B Clear cache for the mail app is grayed out. The only other mail app I tried was K9 and it was uninstalled shortly after I installed it.
  12. OhOneWS6

    OhOneWS6 Well-Known Member

    Seems it is working correctly at the moment. Perhaps resetting the peak times or fetch frequency cleared it up. :dunno:
    marctronixx likes this.
  13. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    If it happens again, simply go back and clear the cache and the data, then you will have to log back in and see if that resolves it.


    marctronixx likes this.
  14. OhOneWS6

    OhOneWS6 Well-Known Member

    It did happen again. I'll try your suggestion.

    EDIT: Data = 4.46 MB for the Mail app but clear data is grayed out.
  15. marctronixx

    marctronixx Moderator Moderator

    is it running when the clear data is grayed out? if so force stop it. also can you clear cache?
  16. OhOneWS6

    OhOneWS6 Well-Known Member

    Just to make sure I am in the right place

    settings/applications/manage applications/all/mail

    It was running. I force quit and both clear data and clear cache are still grayed out after the force quit.

    EDIT: Did a battery pull as well. I will do a little more testing.

    Thanks for all the help.
    marctronixx likes this.
  17. chubbzdroid2

    chubbzdroid2 Member

    may I know where i can find these options, under settings>then? i cant seem to find these options to change peaks hours, manual updates etc . just switched from droid 2 to sprint evo 3d , sorry for the noob ?!
    semper fi
  18. ArmageddonX

    ArmageddonX Well-Known Member

    I have the opposite problem. I have automatic updates turned off on both my accounts and it still seems to retrieve new mail once a day.
  19. atg284

    atg284 Well-Known Member

    I have this problem as well. 2 yahoo accounts and one gmail. I do get yahoo mail now (after the major problem was fixed) but I do not get any of my email updated at the scheduled times I put it at. I have them set every 15 min with peak at 12:01 am - 11:59 pm. They only update when I go into them.

    I hope the peak time is not messing anything up :confused:
  20. chubbzdroid2

    chubbzdroid2 Member

    How did you customized your peak hours ?
  21. marctronixx

    marctronixx Moderator Moderator

    menu, more, settings.

    do the above when in the htc mail app. from there you have multiple options to customise your e-mail experience.. :)

    chubbzdroid2 likes this.
  22. atg284

    atg284 Well-Known Member

    Go into the default mail client -> menu button (bottom hard button) -> More (bottom right) -> settings -> send & receive -> update schedule -> peak time start/end
  23. chubbzdroid2

    chubbzdroid2 Member

    Thank u both ...i was so used to changing peak hours & manual updates from homeccreen menu then settings etc ...(motorola)
    marctronixx and atg284 like this.
  24. OhOneWS6

    OhOneWS6 Well-Known Member

    Just FYI, If you have multiple email accounts, each account can have a different schedule and peak off peak times. If you want them all to be the same you will need to change the settings for each account.
    atg284 and marctronixx like this.
  25. OhOneWS6

    OhOneWS6 Well-Known Member

    I still have the issue. It appears to only be my Yahoo accounts. I am a little confused as to why the fetch function would be any different when on a schedule VS manually fetching email. I'll report to Yahoo and see where it goes.
    marctronixx likes this.

Share This Page