1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Ematic Eglide XL Pro wont load


  1. ryan74

    ryan74 Member

    I couldnt find another place to post this.

    Tablet info:
    Ematic Eglide XL Pro internet tablet & HD video player
    10" screen & Android
    4gb built in flash
    Android 4.0 OS

    This is a friends tablet he bought without a charger so it Worked fine until low battery and it shut off. No charger so it sat for a month.

    I have a charger so I charged it overnight.
    Now With the charger connected it will turn on and flash Ematic splash screen for 1sec. and shut off.
    With the charger disconnected it will turn on, show Ematic splash screen for 5sec., then it goes black with flashing cursor in upper left corner for a few seconds, then black screen with the text 'Android_' about 1/3 down on screen. It stays here until I power off.

    I have tried a hard reset, wiped data, and even unplugged battery with no change.I am stuck at this point.
    Is there a fix for this?
    Do I need software/firmware and where do I get it?(Icant find it online)
    If my only choice is to root and install something else I need a simple guide on how to and the software/firmware.

    Advertisement
    :
  2. mikedt

    mikedt 你好 Guide

    I suspect the software ROM has become corrupted or damaged, given what you describe. Problem is Ematic is only an importer or destributor, which appears to be only contactable by anonymous webform only. Manufacturer is unknown. You'd need to get hold of the correct software ROM to be able to restore it. You probably won't be able to find it online, given that it comes from an unknown manufacturer.
    Ematic's webform for support is here...
    Support | Ematic
  3. ryan74

    ryan74 Member

    thank you for the prompt reply but I have already tried contacting support from your link with no results..I don't have proof of purchase so they closed my case. There only support is-replace it if under warranty with proof of purchase.

    Also-When connected to xppro it shows in my computer as 6 different drives labeled removable disc. If I try to access any of them it says insert disc. I agree it is probly a corrupt/damaged rom.
  4. ryan74

    ryan74 Member

  5. ufheatherd

    ufheatherd New Member

    I have the same issue and device as you EGLXP101P. Tablet was not charged for a while, recieved same issue while charging, same ANDROID_ when not on charge. I also tried factory reset but this did nothing as well. Has anyone found the software ROM for this yet? I found one but it looked to be for another model.
Loading...

Share This Page